summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-10-16 20:04:18 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-10-16 20:04:18 +0000
commit6adc4ec7107b90e6bd38a4e82faed587f0f49b52 (patch)
treec0480b47e65fff1ba10fce09d4cad002e9b5c2a6 /dev-lisp/cl-ptester/cl-ptester-2.1.1.ebuild
parentinitial import (diff)
downloadgentoo-2-6adc4ec7107b90e6bd38a4e82faed587f0f49b52.tar.gz
gentoo-2-6adc4ec7107b90e6bd38a4e82faed587f0f49b52.tar.bz2
gentoo-2-6adc4ec7107b90e6bd38a4e82faed587f0f49b52.zip
initial import
Diffstat (limited to 'dev-lisp/cl-ptester/cl-ptester-2.1.1.ebuild')
-rw-r--r--dev-lisp/cl-ptester/cl-ptester-2.1.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-lisp/cl-ptester/cl-ptester-2.1.1.ebuild b/dev-lisp/cl-ptester/cl-ptester-2.1.1.ebuild
new file mode 100644
index 000000000000..6ebe7fb46302
--- /dev/null
+++ b/dev-lisp/cl-ptester/cl-ptester-2.1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-ptester/cl-ptester-2.1.1.ebuild,v 1.1 2003/10/16 20:04:16 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="A Common Lisp test harness based on the Franz, Inc. tester module."
+HOMEPAGE="http://www.b9.com"
+SRC_URI="ftp://ftp.b9.com/ptester/ptester-${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=ptester
+
+S=${WORKDIR}/ptester-${PV}
+
+src_install() {
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ dohtml tester.html
+}
+
+pkg_preinst() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}
+
+pkg_postrm() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}