summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-06-10 04:54:06 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-06-10 04:54:06 +0000
commitf0499138e7aa5e43bdb88278d6bef3650c46e229 (patch)
treeb29a74bee14985fc7da4a51785f23c0829b3b5d5 /dev-lisp/cl-pg
parentinitial common lisp import (diff)
downloadgentoo-2-f0499138e7aa5e43bdb88278d6bef3650c46e229.tar.gz
gentoo-2-f0499138e7aa5e43bdb88278d6bef3650c46e229.tar.bz2
gentoo-2-f0499138e7aa5e43bdb88278d6bef3650c46e229.zip
initial common lisp import
Diffstat (limited to 'dev-lisp/cl-pg')
-rw-r--r--dev-lisp/cl-pg/ChangeLog8
-rw-r--r--dev-lisp/cl-pg/Manifest5
-rw-r--r--dev-lisp/cl-pg/cl-pg-0.18.ebuild26
-rw-r--r--dev-lisp/cl-pg/files/digest-cl-pg-0.181
-rw-r--r--dev-lisp/cl-pg/files/pg.asd16
5 files changed, 53 insertions, 3 deletions
diff --git a/dev-lisp/cl-pg/ChangeLog b/dev-lisp/cl-pg/ChangeLog
new file mode 100644
index 000000000000..73b34da12d05
--- /dev/null
+++ b/dev-lisp/cl-pg/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-lisp/cl-pg
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-pg/ChangeLog,v 1.1 2003/06/10 04:53:04 mkennedy Exp $
+
+*cl-pg-0.18 (07 Jul 2003)
+
+ 07 Jul 2003; Matthew Kennedy <mkennedy@gentoo.org> :
+ Initial import.
diff --git a/dev-lisp/cl-pg/Manifest b/dev-lisp/cl-pg/Manifest
index 74726c1e96e8..694dd6ade6e4 100644
--- a/dev-lisp/cl-pg/Manifest
+++ b/dev-lisp/cl-pg/Manifest
@@ -1,5 +1,4 @@
-MD5 125ee013081b112d56a1d15507d72ef2 ChangeLog 3674
-MD5 2171debb025e49a45b922fccde6c4411 cl-pg-0.18.ebuild 721
-MD5 b249e408c219768bb47d2f57243ccbf8 cl-pg-0.18.ebuild~ 5822
+MD5 f99f0bc763d6b942317ee8082cb97f26 ChangeLog 314
+MD5 a9430893bc6844c93c49f5a17714975b cl-pg-0.18.ebuild 810
MD5 073460157c1484e18626c97ae7110c4d files/pg.asd 282
MD5 fc83c432277023c106464ef613c92ec1 files/digest-cl-pg-0.18 66
diff --git a/dev-lisp/cl-pg/cl-pg-0.18.ebuild b/dev-lisp/cl-pg/cl-pg-0.18.ebuild
new file mode 100644
index 000000000000..930ec9da2f42
--- /dev/null
+++ b/dev-lisp/cl-pg/cl-pg-0.18.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-pg/cl-pg-0.18.ebuild,v 1.1 2003/06/10 04:53:04 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="Pg is a socket-level interface to the PostgreSQL object-relational Database for Common Lisp."
+HOMEPAGE="http://www.chez.com/emarsden/downloads/
+ http://www.cliki.net/Pg
+ http://packages.debian.org/unstable/devel/cl-pg.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-pg/${PN}_${PV}.orig.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=pg
+
+S=${WORKDIR}/${P}.orig
+
+src_install() {
+ common-lisp-install ${FILESDIR}/pg.asd *.lisp
+ common-lisp-system-symlink
+}
diff --git a/dev-lisp/cl-pg/files/digest-cl-pg-0.18 b/dev-lisp/cl-pg/files/digest-cl-pg-0.18
new file mode 100644
index 000000000000..3ee1a11ba7b2
--- /dev/null
+++ b/dev-lisp/cl-pg/files/digest-cl-pg-0.18
@@ -0,0 +1 @@
+MD5 cd1f5b9da209e97f52abd53cf44b1788 cl-pg_0.18.orig.tar.gz 15900
diff --git a/dev-lisp/cl-pg/files/pg.asd b/dev-lisp/cl-pg/files/pg.asd
new file mode 100644
index 000000000000..c9ba7daff8c6
--- /dev/null
+++ b/dev-lisp/cl-pg/files/pg.asd
@@ -0,0 +1,16 @@
+;;; -*- Mode: lisp -*-
+
+(in-package :asdf)
+
+(defclass pg-component (cl-source-file)
+ ())
+
+(defmethod perform :before ((o load-op) (c pg-component))
+ (ext:load-foreign "/usr/lib/libcrypt.a"))
+
+;; only tested with cmu
+#+:cmu
+(defsystem :pg
+ :components ((:pg-component "pg")))
+
+