summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-06-19 03:16:05 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-06-19 03:16:05 +0000
commit87a905b0215eb436fbc06b9f00bddfefb777d73b (patch)
treefd5d48e39ccaefe550def011c550239f7a348b87 /dev-lisp/cl-odcl
parentnew ebuild (diff)
downloadgentoo-2-87a905b0215eb436fbc06b9f00bddfefb777d73b.tar.gz
gentoo-2-87a905b0215eb436fbc06b9f00bddfefb777d73b.tar.bz2
gentoo-2-87a905b0215eb436fbc06b9f00bddfefb777d73b.zip
new ebuild
Diffstat (limited to 'dev-lisp/cl-odcl')
-rw-r--r--dev-lisp/cl-odcl/ChangeLog9
-rw-r--r--dev-lisp/cl-odcl/Manifest4
-rw-r--r--dev-lisp/cl-odcl/cl-odcl-1.3.3.ebuild33
-rw-r--r--dev-lisp/cl-odcl/files/clisp-tests-gentoo.patch11
-rw-r--r--dev-lisp/cl-odcl/files/digest-cl-odcl-1.3.31
5 files changed, 56 insertions, 2 deletions
diff --git a/dev-lisp/cl-odcl/ChangeLog b/dev-lisp/cl-odcl/ChangeLog
new file mode 100644
index 000000000000..7cb0ccf24532
--- /dev/null
+++ b/dev-lisp/cl-odcl/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-lisp/cl-odcl
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-odcl/ChangeLog,v 1.1 2003/06/19 03:16:02 mkennedy Exp $
+
+*cl-odcl-1.3.3 (18 Jun 2003)
+
+ 18 Jun 2003; Matthew Kennedy <mkennedy@gentoo.org> :
+ Initial import.
+
diff --git a/dev-lisp/cl-odcl/Manifest b/dev-lisp/cl-odcl/Manifest
index 2b11f7e28b13..85be75f1f90a 100644
--- a/dev-lisp/cl-odcl/Manifest
+++ b/dev-lisp/cl-odcl/Manifest
@@ -1,4 +1,4 @@
-MD5 76ef796d8716cb1c0a5a974335f54af0 cl-odcl-1.3.3.ebuild 1293
-MD5 184d775542444182b07cce988d864cf5 ChangeLog 231
+MD5 7730a70b35fc75c1c179852b91169025 cl-odcl-1.3.3.ebuild 1295
+MD5 446dc1ebc69f3e218cac488ab070a5ea ChangeLog 322
MD5 315c60a4469c95eda194018b1eb42117 files/digest-cl-odcl-1.3.3 70
MD5 f123d753710b35e6ad767e2075f1da8b files/clisp-tests-gentoo.patch 400
diff --git a/dev-lisp/cl-odcl/cl-odcl-1.3.3.ebuild b/dev-lisp/cl-odcl/cl-odcl-1.3.3.ebuild
new file mode 100644
index 000000000000..38c36b5565dd
--- /dev/null
+++ b/dev-lisp/cl-odcl/cl-odcl-1.3.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-odcl/cl-odcl-1.3.3.ebuild,v 1.1 2003/06/19 03:16:02 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="A Commmon Lisp library of utility functions. This package contains a number of useful utility functions for Lisp developers. Include are editing contexts, a transaction system, a filesystem database with indexing, a LRU cache algorithm, time functions, simple i18n/l10n, developer diagnostics, a test regression system, SMTP mailer, object property sets and utility functions related to lists, strings and numbers."
+HOMEPAGE="http://alpha.onshored.com/lisp-software/#odcl"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-odcl/${PN}_${PV}.orig.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=odcl
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+ # some tests die on clisp
+ cd ${S} && patch -p0 <${FILESDIR}/clisp-tests-gentoo.patch || die
+}
+
+src_install() {
+ common-lisp-install *.lisp odcl.asd
+ common-lisp-system-symlink
+ insinto /usr/share/common-lisp/source/odcl/tests
+ doins tests/*.lisp
+ dodoc COPYING ChangeLog NEWS README VERSION
+}
diff --git a/dev-lisp/cl-odcl/files/clisp-tests-gentoo.patch b/dev-lisp/cl-odcl/files/clisp-tests-gentoo.patch
new file mode 100644
index 000000000000..33b75c6fa0e8
--- /dev/null
+++ b/dev-lisp/cl-odcl/files/clisp-tests-gentoo.patch
@@ -0,0 +1,11 @@
+--- odcl.asd~ 2003-05-29 13:03:17.000000000 -0500
++++ odcl.asd 2003-06-18 21:58:57.000000000 -0500
+@@ -52,7 +52,7 @@
+ (:file "iso-8601")
+ #+cmu (:file "profile")
+ #+cmu (:file "log")
+- (:module "tests"
++ #+cmu (:module "tests"
+ :components ((:file "test-avl")
+ (:file "test-filesystem")
+ (:file "test-cache")
diff --git a/dev-lisp/cl-odcl/files/digest-cl-odcl-1.3.3 b/dev-lisp/cl-odcl/files/digest-cl-odcl-1.3.3
new file mode 100644
index 000000000000..062791cb1b60
--- /dev/null
+++ b/dev-lisp/cl-odcl/files/digest-cl-odcl-1.3.3
@@ -0,0 +1 @@
+MD5 235fa207f3ae6ed5ab58871ead87582a cl-odcl_1.3.3.orig.tar.gz 100875