summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-02-03 18:07:14 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-02-03 18:07:14 +0000
commit521208b9cd79802af90cf9789f3d79c3df27812a (patch)
treec92306e638d16426164f61f5a5d075d3dea41687 /dev-lisp/cl-mop-features/cl-mop-features-0.41.ebuild
parentStable on hppa. (diff)
downloadgentoo-2-521208b9cd79802af90cf9789f3d79c3df27812a.tar.gz
gentoo-2-521208b9cd79802af90cf9789f3d79c3df27812a.tar.bz2
gentoo-2-521208b9cd79802af90cf9789f3d79c3df27812a.zip
Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'dev-lisp/cl-mop-features/cl-mop-features-0.41.ebuild')
-rw-r--r--dev-lisp/cl-mop-features/cl-mop-features-0.41.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-lisp/cl-mop-features/cl-mop-features-0.41.ebuild b/dev-lisp/cl-mop-features/cl-mop-features-0.41.ebuild
new file mode 100644
index 000000000000..27145a8e5049
--- /dev/null
+++ b/dev-lisp/cl-mop-features/cl-mop-features-0.41.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-mop-features/cl-mop-features-0.41.ebuild,v 1.1 2006/02/03 18:07:14 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="Common Lisp library which tests for the existence and absence of MOP features."
+HOMEPAGE="http://common-lisp.net/project/closer/closer-mop.html"
+SRC_URI="ftp://common-lisp.net/pub/project/closer/${P/cl-/}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lisp/cl-lw-compat"
+
+CLPACKAGE=mop-feature-tests
+
+S=${WORKDIR}/mop-features
+
+src_install() {
+ common-lisp-install *.{asd,lisp}
+ common-lisp-system-symlink
+ dodoc *.txt
+}