summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-05-11 21:24:51 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-05-11 21:24:51 +0000
commit4ca80e9177e2ecf36aa1bfe8cb4549e6fd30147e (patch)
tree647865c18d3e142f75ab0cbe394914d8b32c6e46 /dev-lisp/cl-aserve/cl-aserve-1.2.42.20060121.ebuild
parentNew upstream version. (diff)
downloadgentoo-2-4ca80e9177e2ecf36aa1bfe8cb4549e6fd30147e.tar.gz
gentoo-2-4ca80e9177e2ecf36aa1bfe8cb4549e6fd30147e.tar.bz2
gentoo-2-4ca80e9177e2ecf36aa1bfe8cb4549e6fd30147e.zip
New upstream version.
(Portage version: 2.1_pre10-r5)
Diffstat (limited to 'dev-lisp/cl-aserve/cl-aserve-1.2.42.20060121.ebuild')
-rw-r--r--dev-lisp/cl-aserve/cl-aserve-1.2.42.20060121.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-lisp/cl-aserve/cl-aserve-1.2.42.20060121.ebuild b/dev-lisp/cl-aserve/cl-aserve-1.2.42.20060121.ebuild
new file mode 100644
index 000000000000..0ee33576434c
--- /dev/null
+++ b/dev-lisp/cl-aserve/cl-aserve-1.2.42.20060121.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-aserve/cl-aserve-1.2.42.20060121.ebuild,v 1.1 2006/05/11 21:24:51 mkennedy Exp $
+
+inherit common-lisp eutils
+
+MY_PV=${PV:0:6}
+CVS_PV=${PV:7:4}.${PV:11:2}.${PV:13}
+
+DESCRIPTION="A portable version of AllegroServe which is a web application server for Common Lisp programs."
+HOMEPAGE="http://portableaserve.sourceforge.net/
+ http://packages.debian.org/unstable/web/cl-aserve.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-portable-aserve/cl-portable-aserve_${MY_PV}+cvs.${CVS_PV}.orig.tar.gz"
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+DEPEND="=dev-lisp/cl-acl-compat-${PV}*
+ =dev-lisp/cl-htmlgen-${PV}*"
+
+CLPACKAGE=aserve
+
+S=${WORKDIR}/cl-portable-aserve-${MY_PV}+cvs.${CVS_PV}.orig
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}; epatch ${FILESDIR}/${PV}-clisp-gentoo.patch
+}
+
+src_install() {
+ common-lisp-install aserve/*.cl aserve/*.asd
+ common-lisp-system-symlink
+ dodoc ChangeLog README README.cmucl INSTALL.lisp logical-hostnames.lisp
+ docinto examples
+ dodoc contrib/*.lisp
+}