summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-08-07 05:22:07 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-08-07 05:22:07 +0000
commit81b947883609f274574d41292eed907b71537ff6 (patch)
tree15e292d44046ac9cf43ded04a989c7389fb49010 /dev-lisp/cl-aserve/cl-aserve-1.2.35.20040804.ebuild
parentdev-lisp/cl-rsm-gen-prog (diff)
downloadgentoo-2-81b947883609f274574d41292eed907b71537ff6.tar.gz
gentoo-2-81b947883609f274574d41292eed907b71537ff6.tar.bz2
gentoo-2-81b947883609f274574d41292eed907b71537ff6.zip
boo-ya ka-sha!
Diffstat (limited to 'dev-lisp/cl-aserve/cl-aserve-1.2.35.20040804.ebuild')
-rw-r--r--dev-lisp/cl-aserve/cl-aserve-1.2.35.20040804.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-lisp/cl-aserve/cl-aserve-1.2.35.20040804.ebuild b/dev-lisp/cl-aserve/cl-aserve-1.2.35.20040804.ebuild
new file mode 100644
index 000000000000..2da2dc357aed
--- /dev/null
+++ b/dev-lisp/cl-aserve/cl-aserve-1.2.35.20040804.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-aserve/cl-aserve-1.2.35.20040804.ebuild,v 1.1 2004/08/07 05:22:07 mkennedy Exp $
+
+inherit common-lisp eutils
+
+MY_PV=${PV:0:6}
+CVS_PV=${PV:7:4}.${PV:11:2}.${PV:13}
+
+DESCRIPTION="A portable version of AllegroServe which is a web application server for Common Lisp programs."
+HOMEPAGE="http://packages.debian.org/unstable/web/cl-aserve.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-portable-aserve/cl-portable-aserve_${MY_PV}+cvs.${CVS_PV}.tar.gz"
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp
+ =dev-lisp/cl-acl-compat-${PV}
+ =dev-lisp/cl-htmlgen-${PV}"
+
+CLPACKAGE=aserve
+
+S=${WORKDIR}/cl-portable-aserve-${MY_PV}+cvs.${CVS_PV}
+
+src_unpack () {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-gentoo.patch
+}
+
+src_install() {
+ common-lisp-install aserve/*.cl aserve/*.asd
+ common-lisp-system-symlink
+ dodoc ChangeLog README README.cmucl INSTALL.lisp logical-hostnames.lisp
+ docinto examples
+ dodoc contrib/*.lisp
+}