summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-01-17 08:06:48 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-01-17 08:06:48 +0000
commit0cf974684b86b38ca7613942589982ef290cc197 (patch)
tree42359476de8bc93c4b003ca41b25b9ba056e5352 /dev-lisp/cl-archive/cl-archive-0.5.0.ebuild
parentFix deps for modular-x. New revision as the build-time dep is removed, and re... (diff)
downloadgentoo-2-0cf974684b86b38ca7613942589982ef290cc197.tar.gz
gentoo-2-0cf974684b86b38ca7613942589982ef290cc197.tar.bz2
gentoo-2-0cf974684b86b38ca7613942589982ef290cc197.zip
Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'dev-lisp/cl-archive/cl-archive-0.5.0.ebuild')
-rw-r--r--dev-lisp/cl-archive/cl-archive-0.5.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-lisp/cl-archive/cl-archive-0.5.0.ebuild b/dev-lisp/cl-archive/cl-archive-0.5.0.ebuild
new file mode 100644
index 000000000000..21ea2708861a
--- /dev/null
+++ b/dev-lisp/cl-archive/cl-archive-0.5.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-archive/cl-archive-0.5.0.ebuild,v 1.1 2006/01/17 08:06:48 mkennedy Exp $
+
+inherit common-lisp eutils
+
+DESCRIPTION="A Common Lisp library for reading and writing cpio and tar archives."
+HOMEPAGE="http://www.cliki.net/tar"
+SRC_URI="http://www.cs.rice.edu/~froydnj/lisp/archive_${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lisp/cl-trivial-gray-streams
+ dev-lisp/cl-flexi-streams"
+
+CLPACKAGE=archive
+
+S=${WORKDIR}/archive_${PV}
+
+src_install() {
+ common-lisp-install *.{lisp,asd}
+ common-lisp-system-symlink
+ dodoc TODO NEWS LICENSE README
+}