summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-02-12 09:13:21 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-02-12 09:13:21 +0000
commit43e3c27dace2a5d95561cae575e8e8d0dff3f0c5 (patch)
treeb8f70a003c2da92e9f475a0fe908686227fc6069 /dev-lisp/cl-aima
parentBump to 0.5 (Manifest recommit) (diff)
downloadgentoo-2-43e3c27dace2a5d95561cae575e8e8d0dff3f0c5.tar.gz
gentoo-2-43e3c27dace2a5d95561cae575e8e8d0dff3f0c5.tar.bz2
gentoo-2-43e3c27dace2a5d95561cae575e8e8d0dff3f0c5.zip
Fire in the hole!
Diffstat (limited to 'dev-lisp/cl-aima')
-rw-r--r--dev-lisp/cl-aima/ChangeLog9
-rw-r--r--dev-lisp/cl-aima/Manifest2
-rw-r--r--dev-lisp/cl-aima/cl-aima-1.0.2-r1.ebuild45
-rw-r--r--dev-lisp/cl-aima/files/digest-cl-aima-1.0.2-r12
4 files changed, 56 insertions, 2 deletions
diff --git a/dev-lisp/cl-aima/ChangeLog b/dev-lisp/cl-aima/ChangeLog
index 39ed960331f7..c4717011cd9a 100644
--- a/dev-lisp/cl-aima/ChangeLog
+++ b/dev-lisp/cl-aima/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/cl-aima
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-aima/ChangeLog,v 1.2 2003/10/15 17:11:36 mkennedy Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-aima/ChangeLog,v 1.3 2004/02/12 09:13:12 mkennedy Exp $
+
+*cl-aima-1.0.2-r1 (12 Feb 2004)
+
+ 12 Feb 2004; <mkennedy@gentoo.org> cl-aima-1.0.2-r1.ebuild:
+ Cleanup for eclass changes.
15 Oct 2003; Matthew Kennedy <mkennedy@gentoo.org> cl-aima-1.0.2.ebuild:
add postrm, preinst
diff --git a/dev-lisp/cl-aima/Manifest b/dev-lisp/cl-aima/Manifest
index 25ad74176663..e40fa3e0fc25 100644
--- a/dev-lisp/cl-aima/Manifest
+++ b/dev-lisp/cl-aima/Manifest
@@ -1,4 +1,6 @@
MD5 87db609d57ed4d93a096c3c989f53e87 cl-aima-1.0.2.ebuild 1532
+MD5 3f474baa96d302265ef8baf67f92b99e cl-aima-1.0.2-r1.ebuild 1391
MD5 4016507928fefb54dbbb55d1a427f380 ChangeLog 453
MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
MD5 1b11e210086362909b8f0d4af6489c09 files/digest-cl-aima-1.0.2 136
+MD5 1b11e210086362909b8f0d4af6489c09 files/digest-cl-aima-1.0.2-r1 136
diff --git a/dev-lisp/cl-aima/cl-aima-1.0.2-r1.ebuild b/dev-lisp/cl-aima/cl-aima-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..34023c451c72
--- /dev/null
+++ b/dev-lisp/cl-aima/cl-aima-1.0.2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-aima/cl-aima-1.0.2-r1.ebuild,v 1.1 2004/02/12 09:13:12 mkennedy Exp $
+
+inherit common-lisp
+
+DEB_PV=1
+
+DESCRIPTION="Common Lisp source code from Peter Norvig's Artificial Intelligence: A Modern Approach"
+HOMEPAGE="http://aima.cs.berkeley.edu/
+ http://www.norvig.com/
+ http://packages.debian.org/unstable/devel/cl-aima.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-aima/cl-aima_${PV}.orig.tar.gz
+ http://ftp.debian.org/debian/pool/main/c/cl-aima/cl-aima_${PV}-${DEB_PV}.diff.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=aima
+
+S=${WORKDIR}/cl-aima-${PV}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${PN}_${PV}-${DEB_PV}.diff
+}
+
+src_install() {
+ insinto /usr/share/common-lisp/source/aima/
+ doins debian/aima.asd aima.lisp
+ for module in agents language learning logic search uncertainty utilities; do
+ find ${module} -type f -name \*.lisp -print | while read lisp; do \
+ local dir=${D}/usr/share/common-lisp/source/aima/$(dirname ${lisp})
+ mkdir -p ${dir} &>/dev/null
+ cp ${lisp} ${dir}
+ done
+ mv ${module}/README.html README-${module}.html && dohtml README-${module}.html
+ done
+ common-lisp-system-symlink
+ dohtml doc/*
+ do-debian-credits
+}
diff --git a/dev-lisp/cl-aima/files/digest-cl-aima-1.0.2-r1 b/dev-lisp/cl-aima/files/digest-cl-aima-1.0.2-r1
new file mode 100644
index 000000000000..87b37df54ea6
--- /dev/null
+++ b/dev-lisp/cl-aima/files/digest-cl-aima-1.0.2-r1
@@ -0,0 +1,2 @@
+MD5 da29b0ec00d2abac61d1bcdb769bbf0e cl-aima_1.0.2.orig.tar.gz 188037
+MD5 d51a6942f2745109c5b81ee0b897dc13 cl-aima_1.0.2-1.diff.gz 3511