summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-02-06 00:41:31 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-02-06 00:41:31 +0000
commit9cff3da79e9dcd29dff872c4de2ce89114b3e0da (patch)
tree1d3dd29deb369102eac6c56f76ded112c16fe469 /dev-lisp/cl-aima/cl-aima-1.0.4.ebuild
parent- q/a virtual/os-headers should not be set in an ebuilds RDEPEND (diff)
downloadgentoo-2-9cff3da79e9dcd29dff872c4de2ce89114b3e0da.tar.gz
gentoo-2-9cff3da79e9dcd29dff872c4de2ce89114b3e0da.tar.bz2
gentoo-2-9cff3da79e9dcd29dff872c4de2ce89114b3e0da.zip
(Portage version: 2.0.51-r15)
Diffstat (limited to 'dev-lisp/cl-aima/cl-aima-1.0.4.ebuild')
-rw-r--r--dev-lisp/cl-aima/cl-aima-1.0.4.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-lisp/cl-aima/cl-aima-1.0.4.ebuild b/dev-lisp/cl-aima/cl-aima-1.0.4.ebuild
new file mode 100644
index 000000000000..c16729adbf1e
--- /dev/null
+++ b/dev-lisp/cl-aima/cl-aima-1.0.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-aima/cl-aima-1.0.4.ebuild,v 1.1 2005/02/06 00:41:31 mkennedy Exp $
+
+inherit common-lisp eutils
+
+DEB_PV=1
+
+DESCRIPTION="Common Lisp source code from Peter Norvig's Artificial Intelligence: A Modern Approach"
+HOMEPAGE="http://aima.cs.berkeley.edu/ http://www.norvig.com/ http://packages.debian.org/unstable/devel/cl-aima.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-aima/cl-aima_${PV}.orig.tar.gz
+ http://ftp.debian.org/debian/pool/main/c/cl-aima/cl-aima_${PV}-${DEB_PV}.diff.gz"
+LICENSE="Norvig"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+S=${WORKDIR}/cl-aima-${PV}
+
+CLPACKAGE=aima
+
+src_unpack() {
+ unpack ${A}
+ epatch ${PN}_${PV}-${DEB_PV}.diff
+ gunzip -c ${FILESDIR}/${PV}-defsystem-and-package-lock-gentoo.patch.gz \
+ >${PV}-defsystem-and-package-lock-gentoo.patch \
+ && epatch ${PV}-defsystem-and-package-lock-gentoo.patch || die
+}
+
+src_install() {
+ insinto /usr/share/common-lisp/source/aima/
+ doins aima.asd aima.lisp
+ for module in agents language learning logic search uncertainty utilities; do
+ find ${module} -type f -name \*.lisp -print | while read lisp; do \
+ local dir=${D}/usr/share/common-lisp/source/aima/$(dirname ${lisp})
+ mkdir -p ${dir} &>/dev/null
+ cp ${lisp} ${dir}
+ done
+ mv ${module}/README.html README-${module}.html && dohtml README-${module}.html
+ done
+ common-lisp-system-symlink
+ dohtml doc/*
+ do-debian-credits
+ find ${D} -type f -exec chmod 644 '{}' \;
+}