summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-21 16:51:52 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-21 16:51:52 +0000
commit53a74fa21d13a9e2f65ab68f7e34819a6c38d0b3 (patch)
tree39146fe9003c68afbcdd95f0179b2c68e237d29e /dev-lisp/cl-acl-compat
parent (Manifest recommit) (diff)
downloadgentoo-2-53a74fa21d13a9e2f65ab68f7e34819a6c38d0b3.tar.gz
gentoo-2-53a74fa21d13a9e2f65ab68f7e34819a6c38d0b3.tar.bz2
gentoo-2-53a74fa21d13a9e2f65ab68f7e34819a6c38d0b3.zip
add inherit eutils
Diffstat (limited to 'dev-lisp/cl-acl-compat')
-rw-r--r--dev-lisp/cl-acl-compat/cl-acl-compat-1.2.27.2003.09.19.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/dev-lisp/cl-acl-compat/cl-acl-compat-1.2.27.2003.09.19.ebuild b/dev-lisp/cl-acl-compat/cl-acl-compat-1.2.27.2003.09.19.ebuild
index 369a9dd5d719..c9612b3fd2a2 100644
--- a/dev-lisp/cl-acl-compat/cl-acl-compat-1.2.27.2003.09.19.ebuild
+++ b/dev-lisp/cl-acl-compat/cl-acl-compat-1.2.27.2003.09.19.ebuild
@@ -1,26 +1,28 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-acl-compat/cl-acl-compat-1.2.27.2003.09.19.ebuild,v 1.4 2004/01/27 20:18:12 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-acl-compat/cl-acl-compat-1.2.27.2003.09.19.ebuild,v 1.5 2004/04/21 16:49:51 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
MY_PV=${PV/.2003/+cvs2003}
DESCRIPTION="Compatibility layer for Allegro Common Lisp"
HOMEPAGE="http://packages.debian.org/unstable/web/cl-acl-compat.html"
SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-portable-aserve/cl-portable-aserve_${MY_PV}.tar.gz"
+
LICENSE="LLGPL-2.1"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
+
DEPEND="dev-lisp/common-lisp-controller
dev-lisp/cmucl-source
virtual/commonlisp"
-CLPACKAGE=acl-compat
-
S=${WORKDIR}/cl-portable-aserve-${MY_PV}
+CLPACKAGE=acl-compat
+
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${PV}-lw-buffering.lisp-gentoo.patch
@@ -34,9 +36,9 @@ src_install() {
}
pkg_preinst() {
- rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+ rm -rf ${ROOT}/usr/lib/common-lisp/*/${CLPACKAGE}
}
pkg_postrm() {
- rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+ rm -rf ${ROOT}/usr/lib/common-lisp/*/${CLPACKAGE}
}