summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-04-11 13:21:56 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-04-11 13:21:56 +0000
commit8f2a770245bc71a6c65f4c04d63caf94156392f6 (patch)
tree4e9475b4ccc9048bfdf5a017d37ead57b16837a8 /dev-lisp/bigloo
parentgnomemeeting removed --newer package available, and util-linux as well (diff)
downloadgentoo-2-8f2a770245bc71a6c65f4c04d63caf94156392f6.tar.gz
gentoo-2-8f2a770245bc71a6c65f4c04d63caf94156392f6.tar.bz2
gentoo-2-8f2a770245bc71a6c65f4c04d63caf94156392f6.zip
Added Bigloo 2.4c, a Scheme compiler for JVM and x86
Diffstat (limited to 'dev-lisp/bigloo')
-rw-r--r--dev-lisp/bigloo/ChangeLog15
-rw-r--r--dev-lisp/bigloo/bigloo-2.4c.ebuild70
-rw-r--r--dev-lisp/bigloo/files/digest-bigloo-2.4c1
3 files changed, 86 insertions, 0 deletions
diff --git a/dev-lisp/bigloo/ChangeLog b/dev-lisp/bigloo/ChangeLog
new file mode 100644
index 000000000000..efd3851e333f
--- /dev/null
+++ b/dev-lisp/bigloo/ChangeLog
@@ -0,0 +1,15 @@
+# ChangeLog for dev-lisp/bigloo
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/bigloo/ChangeLog,v 1.1 2002/04/11 13:21:56 karltk Exp $
+
+*bigloo-2.4c (11 Apr 2002)
+
+ 11 Apr 2002; Karl Trygve Kalleberg <karltk@gentoo.org> bigloo-2.4c.ebuild files/digest-bigloo-2.4c:
+
+ Bigloo is a Scheme implementation devoted to one goal: enabling Scheme based
+ programming style where C(++) is usually required. Bigloo attempts to make
+ Scheme practical by offering features usually presented by traditional
+ programming languages but not offered by Scheme and functional programming.
+ Bigloo compiles Scheme modules. It delivers small and fast stand alone
+ binary executables. Bigloo enables full connections between Scheme and C
+ programs and between Scheme and Java programs.
diff --git a/dev-lisp/bigloo/bigloo-2.4c.ebuild b/dev-lisp/bigloo/bigloo-2.4c.ebuild
new file mode 100644
index 000000000000..0eabe34cf9b9
--- /dev/null
+++ b/dev-lisp/bigloo/bigloo-2.4c.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Tools Team <tools@gentoo.org>
+# Author: Karl Trygve Kalleberg <karltk@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/bigloo/bigloo-2.4c.ebuild,v 1.1 2002/04/11 13:21:56 karltk Exp $
+
+S=${WORKDIR}/${PN}${PV}
+DESCRIPTION="Bigloo Scheme compiler for x86, sparc, alpha, ppc and JVM"
+SRC_URI="ftp://ftp-sop.inria.fr/mimosa/fp/Bigloo/bigloo${PV}.tar.gz"
+HOMEPAGE="http://www-sop.inria.fr/mimosa/fp/Bigloo/bigloo.html"
+
+DEPEND=""
+#RDEPEND=""
+
+src_compile() {
+ local myconf
+ local myjava=`java-config --java`
+ local myjavac=`java-config --javac`
+
+ use java &&
+ myconf="--jvm=force --java=$myjava --javac=$myjavac" \
+ || myconf="--jvm=no"
+
+
+ ./configure \
+ --native=yes \
+ --cflags="${CFLAGS}" \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man/man1 \
+ --docdir=/usr/share/doc/${PV} \
+ $myconf || die "./configure failed"
+
+ cp Makefile.config Makefile.config.orig
+ sed "s/JCFLAGS=-O/JCFLAGS=/" \
+ < Makefile.config.orig \
+ > Makefile.config
+ echo LD_LIBRARY_PATH=${S}/lib/2.4c >> Makefile.config
+
+ cp bde/Makefile bde/Makefile.orig
+ sed "s/\$(BOOTBINDIR)\/afile jas/LD_LIBRARY_PATH=\$(LD_LIBRARY_PATH) \$(BOOTBINDIR)\/afile jas/" \
+ < bde/Makefile.orig \
+ > bde/Makefile
+
+ cp Makefile.config Makefile.config.fixed
+
+ make || die
+}
+
+src_install () {
+ dodir /usr/bin
+ dodir /usr/lib
+ dodir /usr/share/doc/${PV}
+ dodir /usr/share/man/man1
+ dodir /usr/share/info
+
+ sed \
+ -e "s:^BINDIR=\(.*\):BINDIR=${D}\1:" \
+ -e "s:^LIBDIR=\(.*\):LIBDIR=${D}\1:" \
+ -e "s:^MANDIR=\(.*\):MANDIR=${D}\1:" \
+ -e "s:^INFODIR=\(.*\):INFODIR=${D}\1:" \
+ -e "s:^DOCDIR=\(.*\):DOCDIR=${D}\1:" \
+ < Makefile.config.fixed \
+ > Makefile.config
+
+ dodir /etc/env.d
+ echo "LDPATH=/usr/lib/bigloo/${PV}/" \
+ > ${D}/etc/env.d/25bigloo
+ make install || die
+}
diff --git a/dev-lisp/bigloo/files/digest-bigloo-2.4c b/dev-lisp/bigloo/files/digest-bigloo-2.4c
new file mode 100644
index 000000000000..59fd0ef8dd46
--- /dev/null
+++ b/dev-lisp/bigloo/files/digest-bigloo-2.4c
@@ -0,0 +1 @@
+MD5 c26ae852bd4ffb88d21ede4d6a395ffc bigloo2.4c.tar.gz 7794688