summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-03-01 13:23:54 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-03-01 13:23:54 +0000
commitfa11051ebebc2078f7eae56fed83fd0e6ec95b5c (patch)
treef46e136587355e39bdfe9940e894f3d74dea501c /dev-libs
parentVersion bump. (diff)
downloadgentoo-2-fa11051ebebc2078f7eae56fed83fd0e6ec95b5c.tar.gz
gentoo-2-fa11051ebebc2078f7eae56fed83fd0e6ec95b5c.tar.bz2
gentoo-2-fa11051ebebc2078f7eae56fed83fd0e6ec95b5c.zip
eapi2ification of 2.1.3 to avoid that annoying pkg_setup.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/xqilla/ChangeLog9
-rw-r--r--dev-libs/xqilla/xqilla-2.1.3-r1.ebuild51
2 files changed, 58 insertions, 2 deletions
diff --git a/dev-libs/xqilla/ChangeLog b/dev-libs/xqilla/ChangeLog
index a2456ac5a945..7acf7e5f793e 100644
--- a/dev-libs/xqilla/ChangeLog
+++ b/dev-libs/xqilla/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/xqilla
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xqilla/ChangeLog,v 1.3 2008/10/15 10:27:42 dev-zero Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xqilla/ChangeLog,v 1.4 2009/03/01 13:23:54 patrick Exp $
+
+*xqilla-2.1.3-r1 (01 Mar 2009)
+
+ 01 Mar 2009; Patrick Lauer <patrick@gentoo.org> +xqilla-2.1.3-r1.ebuild:
+ eapi2ification of 2.1.3 to avoid that annoying pkg_setup.
15 Oct 2008; Tiziano Müller <dev-zero@gentoo.org> xqilla-9999.ebuild:
Updated dep to match xerces-c-3.0.0
diff --git a/dev-libs/xqilla/xqilla-2.1.3-r1.ebuild b/dev-libs/xqilla/xqilla-2.1.3-r1.ebuild
new file mode 100644
index 000000000000..e4aac5088edc
--- /dev/null
+++ b/dev-libs/xqilla/xqilla-2.1.3-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xqilla/xqilla-2.1.3-r1.ebuild,v 1.1 2009/03/01 13:23:54 patrick Exp $
+
+EAPI="2"
+
+inherit eutils
+
+MY_P="XQilla-${PV}"
+
+DESCRIPTION="An XQuery and XPath 2 library and command line utility written in C++."
+HOMEPAGE="http://xqilla.sourceforge.net/HomePage"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+LICENSE="Sleepycat BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc faxpp htmltidy"
+
+RDEPEND="faxpp? ( dev-libs/faxpp )
+ ~dev-libs/xerces-c-2.8.0[xqilla]
+ htmltidy? ( app-text/htmltidy )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ econf --with-xerces=/usr \
+ $(use_enable debug) \
+ $(use_with htmltidy tidy) \
+ $(use_with faxpp faxpp /usr)
+}
+src_compile() {
+ emake || die "emake failed"
+
+ if use doc; then
+ emake docs || die "emake docs failed"
+ emake devdocs || die "emake devdocs failed"
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake docs failed"
+
+ dodoc ChangeLog TODO
+
+ if use doc; then
+ cd docs
+ dohtml -r dev-api dom3-api simple-api
+ fi
+}