summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2006-11-24 15:13:07 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2006-11-24 15:13:07 +0000
commitf7d67fd1c7a4f3fd9ffb7f68249b62dc3522d6d6 (patch)
tree729a1fd23c17485cbcb9197193d79d93774d394f /dev-libs
parentRemove old version (diff)
downloadgentoo-2-f7d67fd1c7a4f3fd9ffb7f68249b62dc3522d6d6.tar.gz
gentoo-2-f7d67fd1c7a4f3fd9ffb7f68249b62dc3522d6d6.tar.bz2
gentoo-2-f7d67fd1c7a4f3fd9ffb7f68249b62dc3522d6d6.zip
Added multilib support, thanks to Christoph Mende, closes bug#156065
(Portage version: 2.1.1-r2)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/botan/ChangeLog5
-rw-r--r--dev-libs/botan/botan-1.5.11.ebuild9
2 files changed, 10 insertions, 4 deletions
diff --git a/dev-libs/botan/ChangeLog b/dev-libs/botan/ChangeLog
index 8c2a1ca6bb09..3d8ceaad353b 100644
--- a/dev-libs/botan/ChangeLog
+++ b/dev-libs/botan/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/botan
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/ChangeLog,v 1.18 2006/10/24 19:33:26 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/ChangeLog,v 1.19 2006/11/24 15:13:07 alonbl Exp $
+
+ 24 Nov 2006; Alon Bar-Lev <alonbl@gentoo.org> botan-1.5.11.ebuild:
+ Added multilib support, thanks to Christoph Mende, closes bug#156065
*botan-1.5.11 (24 Oct 2006)
diff --git a/dev-libs/botan/botan-1.5.11.ebuild b/dev-libs/botan/botan-1.5.11.ebuild
index 483741a5274c..11ad25eb15c8 100644
--- a/dev-libs/botan/botan-1.5.11.ebuild
+++ b/dev-libs/botan/botan-1.5.11.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/botan-1.5.11.ebuild,v 1.1 2006/10/24 19:33:26 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/botan-1.5.11.ebuild,v 1.2 2006/11/24 15:13:07 alonbl Exp $
-inherit eutils
+inherit eutils multilib
MY_PN="Botan"
MY_P="${MY_PN}-${PV}"
@@ -72,7 +72,10 @@ src_compile() {
einfo "Enabling modules: " ${modules}
# FIXME: We might actually be on *BSD or OS X...
- ./configure.pl --noauto gcc-linux-${CHOSTARCH} --modules=$modules ||
+ ./configure.pl \
+ --noauto gcc-linux-${CHOSTARCH} \
+ --libdir=/usr/$(get_libdir) \
+ --modules=$modules ||
die "configure.pl failed"
emake "LIB_OPT=${CXXFLAGS}" "MACH_OPT=" || die "emake failed"
}