summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-09-03 22:57:24 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-09-03 22:57:24 +0000
commitf0b228c49887088c1b3e870b694d96c5c24f71ac (patch)
treeea2df75cabf19ec1d717541f244f402ff077c832 /dev-libs
parentversion bump (diff)
downloadgentoo-2-f0b228c49887088c1b3e870b694d96c5c24f71ac.tar.gz
gentoo-2-f0b228c49887088c1b3e870b694d96c5c24f71ac.tar.bz2
gentoo-2-f0b228c49887088c1b3e870b694d96c5c24f71ac.zip
version bump
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libuv/ChangeLog7
-rw-r--r--dev-libs/libuv/libuv-0.11.12.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-libs/libuv/ChangeLog b/dev-libs/libuv/ChangeLog
index 6de02915f482..699a42e7ea95 100644
--- a/dev-libs/libuv/ChangeLog
+++ b/dev-libs/libuv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libuv
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libuv/ChangeLog,v 1.6 2013/08/26 01:11:15 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libuv/ChangeLog,v 1.7 2013/09/03 22:57:24 hasufell Exp $
+
+*libuv-0.11.12 (03 Sep 2013)
+
+ 03 Sep 2013; Julian Ospald <hasufell@gentoo.org> +libuv-0.11.12.ebuild:
+ version bump
*libuv-0.11.10 (26 Aug 2013)
diff --git a/dev-libs/libuv/libuv-0.11.12.ebuild b/dev-libs/libuv/libuv-0.11.12.ebuild
new file mode 100644
index 000000000000..629e65027502
--- /dev/null
+++ b/dev-libs/libuv/libuv-0.11.12.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libuv/libuv-0.11.12.ebuild,v 1.1 2013/09/03 22:57:24 hasufell Exp $
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="A new platform layer for Node"
+HOMEPAGE="https://github.com/joyent/libuv"
+SRC_URI="https://github.com/joyent/libuv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD BSD-2 ISC MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+src_prepare() {
+ echo "m4_define([UV_EXTRA_AUTOMAKE_FLAGS], [serial-tests])" \
+ > m4/libuv-extra-automake-flags.m4 || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}