summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-02-13 07:17:32 +0000
committerNick Hadaway <raker@gentoo.org>2003-02-13 07:17:32 +0000
commiteda30b5e23a9b1d26ee10ab8f1957a145633606a (patch)
treed0dd48df940eeb3841d3a442eac4e74afa23dfd1 /dev-libs
parentUpdate Copyright years (diff)
downloadgentoo-2-eda30b5e23a9b1d26ee10ab8f1957a145633606a.tar.gz
gentoo-2-eda30b5e23a9b1d26ee10ab8f1957a145633606a.tar.bz2
gentoo-2-eda30b5e23a9b1d26ee10ab8f1957a145633606a.zip
Added some links
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/fftw/ChangeLog12
-rw-r--r--dev-libs/fftw/fftw-2.1.3-r1.ebuild112
-rw-r--r--dev-libs/fftw/files/digest-fftw-2.1.3-r11
3 files changed, 123 insertions, 2 deletions
diff --git a/dev-libs/fftw/ChangeLog b/dev-libs/fftw/ChangeLog
index 4e786f06bd1b..4ae57b46112b 100644
--- a/dev-libs/fftw/ChangeLog
+++ b/dev-libs/fftw/ChangeLog
@@ -1,11 +1,19 @@
# ChangeLog for dev-libs/fftw
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
# Maintainer: George Shapovalov <george@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/fftw/ChangeLog,v 1.7 2003/02/12 06:03:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/fftw/ChangeLog,v 1.8 2003/02/13 07:17:32 raker Exp $
+
+*fftw-2.1.3-r1.ebuild (13 Feb 2003)
+
+ 13 Feb 2003; Nick Hadaway <raker@gentoo.org> fftw-2.1.3-r1.ebuild,
+ files/digest-fftw-2.1.3 :
+ New ebuild which creates links to the standard fftw include/lib names.
+ If you specify SINGLE=yes on the emerge commandline the links will
+ be created to the single precision libs/includes, otherwise by default
+ to the double precision libs/includes.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
-
*fftw-2.1.3.ebuild (20 June 2002)
10 Feb 2003; Peter Johanson <latexer@gentoo.org> fftw-2.1.3.ebuild :
diff --git a/dev-libs/fftw/fftw-2.1.3-r1.ebuild b/dev-libs/fftw/fftw-2.1.3-r1.ebuild
new file mode 100644
index 000000000000..9680cc6dfeb4
--- /dev/null
+++ b/dev-libs/fftw/fftw-2.1.3-r1.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/fftw/fftw-2.1.3-r1.ebuild,v 1.1 2003/02/13 07:17:32 raker Exp $
+
+IUSE="mpi"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="C subroutine library for computing the Discrete Fourier Transform (DFT)"
+SRC_URI="http://www.fftw.org/${P}.tar.gz"
+HOMEPAGE="http://www.fftw.org"
+#lam compiled fine on uniprocessor (drobbins, 01 Aug 2002)
+DEPEND="mpi? ( >=dev-libs/lam-mpi-6.5.6 )"
+SLOT="2.1"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc ~alpha"
+
+src_unpack() {
+ #doc suggests installing single and double precision versions via separate compilations
+ #will do in two separate source trees
+ #since some sed'ing is done during the build (?if --enable-type-prefix is set?)
+
+ unpack "${P}.tar.gz"
+ cd "${WORKDIR}"
+ mv ${P} ${P}-single
+
+ unpack "${P}.tar.gz"
+ cd "${WORKDIR}"
+ mv ${P} ${P}-double
+}
+
+
+src_compile() {
+
+ #here I need (surprise) to increase optimization:
+ #--enable-i386-hacks requires -fomit-frame-pointer to work properly
+ export CFLAGS="${CFLAGS/-fomit-frame-pointer/} -fomit-frame-pointer"
+
+ local myconf=""
+ use mpi && myconf="${myconf} --enable-mpi"
+ #mpi is not a valid flag yet. In this revision it is used merely to block --enable-mpi option
+ #it might be needed if it is decided that lam is an optional dependence
+
+ cd "${S}-single"
+ econf \
+ --enable-shared \
+ --enable-threads \
+ --enable-type-prefix \
+ --enable-float \
+ --enable-i386-hacks \
+ --enable-vec-recurse \
+ ${myconf} || die "./configure failed"
+ emake || die
+
+ #the only difference here is no --enable-float
+ cd "${S}-double"
+ econf \
+ --enable-shared \
+ --enable-threads \
+ --enable-type-prefix \
+ --enable-i386-hacks \
+ --enable-vec-recurse \
+ ${myconf} || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ #both builds are installed in the same place
+ #libs are distinguished by preffix (s or d), see docs for details
+ cd "${S}-single"
+
+ make DESTDIR=${D} install || die
+
+ cd "${S}-double"
+
+ # fix info file
+ echo "INFO-DIR-SECTION Libraries" >>$fftw.info
+ echo "START-INFO-DIR-ENTRY" >>doc/fftw.info
+ echo "* fftw: (fftw). C subroutine library for computing the Discrete Fourier Transform (DFT)" >>doc/fftw.info
+ echo "END-INFO-DIR-ENTRY" >>doc/fftw.info
+
+ make DESTDIR=${D} install || die
+
+ # Install documentation.
+ cd "${S}-single"
+
+ dodoc AUTHORS ChangeLog COPYING INSTALL NEWS TODO
+ dohtml doc/fftw*.html
+
+ if [ "$SINGLE" = "yes" ]; then
+ cd ${D}usr/include
+ dosym sfftw.h /usr/include/fftw.h
+ dosym srfftw.h /usr/include/rfftw.h
+ dosym sfftw_threads.h /usr/include/fftw_threads.h
+ dosym srfftw_threads.h /usr/include/rfftw_threads.h
+ cd ${D}usr/lib
+ dosym libsfftw.so /usr/lib/libfftw.so
+ dosym libsrfftw.so /usr/lib/librfftw.so
+ dosym libsfftw_threads.so /usr/lib/libfftw_threads.so
+ dosym libsrfftw_threads.so /usr/lib/librfftw_threads.so
+ else
+ cd ${D}usr/include
+ dosym dfftw.h /usr/include/fftw.h
+ dosym drfftw.h /usr/include/rfftw.h
+ dosym dfftw_threads.h /usr/include/fftw_threads.h
+ dosym drfftw_threads.h /usr/include/rfftw_threads.h
+ cd ${D}usr/lib
+ dosym libdfftw.so /usr/lib/libfftw.so
+ dosym libdrfftw.so /usr/lib/librfftw.so
+ dosym libdfftw_threads.so /usr/lib/libfftw_threads.so
+ dosym libdrfftw_threads.so /usr/lib/librfftw_threads.so
+ fi
+}
diff --git a/dev-libs/fftw/files/digest-fftw-2.1.3-r1 b/dev-libs/fftw/files/digest-fftw-2.1.3-r1
new file mode 100644
index 000000000000..6490784c2df3
--- /dev/null
+++ b/dev-libs/fftw/files/digest-fftw-2.1.3-r1
@@ -0,0 +1 @@
+MD5 c6c51a4243f0f998ae4c9416108ebba0 fftw-2.1.3.tar.gz 1139406