summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-05-01 14:50:46 +0000
committerMichał Górny <mgorny@gentoo.org>2015-05-01 14:50:46 +0000
commite13bea4107da4595a3b2bdcf99dfd21be8e095c6 (patch)
treeedacd74f67aeaefbc1f9c15d68cdc84105ea45d3 /dev-libs
parentThanks to Ian Delaney for reviewing: the norm is to revbump with the change o... (diff)
downloadgentoo-2-e13bea4107da4595a3b2bdcf99dfd21be8e095c6.tar.gz
gentoo-2-e13bea4107da4595a3b2bdcf99dfd21be8e095c6.tar.bz2
gentoo-2-e13bea4107da4595a3b2bdcf99dfd21be8e095c6.zip
Version bump. Fixes handling of embedded NUL bytes.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/jsoncpp/ChangeLog7
-rw-r--r--dev-libs/jsoncpp/jsoncpp-0.10.2.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/dev-libs/jsoncpp/ChangeLog b/dev-libs/jsoncpp/ChangeLog
index a6d24348631f..b76de36a0cb9 100644
--- a/dev-libs/jsoncpp/ChangeLog
+++ b/dev-libs/jsoncpp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/jsoncpp
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/jsoncpp/ChangeLog,v 1.15 2015/04/13 19:22:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/jsoncpp/ChangeLog,v 1.16 2015/05/01 14:50:46 mgorny Exp $
+
+*jsoncpp-0.10.2 (01 May 2015)
+
+ 01 May 2015; Michał Górny <mgorny@gentoo.org> +jsoncpp-0.10.2.ebuild:
+ Version bump. Fixes handling of embedded NUL bytes.
13 Apr 2015; Mike Frysinger <vapier@gentoo.org> jsoncpp-0.10.1.ebuild:
Add mips love.
diff --git a/dev-libs/jsoncpp/jsoncpp-0.10.2.ebuild b/dev-libs/jsoncpp/jsoncpp-0.10.2.ebuild
new file mode 100644
index 000000000000..b9c41d1738dc
--- /dev/null
+++ b/dev-libs/jsoncpp/jsoncpp-0.10.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/jsoncpp/jsoncpp-0.10.2.ebuild,v 1.1 2015/05/01 14:50:46 mgorny Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils python-any-r1
+
+DESCRIPTION="C++ JSON reader and writer"
+HOMEPAGE="https://github.com/open-source-parsers/jsoncpp"
+SRC_URI="https://github.com/open-source-parsers/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( public-domain MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~x86"
+IUSE="doc test"
+
+DEPEND="
+ doc? (
+ app-doc/doxygen
+ ${PYTHON_DEPS}
+ )
+ test? (
+ ${PYTHON_DEPS}
+ )"
+RDEPEND=""
+
+pkg_setup() {
+ if use doc || use test; then
+ python-any-r1_pkg_setup
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DJSONCPP_WITH_TESTS=$(usex test)
+ -DJSONCPP_WITH_POST_BUILD_UNITTEST=OFF
+ -DJSONCPP_WITH_CMAKE_PACKAGE=ON
+
+ -DBUILD_SHARED_LIBS=ON
+ # Follow Debian, Ubuntu, Arch convention for headers location
+ # bug #452234
+ -DINCLUDE_INSTALL_DIR="${EPREFIX}"/usr/include/jsoncpp
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ if use doc; then
+ "${EPYTHON}" doxybuild.py --doxygen=/usr/bin/doxygen || die
+ fi
+}
+
+src_test() {
+ emake -C "${BUILD_DIR}" jsoncpp_check
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use doc; then
+ dohtml dist/doxygen/jsoncpp*/*
+ fi
+}