summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-06-30 01:13:56 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-06-30 01:13:56 +0000
commitdc8c7dfc6fe3628c8b2e1b56b661256ea0e02af4 (patch)
treea3d568c0cb4718d1de8b4da223f20ddd03a61eff /dev-libs
parentdrop py2.6 pypy2_0 add py3.4 (diff)
downloadgentoo-2-dc8c7dfc6fe3628c8b2e1b56b661256ea0e02af4.tar.gz
gentoo-2-dc8c7dfc6fe3628c8b2e1b56b661256ea0e02af4.tar.bz2
gentoo-2-dc8c7dfc6fe3628c8b2e1b56b661256ea0e02af4.zip
Remove ~arch versions that don't have the forward compat patch
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/leveldb/ChangeLog6
-rw-r--r--dev-libs/leveldb/leveldb-1.10.0.ebuild53
-rw-r--r--dev-libs/leveldb/leveldb-1.11.0.ebuild53
-rw-r--r--dev-libs/leveldb/leveldb-1.12.0.ebuild53
-rw-r--r--dev-libs/leveldb/leveldb-1.13.0.ebuild53
5 files changed, 5 insertions, 213 deletions
diff --git a/dev-libs/leveldb/ChangeLog b/dev-libs/leveldb/ChangeLog
index 3698a4989f00..20b66fff8c50 100644
--- a/dev-libs/leveldb/ChangeLog
+++ b/dev-libs/leveldb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/leveldb
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/leveldb/ChangeLog,v 1.19 2014/06/30 01:08:11 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/leveldb/ChangeLog,v 1.20 2014/06/30 01:13:56 blueness Exp $
+
+ 30 Jun 2014; Anthony G. Basile <blueness@gentoo.org> -leveldb-1.10.0.ebuild,
+ -leveldb-1.11.0.ebuild, -leveldb-1.12.0.ebuild, -leveldb-1.13.0.ebuild:
+ Remove ~arch versions that don't have the forward compat patch
*leveldb-1.11.0-r1 (30 Jun 2014)
*leveldb-1.12.0-r1 (30 Jun 2014)
diff --git a/dev-libs/leveldb/leveldb-1.10.0.ebuild b/dev-libs/leveldb/leveldb-1.10.0.ebuild
deleted file mode 100644
index aef122687a73..000000000000
--- a/dev-libs/leveldb/leveldb-1.10.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/leveldb/leveldb-1.10.0.ebuild,v 1.3 2014/06/30 01:08:11 blueness Exp $
-
-EAPI=4
-
-inherit eutils multilib toolchain-funcs
-
-DESCRIPTION="a fast key-value storage library written at Google"
-HOMEPAGE="http://code.google.com/p/leveldb/"
-SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
-IUSE="+snappy static-libs +tcmalloc"
-
-DEPEND="tcmalloc? ( dev-util/google-perftools )
- snappy? (
- app-arch/snappy
- static-libs? ( app-arch/snappy[static-libs] )
- )"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- # These vars all get picked up by build_detect_platform
- # which the Makefile runs for us automatically.
- tc-export AR CC CXX
- export OPT="-DNDEBUG ${CPPFLAGS}"
- # Probably needs more filling out
- export TARGET_OS
- case ${CHOST} in
- *) TARGET_OS="Linux";;
- esac
- export USE_SNAPPY=$(usex snappy)
- export USE_TCMALLOC=no
-}
-
-src_compile() {
- emake $(usex static-libs '' 'LIBRARY=') all libmemenv.a
-}
-
-src_test() {
- emake check
-}
-
-src_install() {
- insinto /usr/include
- doins -r include/* helpers/memenv/memenv.h
- dolib.so libleveldb*$(get_libname)*
- use static-libs && dolib.a libleveldb.a
- dolib.a libmemenv.a
-}
diff --git a/dev-libs/leveldb/leveldb-1.11.0.ebuild b/dev-libs/leveldb/leveldb-1.11.0.ebuild
deleted file mode 100644
index 00529a42573a..000000000000
--- a/dev-libs/leveldb/leveldb-1.11.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/leveldb/leveldb-1.11.0.ebuild,v 1.2 2014/06/30 01:08:11 blueness Exp $
-
-EAPI=4
-
-inherit eutils multilib toolchain-funcs
-
-DESCRIPTION="a fast key-value storage library written at Google"
-HOMEPAGE="http://code.google.com/p/leveldb/"
-SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
-IUSE="+snappy static-libs +tcmalloc"
-
-DEPEND="tcmalloc? ( dev-util/google-perftools )
- snappy? (
- app-arch/snappy
- static-libs? ( app-arch/snappy[static-libs] )
- )"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- # These vars all get picked up by build_detect_platform
- # which the Makefile runs for us automatically.
- tc-export AR CC CXX
- export OPT="-DNDEBUG ${CPPFLAGS}"
- # Probably needs more filling out
- export TARGET_OS
- case ${CHOST} in
- *) TARGET_OS="Linux";;
- esac
- export USE_SNAPPY=$(usex snappy)
- export USE_TCMALLOC=no
-}
-
-src_compile() {
- emake $(usex static-libs '' 'LIBRARY=') all libmemenv.a
-}
-
-src_test() {
- emake check
-}
-
-src_install() {
- insinto /usr/include
- doins -r include/* helpers/memenv/memenv.h
- dolib.so libleveldb*$(get_libname)*
- use static-libs && dolib.a libleveldb.a
- dolib.a libmemenv.a
-}
diff --git a/dev-libs/leveldb/leveldb-1.12.0.ebuild b/dev-libs/leveldb/leveldb-1.12.0.ebuild
deleted file mode 100644
index 7b6707bb9247..000000000000
--- a/dev-libs/leveldb/leveldb-1.12.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/leveldb/leveldb-1.12.0.ebuild,v 1.2 2014/06/30 01:08:11 blueness Exp $
-
-EAPI=4
-
-inherit eutils multilib toolchain-funcs
-
-DESCRIPTION="a fast key-value storage library written at Google"
-HOMEPAGE="http://code.google.com/p/leveldb/"
-SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
-IUSE="+snappy static-libs +tcmalloc"
-
-DEPEND="tcmalloc? ( dev-util/google-perftools )
- snappy? (
- app-arch/snappy
- static-libs? ( app-arch/snappy[static-libs] )
- )"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- # These vars all get picked up by build_detect_platform
- # which the Makefile runs for us automatically.
- tc-export AR CC CXX
- export OPT="-DNDEBUG ${CPPFLAGS}"
- # Probably needs more filling out
- export TARGET_OS
- case ${CHOST} in
- *) TARGET_OS="Linux";;
- esac
- export USE_SNAPPY=$(usex snappy)
- export USE_TCMALLOC=no
-}
-
-src_compile() {
- emake $(usex static-libs '' 'LIBRARY=') all libmemenv.a
-}
-
-src_test() {
- emake check
-}
-
-src_install() {
- insinto /usr/include
- doins -r include/* helpers/memenv/memenv.h
- dolib.so libleveldb*$(get_libname)*
- use static-libs && dolib.a libleveldb.a
- dolib.a libmemenv.a
-}
diff --git a/dev-libs/leveldb/leveldb-1.13.0.ebuild b/dev-libs/leveldb/leveldb-1.13.0.ebuild
deleted file mode 100644
index a55ff719bdf4..000000000000
--- a/dev-libs/leveldb/leveldb-1.13.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/leveldb/leveldb-1.13.0.ebuild,v 1.2 2014/06/30 01:08:11 blueness Exp $
-
-EAPI=4
-
-inherit eutils multilib toolchain-funcs
-
-DESCRIPTION="a fast key-value storage library written at Google"
-HOMEPAGE="http://code.google.com/p/leveldb/"
-SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
-IUSE="+snappy static-libs +tcmalloc"
-
-DEPEND="tcmalloc? ( dev-util/google-perftools )
- snappy? (
- app-arch/snappy
- static-libs? ( app-arch/snappy[static-libs] )
- )"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- # These vars all get picked up by build_detect_platform
- # which the Makefile runs for us automatically.
- tc-export AR CC CXX
- export OPT="-DNDEBUG ${CPPFLAGS}"
- # Probably needs more filling out
- export TARGET_OS
- case ${CHOST} in
- *) TARGET_OS="Linux";;
- esac
- export USE_SNAPPY=$(usex snappy)
- export USE_TCMALLOC=no
-}
-
-src_compile() {
- emake $(usex static-libs '' 'LIBRARY=') all libmemenv.a
-}
-
-src_test() {
- emake check
-}
-
-src_install() {
- insinto /usr/include
- doins -r include/* helpers/memenv/memenv.h
- dolib.so libleveldb*$(get_libname)*
- use static-libs && dolib.a libleveldb.a
- dolib.a libmemenv.a
-}