summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2009-05-10 19:09:22 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2009-05-10 19:09:22 +0000
commitd7c7bf2b2d0291bdc72ef9b9173c04ddcb7151ea (patch)
treee64e97c92e48c39c6ab12d44257cc5cba83a71a4 /dev-libs
parentNew version for GNOME 2.26. Drop libxml and libgnome usage, breaks API/ABI, l... (diff)
downloadgentoo-2-d7c7bf2b2d0291bdc72ef9b9173c04ddcb7151ea.tar.gz
gentoo-2-d7c7bf2b2d0291bdc72ef9b9173c04ddcb7151ea.tar.bz2
gentoo-2-d7c7bf2b2d0291bdc72ef9b9173c04ddcb7151ea.zip
Bump to 2.26.1, enable compression for locations file by default --
http://bugzilla.gnome.org/show_bug.cgi?id=552868 Keywords were dropped, bug 269298 (Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libgweather/ChangeLog10
-rw-r--r--dev-libs/libgweather/libgweather-2.26.1.ebuild39
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-libs/libgweather/ChangeLog b/dev-libs/libgweather/ChangeLog
index 32a7575efc50..eeaccfbcb0b1 100644
--- a/dev-libs/libgweather/ChangeLog
+++ b/dev-libs/libgweather/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-libs/libgweather
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/ChangeLog,v 1.30 2009/04/28 11:52:47 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/ChangeLog,v 1.31 2009/05/10 19:09:22 nirbheek Exp $
+
+*libgweather-2.26.1 (11 May 2009)
+
+ 11 May 2009; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +libgweather-2.26.1.ebuild:
+ Bump to 2.26.1, enable compression for locations file by default --
+ http://bugzilla.gnome.org/show_bug.cgi?id=552868
+ Keywords were dropped, bug 269298
28 Apr 2009; Raúl Porcel <armin76@gentoo.org> libgweather-2.24.3.ebuild:
arm/sh stable
diff --git a/dev-libs/libgweather/libgweather-2.26.1.ebuild b/dev-libs/libgweather/libgweather-2.26.1.ebuild
new file mode 100644
index 000000000000..632fb012985e
--- /dev/null
+++ b/dev-libs/libgweather/libgweather-2.26.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/libgweather-2.26.1.ebuild,v 1.1 2009/05/10 19:09:22 nirbheek Exp $
+
+EAPI="2"
+
+inherit gnome2
+
+DESCRIPTION="Library to access weather information from online services"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~x86"
+IUSE="python doc"
+
+RDEPEND=">=x11-libs/gtk+-2.11
+ >=dev-libs/glib-2.13
+ >=gnome-base/gconf-2.8
+ >=net-libs/libsoup-2.25.1:2.4[gnome]
+ >=dev-libs/libxml2-2.6.0
+ python? (
+ >=dev-python/pygobject-2
+ >=dev-python/pygtk-2 )
+ !<gnome-base/gnome-applets-2.22.0"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40.3
+ >=dev-util/pkgconfig-0.19
+ doc? ( >=dev-util/gtk-doc-1.9 )"
+
+DOCS="AUTHORS ChangeLog MAINTAINERS NEWS"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-locations-compression
+ --disable-all-translations-in-one-xml
+ --disable-static
+ $(use_enable python)"
+}