summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-05-01 17:10:04 +0000
committerJeroen Roovers <jer@gentoo.org>2012-05-01 17:10:04 +0000
commitd7ae98740e5303204c5762b5bb0dd2c813adc32a (patch)
tree73ce4372c2797bb8fe90488be80e2c52996aebe2 /dev-libs
parentEAPI4 and cleanup (diff)
downloadgentoo-2-d7ae98740e5303204c5762b5bb0dd2c813adc32a.tar.gz
gentoo-2-d7ae98740e5303204c5762b5bb0dd2c813adc32a.tar.bz2
gentoo-2-d7ae98740e5303204c5762b5bb0dd2c813adc32a.zip
Readd USE=doc.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libnl/ChangeLog5
-rw-r--r--dev-libs/libnl/libnl-3.2.8.ebuild17
2 files changed, 18 insertions, 4 deletions
diff --git a/dev-libs/libnl/ChangeLog b/dev-libs/libnl/ChangeLog
index 33419c303879..d60b28be97ab 100644
--- a/dev-libs/libnl/ChangeLog
+++ b/dev-libs/libnl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/libnl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnl/ChangeLog,v 1.74 2012/05/01 17:08:36 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnl/ChangeLog,v 1.75 2012/05/01 17:10:04 jer Exp $
+
+ 01 May 2012; Jeroen Roovers <jer@gentoo.org> libnl-3.2.8.ebuild:
+ Readd USE=doc.
01 May 2012; Jeroen Roovers <jer@gentoo.org> libnl-1.1-r3.ebuild:
Remove empty RDEPEND. PATCHES -> DOCS.
diff --git a/dev-libs/libnl/libnl-3.2.8.ebuild b/dev-libs/libnl/libnl-3.2.8.ebuild
index dc9fab1eed0a..cf7f9aadfdde 100644
--- a/dev-libs/libnl/libnl-3.2.8.ebuild
+++ b/dev-libs/libnl/libnl-3.2.8.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnl/libnl-3.2.8.ebuild,v 1.1 2012/05/01 16:10:45 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnl/libnl-3.2.8.ebuild,v 1.2 2012/05/01 17:10:04 jer Exp $
EAPI=4
-inherit eutils multilib
+inherit autotools eutils multilib
DESCRIPTION="A library for applications dealing with netlink socket"
HOMEPAGE="http://www.infradead.org/~tgr/libnl/"
@@ -11,24 +11,35 @@ SRC_URI="http://www.infradead.org/~tgr/libnl/files/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="3"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux"
-IUSE="static-libs utils"
+IUSE="doc static-libs utils"
DEPEND="
sys-devel/flex
virtual/yacc
+ doc? ( app-doc/doxygen[dot,latex] )
"
src_prepare() {
epatch \
"${FILESDIR}"/${PN}-1.1-vlan-header.patch
+ sed -i doc/Makefile.am -e 's|api_refs|api_ref|g' || die
+ eautomake
}
src_configure() {
econf $(use_enable static-libs static) $(use_enable utils cli)
}
+src_compile() {
+ default
+ use doc && emake -C doc api_ref
+}
+
src_install() {
default
+ if use doc; then
+ dohtml doc/api/*
+ fi
if ! use static-libs; then
rm -f "${D}"/usr/lib*/lib*.la