summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2007-09-25 20:22:27 +0000
committerTiziano Müller <dev-zero@gentoo.org>2007-09-25 20:22:27 +0000
commitd766ddc86a71d0d0d6a13edb45c41120f7639ade (patch)
tree342f25b765a973f46231ef0b2b1a63bde6c227c5 /dev-libs
parentStable on amd64 wrt bug #193611 (diff)
downloadgentoo-2-d766ddc86a71d0d0d6a13edb45c41120f7639ade.tar.gz
gentoo-2-d766ddc86a71d0d0d6a13edb45c41120f7639ade.tar.bz2
gentoo-2-d766ddc86a71d0d0d6a13edb45c41120f7639ade.zip
Version bump (bug #185896), dropped old versions and patches. Added LFS defines to host.h (together with some more, bug #182736).
(Portage version: 2.1.3.9)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/STLport/ChangeLog12
-rw-r--r--dev-libs/STLport/STLport-5.0.3.ebuild109
-rw-r--r--dev-libs/STLport/STLport-5.1.3.ebuild (renamed from dev-libs/STLport/STLport-5.1.0.ebuild)22
-rw-r--r--dev-libs/STLport/files/STLport-5.0.2-gcc41.patch11
-rw-r--r--dev-libs/STLport/files/STLport-5.0.3-ppc.patch11
-rw-r--r--dev-libs/STLport/files/STLport-5.0.3-sparc.patch11
-rw-r--r--dev-libs/STLport/files/STLport-5.1.0-ppc.patch21
-rw-r--r--dev-libs/STLport/files/STLport-5.1.0-wrong_russian_currency_name.patch11
-rw-r--r--dev-libs/STLport/files/digest-STLport-5.0.33
-rw-r--r--dev-libs/STLport/files/digest-STLport-5.1.03
-rw-r--r--dev-libs/STLport/files/digest-STLport-5.1.33
11 files changed, 28 insertions, 189 deletions
diff --git a/dev-libs/STLport/ChangeLog b/dev-libs/STLport/ChangeLog
index dae31e2129ea..06021181bb1e 100644
--- a/dev-libs/STLport/ChangeLog
+++ b/dev-libs/STLport/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-libs/STLport
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/STLport/ChangeLog,v 1.63 2007/07/23 13:32:05 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/STLport/ChangeLog,v 1.64 2007/09/25 20:22:27 dev-zero Exp $
+
+*STLport-5.1.3 (25 Sep 2007)
+
+ 25 Sep 2007; Tiziano Müller <dev-zero@gentoo.org>
+ -files/STLport-5.0.2-gcc41.patch, -files/STLport-5.0.3-ppc.patch,
+ -files/STLport-5.0.3-sparc.patch, -files/STLport-5.1.0-ppc.patch,
+ -files/STLport-5.1.0-wrong_russian_currency_name.patch,
+ -STLport-5.0.3.ebuild, -STLport-5.1.0.ebuild, +STLport-5.1.3.ebuild:
+ Version bump (bug #185896), dropped old versions and patches. Added LFS
+ defines to host.h (together with some more, bug #182736).
23 Jul 2007; Gustavo Zacarias <gustavoz@gentoo.org> STLport-5.1.2.ebuild:
Stable on sparc
diff --git a/dev-libs/STLport/STLport-5.0.3.ebuild b/dev-libs/STLport/STLport-5.0.3.ebuild
deleted file mode 100644
index ac0021061e2d..000000000000
--- a/dev-libs/STLport/STLport-5.0.3.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/STLport/STLport-5.0.3.ebuild,v 1.6 2007/02/17 22:08:15 weeve Exp $
-
-inherit eutils versionator eutils toolchain-funcs multilib flag-o-matic
-
-KEYWORDS="~amd64 ~ppc ~ppc64 sparc x86"
-
-DESCRIPTION="C++ STL library"
-HOMEPAGE="http://stlport.sourceforge.net/"
-SRC_URI="mirror://sourceforge/stlport/${P}.tar.bz2"
-LICENSE="as-is"
-SLOT="0"
-IUSE="boost"
-
-DEPEND="boost? ( dev-libs/boost )"
-RDEPEND="${RDEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${PN}-5.0.2-gcc41.patch"
- epatch "${FILESDIR}/${P}-ppc.patch"
- epatch "${FILESDIR}/${P}-sparc.patch"
- epatch "${FILESDIR}/${PN}-5.1.0-wrong_russian_currency_name.patch"
-
- sed -i \
- -e 's/\(OPT += \)-O2/\1/' \
- build/Makefiles/gmake/*cc.mak \
- || die "sed opts failed"
-
- sed -i \
- -e 's/_STLP_VENDOR_CSTD::wcsftime/::wcsftime/' \
- stlport/stl/_cwchar.h || die "sed failed"
-
-}
-
-src_compile() {
- cat <<- EOF >> stlport/stl_user_config.h
- #define _STLP_NATIVE_INCLUDE_PATH ../g++-v$(gcc-major-version)
- EOF
-
- sed -i \
- -e "s|\(CC :=\) gcc|\1 $(tc-getCC)|" \
- -e "s|\(CXX :=\) c++|\1 $(tc-getCXX)|" \
- -e "s|^\(CFLAGS = \)|\1 ${CFLAGS} |" \
- -e "s|^\(CCFLAGS = \)|\1 ${CFLAGS} |" \
- build/Makefiles/gmake/gcc.mak || die "sed failed"
-
- local myconf
- if use boost ; then
- myconf="${myconf} --with-boost=/usr/include"
- sed -i \
- -e 'N;N;N;s:/\**\n\(#define _STLP_USE_BOOST_SUPPORT 1\)*\n\*/:\1:' \
- stlport/stl_user_config.h
- fi
-
- cd "${S}/build/lib"
-
- append-lfs-flags
-
- # It's not an autoconf script
- ./configure \
- ${myconf} \
- --with-extra-cxxflags="${CXXFLAGS}" || die "configure failed"
-
- cd "${S}"
-
- cat <<- EOF >> build/Makefiles/config.mak
- CFLAGS := ${CFLAGS}
- EOF
-
- local targets
- targets="all-shared all-static"
-
- # The build-system is broken in respect to parallel builds, bug #161881
- emake \
- -j1 \
- -C build/lib \
- -f gcc.mak \
- depend ${targets} || die "Compile failed"
-}
-
-src_install() {
- emake -C build/lib -f gcc.mak install
- dolib.so lib/*
-
- emake -C build/lib -f gcc.mak install-static
- dolib.a lib/*.a
-
- insinto /usr/include
- doins -r stlport
-
- dodoc README etc/ChangeLog* etc/*.txt doc/*
-}
-
-src_test() {
- cd "${S}/build"
-
- sed -i \
- -e "1aLDFLAGS := -L${S}/build/lib/obj/gcc/shared -L${S}/build/lib/obj/gcc/shared-g -L${S}/build/lib/obj/gcc/shared-stlg" \
- test/unit/gcc.mak || die "sed failed"
-
- emake -j1 -C test/unit -f gcc.mak || die "emake tests failed"
-
- export LD_LIBRARY_PATH="./lib/obj/gcc/shared-stlg"
- ./test/unit/obj/gcc/shared-stlg/stl_unit_test || die "unit tests failed"
-}
diff --git a/dev-libs/STLport/STLport-5.1.0.ebuild b/dev-libs/STLport/STLport-5.1.3.ebuild
index 4aa2ea7fca04..6d20bee199fe 100644
--- a/dev-libs/STLport/STLport-5.1.0.ebuild
+++ b/dev-libs/STLport/STLport-5.1.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/STLport/STLport-5.1.0.ebuild,v 1.17 2007/03/12 16:08:59 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/STLport/STLport-5.1.3.ebuild,v 1.1 2007/09/25 20:22:27 dev-zero Exp $
inherit eutils versionator eutils toolchain-funcs multilib flag-o-matic
-KEYWORDS="amd64 ppc ppc64 ~sparc x86"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
DESCRIPTION="C++ STL library"
HOMEPAGE="http://stlport.sourceforge.net/"
@@ -20,9 +20,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
- # It should be save to apply this on non-ppc systems as well
- epatch "${FILESDIR}/${P}-ppc.patch"
- epatch "${FILESDIR}/${P}-wrong_russian_currency_name.patch"
+ epatch "${FILESDIR}/${PN}-5.1.2-fix_bashism.patch"
sed -i \
-e 's/\(OPT += \)-O2/\1/' \
@@ -35,8 +33,16 @@ src_unpack() {
}
src_compile() {
- cat <<- EOF >> stlport/stl/config/user_config.h
+ # We have to add this to host.h to make sure
+ # that dependencies of STLport use the same settings
+ cat <<- EOF >> stlport/stl/config/host.h
#define _STLP_NATIVE_INCLUDE_PATH ../g++-v$(gcc-major-version)
+ /* use pthreads for threading */
+ #define _PTHREADS
+ /* enable largefile support */
+ #define _FILE_OFFSET_BITS 64
+ #define _LARGEFILE_SOURCE
+ #define _LARGEFILE64_SOURCE
EOF
sed -i \
@@ -44,6 +50,7 @@ src_compile() {
-e "s|\(CXX :=\) c++|\1 $(tc-getCXX)|" \
-e "s|^\(CFLAGS = \)|\1 ${CFLAGS} |" \
-e "s|^\(CCFLAGS = \)|\1 ${CFLAGS} |" \
+ -e "s|^\(CPPFLAGS = \)|\1 ${CPPFLAGS} |" \
build/Makefiles/gmake/gcc.mak || die "sed failed"
local myconf
@@ -56,8 +63,6 @@ src_compile() {
cd "${S}/build/lib"
- append-lfs-flags
-
# It's not an autoconf script
./configure \
${myconf} \
@@ -78,6 +83,7 @@ src_compile() {
-C build/lib \
-f gcc.mak \
depend ${targets} || die "Compile failed"
+
}
src_install() {
diff --git a/dev-libs/STLport/files/STLport-5.0.2-gcc41.patch b/dev-libs/STLport/files/STLport-5.0.2-gcc41.patch
deleted file mode 100644
index a593c0f3ed9a..000000000000
--- a/dev-libs/STLport/files/STLport-5.0.2-gcc41.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- STLport/stlport/cwchar.orig 2006-03-22 16:35:19.000000000 +0100
-+++ STLport/stlport/cwchar 2006-03-22 16:35:31.000000000 +0100
-@@ -191,7 +191,7 @@
- # if (!defined(__MSL__) || __MSL__ > 0x7001 ) && !defined(_STLP_WCE_NET) && \
- !defined(_STLP_USE_UCLIBC) /* at least in uClibc 0.9.26 */
-
--using _STLP_VENDOR_CSTD::wcsftime;
-+using ::wcsftime;
- # endif
- using _STLP_VENDOR_CSTD::wcstok;
-
diff --git a/dev-libs/STLport/files/STLport-5.0.3-ppc.patch b/dev-libs/STLport/files/STLport-5.0.3-ppc.patch
deleted file mode 100644
index d3c53799ddd1..000000000000
--- a/dev-libs/STLport/files/STLport-5.0.3-ppc.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- stlport/stl/_config.h.orig 2007-02-13 20:38:46.000000000 +0100
-+++ stlport/stl/_config.h 2007-02-13 20:42:55.000000000 +0100
-@@ -162,7 +162,7 @@
-
- #if !defined (_STLP_BIG_ENDIAN) && ! defined (_STLP_LITTLE_ENDIAN)
- # if defined (_MIPSEB) || defined (__sparc) || defined (_AIX) || \
-- defined (__hpux) || defined (macintosh) || defined (_MAC)
-+ defined (__hpux) || defined (macintosh) || defined (_MAC) || defined (__ppc__)
- # define _STLP_BIG_ENDIAN 1
- # elif defined (__i386) || defined (_M_IX86) || defined (_M_ARM) || \
- defined (__amd64__) || defined (_M_AMD64) || defined (__x86_64__) || \
diff --git a/dev-libs/STLport/files/STLport-5.0.3-sparc.patch b/dev-libs/STLport/files/STLport-5.0.3-sparc.patch
deleted file mode 100644
index c3aed0851575..000000000000
--- a/dev-libs/STLport/files/STLport-5.0.3-sparc.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- stlport/config/stl_gcc.h.orig 2007-02-13 21:30:42.000000000 +0100
-+++ stlport/config/stl_gcc.h 2007-02-13 21:31:02.000000000 +0100
-@@ -236,7 +236,7 @@
- # endif
- #endif
-
--#if defined (__alpha__)
-+#if defined (__alpha__) || defined (__sparc__)
- # define _STLP_NO_VENDOR_MATH_L
- #endif
-
diff --git a/dev-libs/STLport/files/STLport-5.1.0-ppc.patch b/dev-libs/STLport/files/STLport-5.1.0-ppc.patch
deleted file mode 100644
index 1376d8e83d92..000000000000
--- a/dev-libs/STLport/files/STLport-5.1.0-ppc.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- stlport/stl/config/_gcc.h.orig 2006-12-24 02:38:24.000000000 +0100
-+++ stlport/stl/config/_gcc.h 2006-12-24 02:40:20.000000000 +0100
-@@ -9,6 +9,7 @@
- # ifndef _STLP_USE_GLIBC
- # define _STLP_USE_GLIBC 1
- # endif
-+# define _STLP_NO_VENDOR_STDLIB_L
- # if defined (__UCLIBC__) && !defined (_STLP_USE_UCLIBC)
- # define _STLP_USE_UCLIBC 1
- # endif
-@@ -21,7 +22,9 @@
- #endif
-
- #if (__GNUC__ < 3)
--# define _STLP_NO_VENDOR_STDLIB_L
-+# ifndef _STLP_NO_VENDOR_STDLIB_L
-+# define _STLP_NO_VENDOR_STDLIB_L
-+# endif
- #endif
-
- /* We guess if we are using the cygwin distrib that has a special include schema.
diff --git a/dev-libs/STLport/files/STLport-5.1.0-wrong_russian_currency_name.patch b/dev-libs/STLport/files/STLport-5.1.0-wrong_russian_currency_name.patch
deleted file mode 100644
index 5dadc2742cd8..000000000000
--- a/dev-libs/STLport/files/STLport-5.1.0-wrong_russian_currency_name.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- test/unit/locale_test.cpp.orig 2007-01-13 21:56:42.000000000 +0100
-+++ test/unit/locale_test.cpp 2007-01-13 21:57:14.000000000 +0100
-@@ -35,7 +35,7 @@
- #else
- " " },
- #endif
-- { "ru_RU.koi8r", ",", ".", "RUR ", "", "", "\xd2\xd5\xc2", ".", " " },
-+ { "ru_RU.koi8r", ",", ".", "RUB ", "RUR", "", "\xd2\xd5\xc2", ".", " " },
- { "en_GB", ".", ",", "GBP ", "", "\xa3", "", ".", "," },
- { "en_US", ".", ",", "USD ", "", "$", "", ".", "," },
- { "C", ".", ",", "", "", "", "", " ", " " },
diff --git a/dev-libs/STLport/files/digest-STLport-5.0.3 b/dev-libs/STLport/files/digest-STLport-5.0.3
deleted file mode 100644
index 056ef0057099..000000000000
--- a/dev-libs/STLport/files/digest-STLport-5.0.3
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 21d5275f4f8b190be1572b8498382091 STLport-5.0.3.tar.bz2 639508
-RMD160 9fac74a7177812c338b0e9a996cf7557ee90a437 STLport-5.0.3.tar.bz2 639508
-SHA256 5bdc0bb07180a8463b480c940e4294ca46cfdfed50b00d254539cb68ae4c2b24 STLport-5.0.3.tar.bz2 639508
diff --git a/dev-libs/STLport/files/digest-STLport-5.1.0 b/dev-libs/STLport/files/digest-STLport-5.1.0
deleted file mode 100644
index ab1fefb80536..000000000000
--- a/dev-libs/STLport/files/digest-STLport-5.1.0
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 dcf079313e7e0d7870307b74b658bb81 STLport-5.1.0.tar.bz2 664143
-RMD160 b49180f575315004ee83c7673f9b73ff23b03f2c STLport-5.1.0.tar.bz2 664143
-SHA256 bafaf651679c1ab95a3d2ed54d6410915a047a617e4c9b8dbcb1b6fc3ce95e67 STLport-5.1.0.tar.bz2 664143
diff --git a/dev-libs/STLport/files/digest-STLport-5.1.3 b/dev-libs/STLport/files/digest-STLport-5.1.3
new file mode 100644
index 000000000000..f66652eb691b
--- /dev/null
+++ b/dev-libs/STLport/files/digest-STLport-5.1.3
@@ -0,0 +1,3 @@
+MD5 bb6459a6807c77a0363cf0d9c1fe4eb2 STLport-5.1.3.tar.bz2 679697
+RMD160 7e0b484849039893717caaeb9f5cdd35e7798267 STLport-5.1.3.tar.bz2 679697
+SHA256 08ecdec9fccd5e629af9cf5b5ce88e3476e8caf396aa390520e0cc18bc9fd5b4 STLport-5.1.3.tar.bz2 679697