summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2012-05-16 09:18:07 +0000
committerTiziano Müller <dev-zero@gentoo.org>2012-05-16 09:18:07 +0000
commitcf8cccb5c3e92362f66e1f559807463b2857b99d (patch)
tree83329439c1e3ce01702e7f58fc19e2123d8af1fe /dev-libs
parentVersion bump to latest bugfix (typofix) release. Stable that one on amd64, x8... (diff)
downloadgentoo-2-cf8cccb5c3e92362f66e1f559807463b2857b99d.tar.gz
gentoo-2-cf8cccb5c3e92362f66e1f559807463b2857b99d.tar.bz2
gentoo-2-cf8cccb5c3e92362f66e1f559807463b2857b99d.zip
Drop -fshort-wchar when building wchar_t expat since we're not building for WINE-compatibility and need expatw with full wchar_t for amara.
(Portage version: 2.1.10.56/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/expat/ChangeLog8
-rw-r--r--dev-libs/expat/expat-2.1.0-r2.ebuild93
2 files changed, 100 insertions, 1 deletions
diff --git a/dev-libs/expat/ChangeLog b/dev-libs/expat/ChangeLog
index 2a6ba1c48413..58a2f5f887af 100644
--- a/dev-libs/expat/ChangeLog
+++ b/dev-libs/expat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/expat
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/ChangeLog,v 1.136 2012/04/26 12:16:04 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/ChangeLog,v 1.137 2012/05/16 09:18:07 dev-zero Exp $
+
+*expat-2.1.0-r2 (16 May 2012)
+
+ 16 May 2012; Tiziano Müller <dev-zero@gentoo.org> +expat-2.1.0-r2.ebuild:
+ Drop -fshort-wchar when building wchar_t expat since we're not building for
+ WINE-compatibility and need expatw with full wchar_t for amara.
26 Apr 2012; Alexis Ballier <aballier@gentoo.org> expat-2.1.0-r1.ebuild:
keyword ~amd64-fbsd
diff --git a/dev-libs/expat/expat-2.1.0-r2.ebuild b/dev-libs/expat/expat-2.1.0-r2.ebuild
new file mode 100644
index 000000000000..fdda9f534e67
--- /dev/null
+++ b/dev-libs/expat/expat-2.1.0-r2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-2.1.0-r2.ebuild,v 1.1 2012/05/16 09:18:07 dev-zero Exp $
+
+EAPI=4
+inherit eutils libtool multilib toolchain-funcs
+
+DESCRIPTION="XML parsing libraries"
+HOMEPAGE="http://expat.sourceforge.net/"
+SRC_URI="mirror://sourceforge/expat/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="elibc_FreeBSD examples static-libs unicode"
+
+src_prepare() {
+ elibtoolize
+ epunt_cxx
+
+ mkdir "${S}"-build{,u,w} || die
+}
+
+src_configure() {
+ local myconf="$(use_enable static-libs static)"
+
+ pushd "${S}"-build >/dev/null
+ ECONF_SOURCE="${S}" econf ${myconf}
+ popd >/dev/null
+
+ if use unicode; then
+ pushd "${S}"-buildu >/dev/null
+ CPPFLAGS="${CPPFLAGS} -DXML_UNICODE" ECONF_SOURCE="${S}" econf ${myconf}
+ popd >/dev/null
+
+ pushd "${S}"-buildw >/dev/null
+ CPPFLAGS="${CPPFLAGS} -DXML_UNICODE_WCHAR_T" ECONF_SOURCE="${S}" econf ${myconf}
+ popd >/dev/null
+ fi
+}
+
+src_compile() {
+ pushd "${S}"-build >/dev/null
+ emake
+ popd >/dev/null
+
+ if use unicode; then
+ pushd "${S}"-buildu >/dev/null
+ emake buildlib LIBRARY=libexpatu.la
+ popd >/dev/null
+
+ pushd "${S}"-buildw >/dev/null
+ emake buildlib LIBRARY=libexpatw.la
+ popd >/dev/null
+ fi
+}
+
+src_install() {
+ dodoc Changes README
+ dohtml doc/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.c
+ fi
+
+ pushd "${S}"-build >/dev/null
+ emake install DESTDIR="${D}"
+ popd >/dev/null
+
+ if use unicode; then
+ pushd "${S}"-buildu >/dev/null
+ emake installlib DESTDIR="${D}" LIBRARY=libexpatu.la
+ popd >/dev/null
+
+ pushd "${S}"-buildw >/dev/null
+ emake installlib DESTDIR="${D}" LIBRARY=libexpatw.la
+ popd >/dev/null
+
+ pushd "${ED}"/usr/$(get_libdir)/pkgconfig >/dev/null
+ cp expat.pc expatu.pc
+ sed -i -e '/^Libs/s:-lexpat:&u:' expatu.pc || die
+ cp expat.pc expatw.pc
+ sed -i -e '/^Libs/s:-lexpat:&w:' expatw.pc || die
+ popd >/dev/null
+ fi
+
+ rm -f "${ED}"usr/lib*/libexpat{,u,w}.la
+
+ # libgeom in /lib and ifconfig in /sbin require libexpat on FreeBSD since
+ # we stripped the libbsdxml copy starting from freebsd-lib-8.2-r1
+ use elibc_FreeBSD && gen_usr_ldscript -a expat
+}