summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-09-15 19:41:02 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-09-15 19:41:02 +0000
commitcf5e4efa447c398539b0d33c79b8b8ef1202b154 (patch)
treea5ea5a6764bdeec5115be88c512c9f0dd1e8308c /dev-libs
parentEAPI=2; build when kde4 is installed (bug #274737) (diff)
downloadgentoo-2-cf5e4efa447c398539b0d33c79b8b8ef1202b154.tar.gz
gentoo-2-cf5e4efa447c398539b0d33c79b8b8ef1202b154.tar.bz2
gentoo-2-cf5e4efa447c398539b0d33c79b8b8ef1202b154.zip
Implement basic ARM support, thanks to the mv78100 board from Marvell.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/klibc/ChangeLog5
-rw-r--r--dev-libs/klibc/klibc-1.5.15.ebuild18
2 files changed, 19 insertions, 4 deletions
diff --git a/dev-libs/klibc/ChangeLog b/dev-libs/klibc/ChangeLog
index 1eeaf96bc9d5..e800faa01b00 100644
--- a/dev-libs/klibc/ChangeLog
+++ b/dev-libs/klibc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/klibc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/klibc/ChangeLog,v 1.68 2009/05/09 22:57:42 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/klibc/ChangeLog,v 1.69 2009/09/15 19:41:02 robbat2 Exp $
+
+ 15 Sep 2009; Robin H. Johnson <robbat2@gentoo.org> klibc-1.5.15.ebuild:
+ Implement basic ARM support, thanks to the mv78100 board from Marvell.
*klibc-1.5.15 (09 May 2009)
diff --git a/dev-libs/klibc/klibc-1.5.15.ebuild b/dev-libs/klibc/klibc-1.5.15.ebuild
index 6a2c2f599634..df93fb3c8944 100644
--- a/dev-libs/klibc/klibc-1.5.15.ebuild
+++ b/dev-libs/klibc/klibc-1.5.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/klibc/klibc-1.5.15.ebuild,v 1.1 2009/05/09 22:57:42 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/klibc/klibc-1.5.15.ebuild,v 1.2 2009/09/15 19:41:02 robbat2 Exp $
# Robin H. Johnson <robbat2@gentoo.org>, 12 Nov 2007:
# This still needs major work.
@@ -37,7 +37,7 @@ SRC_URI="
${KERNEL_URI}"
LICENSE="|| ( GPL-2 LGPL-2 )"
-KEYWORDS="~amd64 -mips ~ppc ~sparc ~x86"
+KEYWORDS="~amd64 -mips ~ppc ~sparc ~x86 ~arm"
SLOT="0"
IUSE="debug n32"
@@ -87,7 +87,7 @@ kernel_defconfig() {
case ${a} in
ppc64) echo ppc64_defconfig ;;
ppc) echo pmac32_defconfig ;;
- arm*|sh*) die "TODO: Your arch is not supported by the klibc ebuild. Please suggest a defconfig in a bug." ;;
+ sh*) die "TODO: Your arch is not supported by the klibc ebuild. Please suggest a defconfig in a bug." ;;
*) echo defconfig ;;
esac
}
@@ -136,6 +136,18 @@ src_compile() {
cd "${KS}"
emake ${defconfig} CC="${CC}" HOSTCC="${HOSTCC}" || die "No defconfig"
+ if [[ "${KLIBCARCH/arm}" != "${KLIBCARCH}" ]] && \
+ [[ "${CHOST/eabi}" != "${CHOST}" ]]; then
+ # The delete and insert are seperate statements
+ # so that they are reliably used.
+ sed -i \
+ -e '/CONFIG_AEABI/d' \
+ -e '1iCONFIG_AEABI=y' \
+ -e '/CONFIG_OABI_COMPAT/d' \
+ -e '1iCONFIG_OABI_COMPAT=y' \
+ "${KS}"/.config \
+ "${S}"/defconfig
+ fi
emake prepare CC="${CC}" HOSTCC="${HOSTCC}" || die "Failed to prepare kernel sources for header usage"
cd "${S}"