summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-10-08 17:01:19 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-10-08 17:01:19 +0000
commitc0bf4107207debc770f014c6a48b736dfda0ff90 (patch)
tree079dd5e66ef43a8616b2c19bf1ac6c8559f914ef /dev-libs
parentamd64 stable wrt #386001 (diff)
downloadgentoo-2-c0bf4107207debc770f014c6a48b736dfda0ff90.tar.gz
gentoo-2-c0bf4107207debc770f014c6a48b736dfda0ff90.tar.bz2
gentoo-2-c0bf4107207debc770f014c6a48b736dfda0ff90.zip
Apply exceptions patch(upstream) thanks to Joel Berendzen <joelb@lanl.gov>. BUg #386097
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/boost/ChangeLog7
-rw-r--r--dev-libs/boost/boost-1.47.0.ebuild4
-rw-r--r--dev-libs/boost/files/boost-1.47.0-exceptions.patch22
3 files changed, 30 insertions, 3 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index dd1a48d39421..718167777e40 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/boost
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.228 2011/09/26 11:02:02 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.229 2011/10/08 17:01:19 hwoarang Exp $
+
+ 08 Oct 2011; Markos Chandras <hwoarang@gentoo.org> boost-1.47.0.ebuild,
+ +files/boost-1.47.0-exceptions.patch:
+ Apply exceptions patch(upstream) thanks to Joel Berendzen <joelb@lanl.gov>.
+ BUg #386097
*boost-1.47.0 (26 Sep 2011)
diff --git a/dev-libs/boost/boost-1.47.0.ebuild b/dev-libs/boost/boost-1.47.0.ebuild
index 0d52db7cc6ce..6d9bafcf2493 100644
--- a/dev-libs/boost/boost-1.47.0.ebuild
+++ b/dev-libs/boost/boost-1.47.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.47.0.ebuild,v 1.1 2011/09/26 11:02:02 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.47.0.ebuild,v 1.2 2011/10/08 17:01:19 hwoarang Exp $
EAPI="2"
@@ -85,7 +85,7 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}/remove-toolset-${PV}.patch"
-
+ epatch "${FILESDIR}/${P}-exceptions.patch"
# This enables building the boost.random library with /dev/urandom support
if [[ -e /dev/urandom ]] ; then
mkdir -p libs/random/build || die
diff --git a/dev-libs/boost/files/boost-1.47.0-exceptions.patch b/dev-libs/boost/files/boost-1.47.0-exceptions.patch
new file mode 100644
index 000000000000..61ab3564a3ab
--- /dev/null
+++ b/dev-libs/boost/files/boost-1.47.0-exceptions.patch
@@ -0,0 +1,22 @@
+--- boost/numeric/conversion/converter_policies.hpp 2008-10-13 11:00:03.000000000 +0200
++++ boost/numeric/conversion/converter_policies.hpp 2011-07-22 11:46:40.961876274 +0200
+@@ -20,6 +20,7 @@
+
+ #include "boost/mpl/if.hpp"
+ #include "boost/mpl/integral_c.hpp"
++#include "boost/throw_exception.hpp"
+
+ namespace boost { namespace numeric
+ {
+@@ -159,9 +160,9 @@ struct def_overflow_handler
+ void operator() ( range_check_result r ) // throw(negative_overflow,positive_overflow)
+ {
+ if ( r == cNegOverflow )
+- throw negative_overflow() ;
++ boost::throw_exception( negative_overflow() ) ;
+ else if ( r == cPosOverflow )
+- throw positive_overflow() ;
++ boost::throw_exception( positive_overflow() ) ;
+ }
+ } ;
+