summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-01-18 00:57:24 +0000
committerTim Harder <radhermit@gentoo.org>2013-01-18 00:57:24 +0000
commitb615fd2c291b3cf86980a67c4a8c81242e18683a (patch)
tree88f707c88006da45062cccc136aed5db3285d792 /dev-libs
parentLinux patch 3.7.3. FBCONDECOR patch thanks to Jeremy (diff)
downloadgentoo-2-b615fd2c291b3cf86980a67c4a8c81242e18683a.tar.gz
gentoo-2-b615fd2c291b3cf86980a67c4a8c81242e18683a.tar.bz2
gentoo-2-b615fd2c291b3cf86980a67c4a8c81242e18683a.zip
Version bump. Update to EAPI 5 and add subslot, add doc and test use flags, and run tests.
(Portage version: 2.2.0_alpha154/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/nettle/ChangeLog11
-rw-r--r--dev-libs/nettle/files/nettle-2.6-shared.patch100
-rw-r--r--dev-libs/nettle/nettle-2.6.ebuild58
3 files changed, 167 insertions, 2 deletions
diff --git a/dev-libs/nettle/ChangeLog b/dev-libs/nettle/ChangeLog
index 7c63313d64b0..fd2506295b1d 100644
--- a/dev-libs/nettle/ChangeLog
+++ b/dev-libs/nettle/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/nettle
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/ChangeLog,v 1.73 2012/12/15 12:06:14 alonbl Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/ChangeLog,v 1.74 2013/01/18 00:57:24 radhermit Exp $
+
+*nettle-2.6 (18 Jan 2013)
+
+ 18 Jan 2013; Tim Harder <radhermit@gentoo.org> +nettle-2.6.ebuild,
+ +files/nettle-2.6-shared.patch:
+ Version bump. Update to EAPI 5 and add subslot, add doc and test use flags,
+ and run tests.
14 Dec 2012; Alon Bar-Lev <alonbl@gentoo.org> +files/nettle-2.5-build-ar.patch,
nettle-2.5-r1.ebuild:
diff --git a/dev-libs/nettle/files/nettle-2.6-shared.patch b/dev-libs/nettle/files/nettle-2.6-shared.patch
new file mode 100644
index 000000000000..0a322bef5316
--- /dev/null
+++ b/dev-libs/nettle/files/nettle-2.6-shared.patch
@@ -0,0 +1,100 @@
+--- nettle-2.6/examples/Makefile.in
++++ nettle-2.6/examples/Makefile.in
+@@ -8,7 +8,7 @@
+ include ../config.make
+
+ PRE_CPPFLAGS = -I.. -I$(top_srcdir)
+-PRE_LDFLAGS = -L..
++PRE_LDFLAGS = -L../.lib
+
+ OPENSSL_LIBFLAGS = @OPENSSL_LIBFLAGS@
+ BENCH_LIBS = @BENCH_LIBS@ -lm
+@@ -49,11 +49,11 @@
+ ( cd .. && $(MAKE) nettle-internal.$(OBJEXT))
+
+ # For Solaris and BSD make, we have to use an explicit rule for each executable
+-next-prime$(EXEEXT): next-prime.$(OBJEXT) $(GETOPT_OBJS) ../libhogweed.a
++next-prime$(EXEEXT): next-prime.$(OBJEXT) $(GETOPT_OBJS) ../$(LIBHOGWEED_FORLINK)
+ $(LINK) next-prime.$(OBJEXT) $(GETOPT_OBJS) \
+ -lhogweed -lnettle $(LIBS) -o next-prime$(EXEEXT)
+
+-random-prime$(EXEEXT): random-prime.$(OBJEXT) io.$(OBJEXT) $(GETOPT_OBJS) ../libhogweed.a
++random-prime$(EXEEXT): random-prime.$(OBJEXT) io.$(OBJEXT) $(GETOPT_OBJS) ../$(LIBHOGWEED_FORLINK)
+ $(LINK) random-prime.$(OBJEXT) io.$(OBJEXT) $(GETOPT_OBJS) \
+ -lhogweed -lnettle $(LIBS) -o random-prime$(EXEEXT)
+
+@@ -102,7 +102,7 @@
+ nettle-benchmark$(EXEEXT): $(BENCH_OBJS)
+ $(LINK) $(BENCH_OBJS) -lnettle $(BENCH_LIBS) $(OPENSSL_LIBFLAGS) -o nettle-benchmark$(EXEEXT)
+
+-$(TARGETS) : io.$(OBJEXT) ../libnettle.a
++$(TARGETS) : io.$(OBJEXT) ../$(LIBNETTLE_FORLINK)
+
+
+ check: $(TS_ALL)
+--- nettle-2.6/run-tests
++++ nettle-2.6/run-tests
+@@ -28,6 +28,8 @@
+
+ export srcdir
+
++export LD_LIBRARY_PATH="../.lib"
++
+ # When used in make rules, we sometimes get the filenames VPATH
+ # expanded, but usually not.
+ find_program () {
+--- nettle-2.6/testsuite/Makefile.in
++++ nettle-2.6/testsuite/Makefile.in
+@@ -8,7 +8,7 @@
+ include ../config.make
+
+ PRE_CPPFLAGS = -I.. -I$(top_srcdir)
+-PRE_LDFLAGS = -L..
++PRE_LDFLAGS = -L../.lib
+
+ TS_NETTLE_SOURCES = aes-test.c arcfour-test.c arctwo-test.c \
+ blowfish-test.c cast128-test.c \
+@@ -93,7 +93,7 @@
+ include $(srcdir)/.test-rules.make
+
+ $(TARGETS) $(EXTRA_TARGETS): testutils.$(OBJEXT) ../nettle-internal.$(OBJEXT) \
+- ../libnettle.a @IF_HOGWEED@ ../libhogweed.a
++ ../$(LIBNETTLE_FORLINK) @IF_HOGWEED@ ../$(LIBHOGWEED_FORLINK)
+
+ # For use as, e.g.,
+ #
+--- nettle-2.6/tools/Makefile.in
++++ nettle-2.6/tools/Makefile.in
+@@ -15,7 +15,7 @@
+ include ../config.make
+
+ PRE_CPPFLAGS = -I.. -I$(top_srcdir)
+-PRE_LDFLAGS = -L..
++PRE_LDFLAGS = -L../.lib
+
+ HOGWEED_TARGETS = pkcs1-conv$(EXEEXT)
+ TARGETS = sexp-conv$(EXEEXT) nettle-hash$(EXEEXT) nettle-lfib-stream$(EXEEXT) \
+@@ -34,19 +34,19 @@
+ DISTFILES = $(SOURCES) Makefile.in input.h misc.h output.h parse.h
+
+ sexp_conv_OBJS = $(sexp_conv_SOURCES:.c=.$(OBJEXT)) $(getopt_OBJS)
+-sexp-conv$(EXEEXT): $(sexp_conv_OBJS) ../libnettle.a
++sexp-conv$(EXEEXT): $(sexp_conv_OBJS) ../$(LIBNETTLE_FORLINK)
+ $(LINK) $(sexp_conv_OBJS) -lnettle $(LIBS) -o $@
+
+-nettle-lfib-stream$(EXEEXT): nettle-lfib-stream.$(OBJEXT) ../libnettle.a
++nettle-lfib-stream$(EXEEXT): nettle-lfib-stream.$(OBJEXT) ../$(LIBNETTLE_FORLINK)
+ $(LINK) nettle-lfib-stream.$(OBJEXT) -lnettle $(LIBS) -o $@
+
+ pkcs1_conv_OBJS = $(pkcs1_conv_SOURCES:.c=.$(OBJEXT)) $(getopt_OBJS)
+-pkcs1-conv$(EXEEXT): $(pkcs1_conv_OBJS) ../libnettle.a ../libhogweed.a
++pkcs1-conv$(EXEEXT): $(pkcs1_conv_OBJS) ../$(LIBNETTLE_FORLINK) ../$(LIBHOGWEED_FORLINK)
+ $(LINK) $(pkcs1_conv_OBJS) -lhogweed -lnettle $(LIBS) -o $@
+
+ # FIXME: Avoid linking with gmp
+ nettle_hash_OBJS = $(nettle_hash_SOURCES:.c=.$(OBJEXT)) $(getopt_OBJS)
+-nettle-hash$(EXEEXT): $(nettle_hash_OBJS) ../libnettle.a
++nettle-hash$(EXEEXT): $(nettle_hash_OBJS) ../$(LIBNETTLE_FORLINK)
+ $(LINK) $(nettle_hash_OBJS) -lnettle $(LIBS) -o $@
+
+
diff --git a/dev-libs/nettle/nettle-2.6.ebuild b/dev-libs/nettle/nettle-2.6.ebuild
new file mode 100644
index 000000000000..e17ff43ff867
--- /dev/null
+++ b/dev-libs/nettle/nettle-2.6.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/nettle-2.6.ebuild,v 1.1 2013/01/18 00:57:24 radhermit Exp $
+
+EAPI="5"
+
+inherit eutils autotools
+
+DESCRIPTION="Low-level cryptographic library"
+HOMEPAGE="http://www.lysator.liu.se/~nisse/nettle/"
+SRC_URI="http://www.lysator.liu.se/~nisse/archive/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-3 LGPL-2.1 )"
+SLOT="0/4" # subslot = libnettle soname version
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc +gmp static-libs test"
+
+DEPEND="gmp? ( dev-libs/gmp )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-shared.patch
+ sed -e '/CFLAGS=/s: -ggdb3::' \
+ -e 's/solaris\*)/sunldsolaris*)/' \
+ -i configure.ac || die
+
+ # conditionally build tests and examples required by tests
+ use test || sed -i '/SUBDIRS/s/testsuite.*//' Makefile.in || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # --disable-openssl bug #427526
+ econf \
+ $(use_enable gmp public-key) \
+ $(use_enable static-libs static) \
+ $(use_enable doc documentation) \
+ --disable-openssl
+}
+
+src_test() {
+ cd testsuite
+
+ # symbols test requires static libs
+ use static-libs || rm symbols-test || die
+
+ ../run-tests || die
+}
+
+src_install() {
+ default
+
+ if use doc ; then
+ dohtml nettle.html
+ dodoc nettle.pdf
+ fi
+}