summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-04-02 03:28:10 +0000
committerChris Reffett <creffett@gentoo.org>2013-04-02 03:28:10 +0000
commitb0b885b64975cff40e5cfe107020535b27e158dd (patch)
treea76e9fa796b99a7120debbfb28425a7dc38d4f76 /dev-libs
parentRevert previous due to breakage. (diff)
downloadgentoo-2-b0b885b64975cff40e5cfe107020535b27e158dd.tar.gz
gentoo-2-b0b885b64975cff40e5cfe107020535b27e158dd.tar.bz2
gentoo-2-b0b885b64975cff40e5cfe107020535b27e158dd.zip
Version bump wrt bug 463280. Respin pkgconfig patch, no longer need the crypto patch. Some tests failing, restricting for now until I have a chance to look at them more.
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libzip/ChangeLog10
-rw-r--r--dev-libs/libzip/files/libzip-0.11-fix_pkgconfig.patch16
-rw-r--r--dev-libs/libzip/libzip-0.11.ebuild58
3 files changed, 83 insertions, 1 deletions
diff --git a/dev-libs/libzip/ChangeLog b/dev-libs/libzip/ChangeLog
index 6e669c321087..fdb44313469a 100644
--- a/dev-libs/libzip/ChangeLog
+++ b/dev-libs/libzip/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-libs/libzip
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libzip/ChangeLog,v 1.57 2013/03/11 13:01:20 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libzip/ChangeLog,v 1.58 2013/04/02 03:28:10 creffett Exp $
+
+*libzip-0.11 (02 Apr 2013)
+
+ 02 Apr 2013; Chris Reffett <creffett@gentoo.org>
+ +files/libzip-0.11-fix_pkgconfig.patch, +libzip-0.11.ebuild:
+ Version bump wrt bug 463280. Respin pkgconfig patch, no longer need the crypto
+ patch. Some tests failing, restricting for now until I have a chance to look
+ at them more.
11 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> libzip-0.10.1-r1.ebuild:
Convert remove_libtool_files to prune_libtool_files.
diff --git a/dev-libs/libzip/files/libzip-0.11-fix_pkgconfig.patch b/dev-libs/libzip/files/libzip-0.11-fix_pkgconfig.patch
new file mode 100644
index 000000000000..ff3e8155b944
--- /dev/null
+++ b/dev-libs/libzip/files/libzip-0.11-fix_pkgconfig.patch
@@ -0,0 +1,16 @@
+--- a/libzip.pc.in
++++ b/libzip.pc.in
+@@ -2,7 +2,6 @@
+ exec_prefix=@exec_prefix@
+ libdir=@libdir@
+ includedir=@includedir@
+-libincludedir=@libdir@/@PACKAGE@/include
+
+ zipcmp=@prefix@/bin/zipcmp
+
+@@ -10,5 +9,4 @@
+ Description: library for handling zip archives
+ Version: @VERSION@
+ Libs: -L${libdir} -lzip @LIBS@
+-Cflags: -I${includedir} -I${libincludedir}
+
diff --git a/dev-libs/libzip/libzip-0.11.ebuild b/dev-libs/libzip/libzip-0.11.ebuild
new file mode 100644
index 000000000000..682fa293712d
--- /dev/null
+++ b/dev-libs/libzip/libzip-0.11.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libzip/libzip-0.11.ebuild,v 1.1 2013/04/02 03:28:10 creffett Exp $
+
+EAPI=5
+
+MY_P=${P/_}
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils eutils
+
+DESCRIPTION="Library for manipulating zip archives"
+HOMEPAGE="http://www.nih.at/libzip/"
+SRC_URI="http://www.nih.at/libzip/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="static-libs"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+DOCS=( NEWS README THANKS AUTHORS )
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.10_rc1-fix_headers.patch"
+ "${FILESDIR}/${PN}-0.11-fix_pkgconfig.patch"
+)
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+RESTRICT="test"
+
+src_prepare() {
+ autotools-utils_src_prepare
+ # run due to fix_headers patch
+ AT_NOELIBTOOLIZE=yes eautoreconf
+ #elibtoolize # FreeBSD .so version
+
+ # fix test return state
+ sed -i \
+ -e 's:19/2:19/0:' \
+ regress/open_nonarchive.test || die
+}
+
+src_install() {
+ autotools-utils_src_install
+ prune_libtool_files --all
+}
+
+src_test() {
+ #Having VERBOSE as an env variable causes the fread test to fail (bug 421651)
+ unset VERBOSE
+ autotools-utils_src_test
+}