summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-06-27 16:43:58 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-06-27 16:43:58 +0000
commitaaf4aac55bd3edea1411f6e939c9519d601383d4 (patch)
tree9ebbea90d5993f3840e5439110f39b3cad1b4eaa /dev-libs
parentRevision bump: EAPI 5, autotools-utils eclass, install static libraries condi... (diff)
downloadgentoo-2-aaf4aac55bd3edea1411f6e939c9519d601383d4.tar.gz
gentoo-2-aaf4aac55bd3edea1411f6e939c9519d601383d4.tar.bz2
gentoo-2-aaf4aac55bd3edea1411f6e939c9519d601383d4.zip
version bump for tl2013
(Portage version: 2.2.0_alpha185/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/ptexenc/ChangeLog8
-rw-r--r--dev-libs/ptexenc/ptexenc-1.3.1_p20130530.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-libs/ptexenc/ChangeLog b/dev-libs/ptexenc/ChangeLog
index 2349d54b33da..59e7d8f2b380 100644
--- a/dev-libs/ptexenc/ChangeLog
+++ b/dev-libs/ptexenc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/ptexenc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ptexenc/ChangeLog,v 1.42 2013/06/26 14:37:55 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ptexenc/ChangeLog,v 1.43 2013/06/27 16:43:58 aballier Exp $
+
+*ptexenc-1.3.1_p20130530 (26 Jun 2013)
+
+ 26 Jun 2013; Alexis Ballier <aballier@gentoo.org>
+ +ptexenc-1.3.1_p20130530.ebuild:
+ version bump for tl2013
26 Jun 2013; Alexis Ballier <aballier@gentoo.org>
-ptexenc-1.2.0_p20110705.ebuild:
diff --git a/dev-libs/ptexenc/ptexenc-1.3.1_p20130530.ebuild b/dev-libs/ptexenc/ptexenc-1.3.1_p20130530.ebuild
new file mode 100644
index 000000000000..f34a005eef4e
--- /dev/null
+++ b/dev-libs/ptexenc/ptexenc-1.3.1_p20130530.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ptexenc/ptexenc-1.3.1_p20130530.ebuild,v 1.1 2013/06/27 16:43:58 aballier Exp $
+
+EAPI=3
+
+inherit libtool
+
+DESCRIPTION="Library for Japanese pTeX providing a better way of handling character encodings"
+HOMEPAGE="http://tutimura.ath.cx/ptexlive/?ptexenc"
+SRC_URI="mirror://gentoo/texlive-${PV#*_p}-source.tar.xz"
+# http://tutimura.ath.cx/~nob/tex/ptexlive/ptexenc/${P}.tar.xz
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~ppc-macos ~x86-macos"
+IUSE="iconv static-libs"
+
+DEPEND="iconv? ( virtual/libiconv )
+ dev-libs/kpathsea"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/texlive-${PV#*_p}-source/texk/${PN}
+
+src_prepare() {
+ default
+
+ # https://bugs.gentoo.org/show_bug.cgi?id=377141
+ sed -i '/^LIBS/s:@LIBS@:@LIBS@ @KPATHSEA_LIBS@:' "${S}"/Makefile.in || die
+
+ cd "${WORKDIR}/texlive-${PV#*_p}-source"
+ S="${WORKDIR}/texlive-${PV#*_p}-source" elibtoolize #sane .so versionning on gfbsd
+}
+
+src_configure() {
+ econf \
+ --with-system-kpathsea \
+ $(use_enable static-libs static) \
+ $(use_enable iconv kanji-iconv)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ find "${D}" -name '*.la' -delete
+
+ dodoc ChangeLog README || die
+}