summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-01-14 04:54:24 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-01-14 04:54:24 +0000
commitaa6128ddbed39d219e45e251b47fcdf8be9e6d06 (patch)
treec9c449d5422fdf3732ff0d1acd36e3b9ac6620e2 /dev-libs
parentkeyword ~amd64-linux (diff)
downloadgentoo-2-aa6128ddbed39d219e45e251b47fcdf8be9e6d06.tar.gz
gentoo-2-aa6128ddbed39d219e45e251b47fcdf8be9e6d06.tar.bz2
gentoo-2-aa6128ddbed39d219e45e251b47fcdf8be9e6d06.zip
Bump, fixes several crashes, including in gnome-shell when using certain third-party extensions.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/gjs/ChangeLog10
-rw-r--r--dev-libs/gjs/gjs-1.30.1.ebuild65
2 files changed, 73 insertions, 2 deletions
diff --git a/dev-libs/gjs/ChangeLog b/dev-libs/gjs/ChangeLog
index 0e3704c5ed21..4a05545e6431 100644
--- a/dev-libs/gjs/ChangeLog
+++ b/dev-libs/gjs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/gjs
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gjs/ChangeLog,v 1.4 2011/11/15 09:06:58 nirbheek Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gjs/ChangeLog,v 1.5 2012/01/14 04:54:24 tetromino Exp $
+
+*gjs-1.30.1 (14 Jan 2012)
+
+ 14 Jan 2012; Alexandre Rostovtsev <tetromino@gentoo.org> +gjs-1.30.1.ebuild:
+ Bump, fixes several crashes, including in gnome-shell when using certain
+ third-party extensions.
15 Nov 2011; Nirbheek Chauhan <nirbheek@gentoo.org> gjs-1.30.0.ebuild:
Port to EAPI 4
diff --git a/dev-libs/gjs/gjs-1.30.1.ebuild b/dev-libs/gjs/gjs-1.30.1.ebuild
new file mode 100644
index 000000000000..56055b23fdd9
--- /dev/null
+++ b/dev-libs/gjs/gjs-1.30.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gjs/gjs-1.30.1.ebuild,v 1.1 2012/01/14 04:54:24 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_DEPEND="2"
+
+inherit gnome2 python virtualx
+
+DESCRIPTION="Javascript bindings for GNOME"
+HOMEPAGE="http://live.gnome.org/Gjs"
+
+LICENSE="MIT MPL-1.1 LGPL-2 GPL-2"
+SLOT="0"
+IUSE="examples test"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-libs/glib-2.18:2
+ >=dev-libs/gobject-introspection-1.29.16
+
+ dev-libs/dbus-glib
+ sys-libs/readline
+ x11-libs/cairo
+ >=dev-lang/spidermonkey-1.8.5"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.9"
+
+pkg_setup() {
+ # AUTHORS, ChangeLog are empty
+ DOCS="NEWS README"
+ # FIXME: add systemtap/dtrace support, like in glib:2
+ # FIXME: --enable-systemtap installs files in ${D}/${D} for some reason
+ # XXX: Do NOT enable coverage, completely useless for portage installs
+ G2CONF="${G2CONF}
+ --with-js-package=mozjs185
+ --disable-systemtap
+ --disable-dtrace
+ --disable-coverage"
+
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ gnome2_src_prepare
+ python_convert_shebangs 2 "${S}"/scripts/make-tests
+}
+
+src_test() {
+ # Tests need dbus
+ Xemake check
+}
+
+src_install() {
+ # installation sometimes fails in parallel
+ gnome2_src_install -j1
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins ${S}/examples/*
+ fi
+}