summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoel Martin <kanaka@gentoo.org>2007-06-29 19:46:07 +0000
committerJoel Martin <kanaka@gentoo.org>2007-06-29 19:46:07 +0000
commitaa59b8143dcd64fca39796187ba5b071e009e5df (patch)
treecf9def45c6adb14a124b6eaada7f8998b16f8ad4 /dev-libs
parentversion bump (diff)
downloadgentoo-2-aa59b8143dcd64fca39796187ba5b071e009e5df.tar.gz
gentoo-2-aa59b8143dcd64fca39796187ba5b071e009e5df.tar.bz2
gentoo-2-aa59b8143dcd64fca39796187ba5b071e009e5df.zip
Previous patch ineffective, this one modifies mkinstalldirs to be parallel safe instead.
(Portage version: 2.1.1)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libelf/ChangeLog11
-rw-r--r--dev-libs/libelf/files/libelf-0.8.9-parallelmakefix.patch23
2 files changed, 26 insertions, 8 deletions
diff --git a/dev-libs/libelf/ChangeLog b/dev-libs/libelf/ChangeLog
index ec190b0dc6b3..090248615c59 100644
--- a/dev-libs/libelf/ChangeLog
+++ b/dev-libs/libelf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libelf
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libelf/ChangeLog,v 1.20 2007/06/29 18:09:30 kanaka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libelf/ChangeLog,v 1.21 2007/06/29 19:46:07 kanaka Exp $
+
+ 29 Jun 2007; Joel Martin <kanaka@gentoo.org>
+ files/libelf-0.8.9-parallelmakefix.patch:
+ After discussion with maintainer, change mkinstalldirs to be
+ more parallel safe.
29 Jun 2007; Joel Martin <kanaka@gentoo.org>
files/libelf-0.8.9-parallelmakefix.patch:
@@ -12,13 +17,13 @@
*libelf-0.8.9 (17 Jun 2007)
- 17 Jun 2007; Tiziano Müller <dev-zero@gentoo.org> +libelf-0.8.9.ebuild:
+ 17 Jun 2007; Tiziano Müller <dev-zero@gentoo.org> +libelf-0.8.9.ebuild:
Version bump.
14 May 2007; Thilo Bangert <bangert@gentoo.org> metadata.xml:
add <herd>no-herd</herd>
- 22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
+ 22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
06 Jan 2007; Danny van Dyk <kugelfang@gentoo.org> -libelf-0.8.5.ebuild:
diff --git a/dev-libs/libelf/files/libelf-0.8.9-parallelmakefix.patch b/dev-libs/libelf/files/libelf-0.8.9-parallelmakefix.patch
index 67e36f76b67c..6a0eddfd0474 100644
--- a/dev-libs/libelf/files/libelf-0.8.9-parallelmakefix.patch
+++ b/dev-libs/libelf/files/libelf-0.8.9-parallelmakefix.patch
@@ -1,10 +1,6 @@
--- libelf-0.8.9/lib/Makefile.in.orig 2007-06-29 00:09:41.876160240 -0400
+++ libelf-0.8.9/lib/Makefile.in 2007-06-29 00:10:13.601337280 -0400
-@@ -171,10 +171,11 @@ installdirs: $(top_srcdir)/mkinstalldirs
-
- installdirs: $(top_srcdir)/mkinstalldirs
- dirs="$(installdirs)"; for dir in $$dirs; do \
-+ if test -d $(distsubdir); then continue; fi; \
+@@ -174,7 +174,7 @@ installdirs: $(top_srcdir)/mkinstalldirs
$(SHELL) $(top_srcdir)/mkinstalldirs $(instroot)$$dir; \
done
@@ -31,3 +27,20 @@
files="$(HDRS)"; for file in $$files; do \
if test -f $(instroot)$(includedir)/$$file; then true; else \
echo "#include <libelf/$$file>" > $(instroot)$(includedir)/$$file; \
+--- libelf-0.8.9/mkinstalldirs.orig 2007-06-29 15:22:54.048886832 -0400
++++ libelf-0.8.9/mkinstalldirs 2007-06-29 15:31:49.261522144 -0400
+@@ -23,7 +23,13 @@ for file in ${1+"$@"} ; do
+
+ if test ! -d "${pathcomp}"; then
+ echo "mkdir $pathcomp" 1>&2
+- mkdir "${pathcomp}" || errstatus=$?
++ mkdir "${pathcomp}"
++ tmpstatus=$?
++ if test "${tmpstatus}" != 0; then
++ # If there was an error but the dir exists
++ # then a race happened so ignore the error
++ test -d "${pathcomp}" || errstatus=${tmpstatus}
++ fi
+ fi
+
+ pathcomp="${pathcomp}/"