summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2008-03-11 00:28:40 +0000
committerMart Raudsepp <leio@gentoo.org>2008-03-11 00:28:40 +0000
commita98a4936ac3185a93d9ffd839b4f352e983789e0 (patch)
treefb94e77db70a28074806105c7fc1c9e596fc9854 /dev-libs
parentAdded some new packages for KDE 4.0.2. (diff)
downloadgentoo-2-a98a4936ac3185a93d9ffd839b4f352e983789e0.tar.gz
gentoo-2-a98a4936ac3185a93d9ffd839b4f352e983789e0.tar.bz2
gentoo-2-a98a4936ac3185a93d9ffd839b4f352e983789e0.zip
New major release. Major new features include: GIO - a virtual filesystem API designed to replace gnome-vfs, carrying support for local filesystems with gnome-base/gvfs containing backends for many other (samba, ftp, sftp, http, etc); GChecksum providing MD5, SHA-1 and SHA-256 algorithms for applications to use; GTest - a test framework
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/glib/ChangeLog11
-rw-r--r--dev-libs/glib/glib-2.16.0.ebuild86
2 files changed, 96 insertions, 1 deletions
diff --git a/dev-libs/glib/ChangeLog b/dev-libs/glib/ChangeLog
index c1245d0c200a..bad1449fe1d9 100644
--- a/dev-libs/glib/ChangeLog
+++ b/dev-libs/glib/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-libs/glib
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.311 2008/02/10 22:12:27 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.312 2008/03/11 00:28:40 leio Exp $
+
+*glib-2.16.0 (10 Mar 2008)
+
+ 10 Mar 2008; Mart Raudsepp <leio@gentoo.org> +glib-2.16.0.ebuild:
+ New major release. Major new features include: GIO - a virtual filesystem
+ API designed to replace gnome-vfs, carrying support for local filesystems
+ with gnome-base/gvfs containing backends for many other (samba, ftp, sftp,
+ http, etc); GChecksum providing MD5, SHA-1 and SHA-256 algorithms for
+ applications to use; GTest - a test framework
10 Feb 2008; Olivier Crête <tester@gentoo.org> glib-2.14.6.ebuild:
Stable on amd64, security bug #209293
diff --git a/dev-libs/glib/glib-2.16.0.ebuild b/dev-libs/glib/glib-2.16.0.ebuild
new file mode 100644
index 000000000000..7a23b24c6308
--- /dev/null
+++ b/dev-libs/glib/glib-2.16.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.16.0.ebuild,v 1.1 2008/03/11 00:28:40 leio Exp $
+
+inherit gnome.org libtool eutils flag-o-matic
+
+DESCRIPTION="The GLib library of C routines"
+HOMEPAGE="http://www.gtk.org/"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="debug doc fam hardened selinux xattr"
+
+RDEPEND="virtual/libc
+ virtual/libiconv
+ xattr? ( sys-apps/attr )
+ fam? ( virtual/fam )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.16
+ >=sys-devel/gettext-0.11
+ doc? (
+ >=dev-libs/libxslt-1.0
+ >=dev-util/gtk-doc-1.8
+ ~app-text/docbook-xml-dtd-4.1.2
+ )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if use ppc64 && use hardened ; then
+ replace-flags -O[2-3] -O1
+ epatch "${FILESDIR}/glib-2.6.3-testglib-ssp.patch"
+ fi
+
+ if use ia64 ; then
+ # Only apply for < 4.1
+ local major=$(gcc-major-version)
+ local minor=$(gcc-minor-version)
+ if (( major < 4 || ( major == 4 && minor == 0 ) )); then
+ epatch "${FILESDIR}/glib-2.10.3-ia64-atomic-ops.patch"
+ fi
+ fi
+
+ sed -e "s/MATCH_LIMIT_RECURSION=10000000/MATCH_LIMIT_RECURSION=8192/g" \
+ -i "${S}/glib/pcre/Makefile.in" "${S}/glib/pcre/Makefile.am"
+
+ # Fix gmodule issues on fbsd; bug #184301
+ epatch "${FILESDIR}"/${PN}-2.12.12-fbsd.patch
+
+ [[ ${CHOST} == *-freebsd* ]] && elibtoolize
+}
+
+src_compile() {
+ local myconf
+
+ epunt_cxx
+
+ # Building with --disable-debug highly unrecommended. It will build glib in
+ # an unusable form as it disables some commonly used API. Please do not
+ # convert this to the use_enable form, as it results in a broken build.
+ # -- compnerd (3/27/06)
+ use debug && myconf="--enable-debug"
+
+ # always build static libs, see #153807
+ econf ${myconf} \
+ $(use_enable xattr) \
+ $(use_enable doc man) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable fam) \
+ $(use_enable selinux) \
+ --enable-static \
+ --with-threads=posix || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ # Do not install charset.alias even if generated, leave it to libiconv
+ rm -f "${D}/usr/lib/charset.alias"
+
+ dodoc AUTHORS ChangeLog* NEWS* README
+}