summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-28 06:50:51 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-28 06:50:51 +0000
commita98921f3362216af4f911a1a5011f7ae6b83092e (patch)
treee366bb6608b80bdc29441185b111c311e08a2126 /dev-libs
parentgcc-3.4 patch #49238 (diff)
downloadgentoo-2-a98921f3362216af4f911a1a5011f7ae6b83092e.tar.gz
gentoo-2-a98921f3362216af4f911a1a5011f7ae6b83092e.tar.bz2
gentoo-2-a98921f3362216af4f911a1a5011f7ae6b83092e.zip
add -ldl fix for arm
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/openssl/openssl-0.9.7d.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-libs/openssl/openssl-0.9.7d.ebuild b/dev-libs/openssl/openssl-0.9.7d.ebuild
index 3cf2a5d4ace5..5516eeaae364 100644
--- a/dev-libs/openssl/openssl-0.9.7d.ebuild
+++ b/dev-libs/openssl/openssl-0.9.7d.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.7d.ebuild,v 1.8 2004/04/26 04:50:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.7d.ebuild,v 1.9 2004/04/28 06:50:51 vapier Exp $
inherit eutils flag-o-matic gcc
@@ -40,6 +40,12 @@ src_unpack() {
# Fix detection of parisc running 64 bit kernel
sed -i -e 's/parisc-\*-linux2/parisc\*-\*-linux2/' config
fi
+ if [ "${ARCH}" = "arm" ]; then
+ # patch linker to add -ldl or things linking aginst libcrypto fail
+ sed -i -e \
+ 's!^"linux-elf-arm"\(.*\)::BN\(.*\)!"linux-elf-arm"\1:-ldl:BN\2!' \
+ Configure
+ fi
if [ "${ARCH}" = "alpha" -a "${CC}" != "ccc" ]; then
# ccc compiled openssl will break things linked against
# a gcc compiled openssl, the configure will automatically detect