summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-05-30 18:32:10 +0000
committerSven Wegener <swegener@gentoo.org>2005-05-30 18:32:10 +0000
commita55ee3ab3e6ac455200c5d53f35a67c428fa1191 (patch)
tree21183bb04e0fd22d0a5d048d36bd6fbb7a02d53a /dev-libs
parentRemoved unneeded use of gcc.eclass. (diff)
downloadgentoo-2-a55ee3ab3e6ac455200c5d53f35a67c428fa1191.tar.gz
gentoo-2-a55ee3ab3e6ac455200c5d53f35a67c428fa1191.tar.bz2
gentoo-2-a55ee3ab3e6ac455200c5d53f35a67c428fa1191.zip
Moved from gcc.eclass to toolchain-funcs.eclass, bug #92745.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/xalan-c/ChangeLog7
-rw-r--r--dev-libs/xalan-c/xalan-c-1.7.0.ebuild8
2 files changed, 9 insertions, 6 deletions
diff --git a/dev-libs/xalan-c/ChangeLog b/dev-libs/xalan-c/ChangeLog
index b1d04e376d8e..cf98b2ffabf3 100644
--- a/dev-libs/xalan-c/ChangeLog
+++ b/dev-libs/xalan-c/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/xalan-c
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xalan-c/ChangeLog,v 1.3 2004/11/11 01:17:27 vapier Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xalan-c/ChangeLog,v 1.4 2005/05/30 18:28:55 swegener Exp $
+
+ 30 May 2005; Sven Wegener <swegener@gentoo.org> xalan-c-1.7.0.ebuild:
+ Moved from gcc.eclass to toolchain-funcs.eclass, bug #92745.
*xalan-c-1.8.0 (10 Nov 2004)
diff --git a/dev-libs/xalan-c/xalan-c-1.7.0.ebuild b/dev-libs/xalan-c/xalan-c-1.7.0.ebuild
index 73e482cee783..13558f515587 100644
--- a/dev-libs/xalan-c/xalan-c-1.7.0.ebuild
+++ b/dev-libs/xalan-c/xalan-c-1.7.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xalan-c/xalan-c-1.7.0.ebuild,v 1.6 2004/11/11 01:17:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xalan-c/xalan-c-1.7.0.ebuild,v 1.7 2005/05/30 18:28:55 swegener Exp $
-inherit gcc
+inherit toolchain-funcs
MY_PV=${PV//./_}
DESCRIPTION="XSLT processor for transforming XML into HTML, text, or other XML types"
@@ -23,7 +23,7 @@ S=${WORKDIR}/xml-xalan/c
src_compile() {
export XALANCROOT=${S}
export XERCESCROOT="/usr/include/xercesc"
- ./runConfigure -p linux -c "$(gcc-getCC)" -x "$(gcc-getCXX)" -P /usr || die
+ ./runConfigure -p linux -c "$(tc-getCC)" -x "$(tc-getCXX)" -P /usr || die
emake -j1 || die
}