summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryon Roche <kain@gentoo.org>2002-09-17 11:46:56 +0000
committerBryon Roche <kain@gentoo.org>2002-09-17 11:46:56 +0000
commit9c69f3cc54e9c49d24e0bbe0eff2695aec8ee7e8 (patch)
treea1b77ec9510a997d70ccd7ead14dacae0c8b4640 /dev-libs
parentAlso mask my impending saslv1 fix (diff)
downloadgentoo-2-9c69f3cc54e9c49d24e0bbe0eff2695aec8ee7e8.tar.gz
gentoo-2-9c69f3cc54e9c49d24e0bbe0eff2695aec8ee7e8.tar.bz2
gentoo-2-9c69f3cc54e9c49d24e0bbe0eff2695aec8ee7e8.zip
Also fixes for cyrus sasl 1.5.27; also slotted these since they could
conceivably be installed concurrently.
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/cyrus-sasl/ChangeLog6
-rw-r--r--dev-libs/cyrus-sasl/cyrus-sasl-1.5.27-r5.ebuild98
-rw-r--r--dev-libs/cyrus-sasl/cyrus-sasl-2.1.7-r2.ebuild4
-rw-r--r--dev-libs/cyrus-sasl/files/digest-cyrus-sasl-1.5.27-r51
4 files changed, 104 insertions, 5 deletions
diff --git a/dev-libs/cyrus-sasl/ChangeLog b/dev-libs/cyrus-sasl/ChangeLog
index fa4b9b8ccf81..e8c8ffb53701 100644
--- a/dev-libs/cyrus-sasl/ChangeLog
+++ b/dev-libs/cyrus-sasl/ChangeLog
@@ -1,12 +1,12 @@
# ChangeLog for dev-libs/cyrus-sasl
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/ChangeLog,v 1.20 2002/09/17 09:37:57 kain Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/ChangeLog,v 1.21 2002/09/17 11:46:56 kain Exp $
*cyrus-sasl-2.1.7-r2 (17 Sep 2002)
17 Sep 2002; Bryon Roche <kain@kain.org>
- cyrus-sasl-2.1.7-r2.ebuild, files/digest-cyrus-sasl-2.1.7-r2,
- files/cyrus-sasl-gcc32.patch :
+ cyrus-sasl-1.5.27-r5.ebuild, cyrus-sasl-2.1.7-r2.ebuild,
+ files/digest-cyrus-sasl-2.1.7-r2, files/cyrus-sasl-gcc32.patch :
Kerberos 5 fix and a fix for GCC 3.2
*cyrus-sasl-2.1.7-r1 (23 Aug 2002)
diff --git a/dev-libs/cyrus-sasl/cyrus-sasl-1.5.27-r5.ebuild b/dev-libs/cyrus-sasl/cyrus-sasl-1.5.27-r5.ebuild
new file mode 100644
index 000000000000..cfb6ad4db474
--- /dev/null
+++ b/dev-libs/cyrus-sasl/cyrus-sasl-1.5.27-r5.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/cyrus-sasl-1.5.27-r5.ebuild,v 1.1 2002/09/17 11:46:56 kain Exp $
+
+DESCRIPTION="The Cyrus SASL (Simple Authentication and Security Layer)"
+HOMEPAGE="http://asg.web.cmu.edu/cyrus/"
+
+S=${WORKDIR}/${P}
+SRC_URI="ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/${P}.tar.gz"
+LICENSE="as-is"
+SLOT="1"
+KEYWORDS="x86 sparc sparc64"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/db-3.2
+ >=sys-libs/pam-0.75
+ kerberos? ( >=app-crypt/krb5-1.2.5 )"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/automake-1.6.1-r2"
+# need automake for fixed automake-1.5 support.
+
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ # some nice patches... thanks mandrake ;-)
+ patch -p1 < ${FILESDIR}/${PN}-1.5.21-des.patch || die
+ patch -p1 < ${FILESDIR}/${PN}-configdir.patch || die
+ patch -p1 < ${FILESDIR}/${PN}-saslauthd.patch || die
+ patch -p1 < ${FILESDIR}/${PN}-1.5.24-rpath.patch || die
+ patch -p0 < ${FILESDIR}/${PN}-1.5.27-scram.patch || die
+
+ # fix gcc3.2 brokenness
+ patch -p0 < ${FILESDIR}/${PN}-gcc32.patch || die
+
+ # this script distributed with the package is too
+ # old, so remove it, as "automake --add-missing"
+ # will install the new one if its not found.
+ rm -f ${S}/config/missing
+
+ libtoolize --copy --force
+ export WANT_AUTOMAKE_1_5=1
+ aclocal -I cmulocal || die
+ automake --add-missing || die
+ autoconf || die
+}
+
+src_compile() {
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib \
+ --mandir=/usr/share/man \
+ --with-configdir=/etc/sasl \
+ --with-pwcheck=/var/lib/sasl \
+ --with-plugindir=/usr/lib/sasl \
+ --with-saslauthd=/var/lib/sasl \
+ --with-dbpath=/var/lib/sasl/sasl.db \
+ --with-des \
+ --with-rc4 \
+ --enable-pam \
+ --enable-anon \
+ --enable-cram \
+ --with-gnu-ld \
+ --enable-scram \
+ --enable-plain \
+ --enable-login \
+ --disable-krb4 \
+ --enable-static \
+ --enable-shared \
+ --without-mysql \
+ --enable-digest \
+ --enable-gssapi \
+ --disable-sample \
+ --with-dblib=berkeley \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ make || die "compile problem"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc COPYING AUTHORS INSTALL NEWS README* TODO \
+ ChangeLog testing.txt doc/*.txt
+ docinto examples ; dodoc sample/{*.[ch],Makefile}
+ newdoc pwcheck/README README.pwcheck
+ dohtml doc/*
+
+ insinto /etc/conf.d ; newins ${FILESDIR}/saslauthd.confd saslauthd
+ exeinto /etc/init.d ; newexe ${FILESDIR}/saslauthd.rc6 saslauthd
+ exeinto /etc/init.d ; newexe ${FILESDIR}/pwcheck.rc6 pwcheck
+}
+
+pkg_postinst() {
+ # empty directories..
+ install -d -m0755 ${ROOT}/var/lib/sasl
+ install -d -m0755 ${ROOT}/etc/sasl
+}
diff --git a/dev-libs/cyrus-sasl/cyrus-sasl-2.1.7-r2.ebuild b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.7-r2.ebuild
index ab8fa1cb39a0..8839f7fba1c1 100644
--- a/dev-libs/cyrus-sasl/cyrus-sasl-2.1.7-r2.ebuild
+++ b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.7-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/cyrus-sasl-2.1.7-r2.ebuild,v 1.1 2002/09/17 09:37:57 kain Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/cyrus-sasl-2.1.7-r2.ebuild,v 1.2 2002/09/17 11:46:56 kain Exp $
S=${WORKDIR}/${P}
@@ -9,7 +9,7 @@ HOMEPAGE="http://asg.web.cmu.edu/sasl/"
SRC_URI="ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/${P}.tar.gz"
LICENSE="as-is"
-SLOT="0"
+SLOT="2"
KEYWORDS="x86 -ppc -sparc -sparc64"
RDEPEND=">=sys-libs/db-3.2
diff --git a/dev-libs/cyrus-sasl/files/digest-cyrus-sasl-1.5.27-r5 b/dev-libs/cyrus-sasl/files/digest-cyrus-sasl-1.5.27-r5
new file mode 100644
index 000000000000..477dd8cc141c
--- /dev/null
+++ b/dev-libs/cyrus-sasl/files/digest-cyrus-sasl-1.5.27-r5
@@ -0,0 +1 @@
+MD5 76ea426e2e2da3b8d2e3a43af5488f3b cyrus-sasl-1.5.27.tar.gz 528252