summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2013-09-24 22:51:43 +0000
committerJory Pratt <anarchy@gentoo.org>2013-09-24 22:51:43 +0000
commit9c168c29343c707b97472c7529774a054718f3bc (patch)
treea0c75f3cfd9b301f94aee7d12541b407548951c5 /dev-libs
parentAdd arm love for ChromiumOS. (diff)
downloadgentoo-2-9c168c29343c707b97472c7529774a054718f3bc.tar.gz
gentoo-2-9c168c29343c707b97472c7529774a054718f3bc.tar.bz2
gentoo-2-9c168c29343c707b97472c7529774a054718f3bc.zip
Version bump, bug #482050
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xB4D088B4)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/jemalloc/ChangeLog7
-rw-r--r--dev-libs/jemalloc/jemalloc-3.4.0.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-libs/jemalloc/ChangeLog b/dev-libs/jemalloc/ChangeLog
index fac5188f4ef2..fa70164a1ce8 100644
--- a/dev-libs/jemalloc/ChangeLog
+++ b/dev-libs/jemalloc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/jemalloc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/jemalloc/ChangeLog,v 1.33 2013/07/29 12:28:53 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/jemalloc/ChangeLog,v 1.34 2013/09/24 22:51:43 anarchy Exp $
+
+*jemalloc-3.4.0 (24 Sep 2013)
+
+ 24 Sep 2013; Jory A. Pratt <anarchy@gentoo.org> +jemalloc-3.4.0.ebuild:
+ Version bump, bug #482050
29 Jul 2013; Fabian Groffen <grobian@gentoo.org> jemalloc-3.3.1.ebuild:
Fix install on Darwin by Hugh Nowlan, bug #437362
diff --git a/dev-libs/jemalloc/jemalloc-3.4.0.ebuild b/dev-libs/jemalloc/jemalloc-3.4.0.ebuild
new file mode 100644
index 000000000000..68445fab3e68
--- /dev/null
+++ b/dev-libs/jemalloc/jemalloc-3.4.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/jemalloc/jemalloc-3.4.0.ebuild,v 1.1 2013/09/24 22:51:43 anarchy Exp $
+
+EAPI=4
+
+inherit autotools eutils
+
+DESCRIPTION="Jemalloc is a general-purpose scalable concurrent allocator"
+HOMEPAGE="http://www.canonware.com/jemalloc/"
+SRC_URI="http://www.canonware.com/download/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~x86 ~x64-macos"
+IUSE="debug static-libs stats"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${PN}-3.0.0-strip-optimization.patch" \
+ "${FILESDIR}/${PN}-3.0.0-no-pprof.patch" \
+ "${FILESDIR}/${PN}-3.0.0_fix_html_install.patch" \
+ "${FILESDIR}/${PN}-fix-ar-call.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable stats)
+}
+
+src_install() {
+ default
+ dohtml doc/jemalloc.html
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # fixup install_name, #437362
+ install_name_tool \
+ -id "${EPREFIX}"/usr/$(get_libdir)/libjemalloc.1.dylib \
+ "${ED}"/usr/$(get_libdir)/libjemalloc.1.dylib || die
+ fi
+ use static-libs || find "${ED}" -name '*.a' -delete
+}