summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-30 09:13:23 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-30 09:13:23 +0000
commit96df6349be01e7c69f12e9325b2fc37f5c7e8009 (patch)
tree3e2befe470830b632aa8c7c7336a0297b7d3fdaf /dev-libs
parentFix building with -Wl,--as-needed wrt #325969 by Christian Faulhammer. (diff)
downloadgentoo-2-96df6349be01e7c69f12e9325b2fc37f5c7e8009.tar.gz
gentoo-2-96df6349be01e7c69f12e9325b2fc37f5c7e8009.tar.bz2
gentoo-2-96df6349be01e7c69f12e9325b2fc37f5c7e8009.zip
New addition
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/excelformat/ChangeLog10
-rw-r--r--dev-libs/excelformat/excelformat-100112.ebuild45
-rw-r--r--dev-libs/excelformat/files/100112-gcc.patch12
-rw-r--r--dev-libs/excelformat/metadata.xml7
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-libs/excelformat/ChangeLog b/dev-libs/excelformat/ChangeLog
new file mode 100644
index 000000000000..19f91698e62e
--- /dev/null
+++ b/dev-libs/excelformat/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-libs/excelformat
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/excelformat/ChangeLog,v 1.1 2010/06/30 09:13:22 jlec Exp $
+
+*excelformat-100112 (30 Jun 2010)
+
+ 30 Jun 2010; Justin Lecher <jlec@gentoo.org> +files/100112-gcc.patch,
+ +excelformat-100112.ebuild, +metadata.xml:
+ New addition
+
diff --git a/dev-libs/excelformat/excelformat-100112.ebuild b/dev-libs/excelformat/excelformat-100112.ebuild
new file mode 100644
index 000000000000..c9301540ab66
--- /dev/null
+++ b/dev-libs/excelformat/excelformat-100112.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/excelformat/excelformat-100112.ebuild,v 1.1 2010/06/30 09:13:22 jlec Exp $
+
+EAPI="3"
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Library for reading, writing, and editing of XLS (BIFF8 format) files"
+HOMEPAGE="http://www.codeproject.com/KB/office/ExcelFormat.aspx"
+SRC_URI="mirror://gentoo/${P}.zip"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="CPOL"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ edos2unix *
+ epatch "${FILESDIR}"/${PV}-gcc.patch
+}
+
+src_compile() {
+ for i in *.cpp; do
+ cmd="$(tc-getCXX) ${CXXFLAGS} -trigraphs -c $i"
+ einfo ${cmd}
+ ${cmd} || die
+ done
+ cmd="$(tc-getCXX) ${LDFLAGS} -Wl,-soname,libExcelFormat.so.0 -o libExcelFormat.so.0.0.0 `ls *.o`"
+ einfo ${cmd}
+ ${cmd} || die
+}
+
+src_install() {
+ insinto /usr/include/
+ doins BasicExcel.hpp ExcelFormat.h || die
+ dolib.so libExcelFormat.so.0.0.0 || die
+ dosym libExcelFormat.so.0.0.0 /usr/$(get_libdir)/libExcelFormat.so || die
+}
diff --git a/dev-libs/excelformat/files/100112-gcc.patch b/dev-libs/excelformat/files/100112-gcc.patch
new file mode 100644
index 000000000000..9d2c9841f059
--- /dev/null
+++ b/dev-libs/excelformat/files/100112-gcc.patch
@@ -0,0 +1,12 @@
+diff --git a/BasicExcel.cpp b/BasicExcel.cpp
+index 0cf56d9..e41dc3f 100644
+--- a/BasicExcel.cpp
++++ b/BasicExcel.cpp
+@@ -1,5 +1,7 @@
+ #include "ExcelFormat.h"
+
++#include <cstring>
++
+ #if _MSC_VER>=1400 // VS 2005
+ #include <share.h> // _SH_DENYRW
+ #endif
diff --git a/dev-libs/excelformat/metadata.xml b/dev-libs/excelformat/metadata.xml
new file mode 100644
index 000000000000..7190ba7dbb8d
--- /dev/null
+++ b/dev-libs/excelformat/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+</pkgmetadata>