summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-06-06 20:04:08 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-06-06 20:04:08 +0000
commit930d99333e183b0a918fec0d549444d90b3205fc (patch)
tree119fdacff6dd380c9a545b5cba40d1f9cf492dbc /dev-libs
parent262866 (diff)
downloadgentoo-2-930d99333e183b0a918fec0d549444d90b3205fc.tar.gz
gentoo-2-930d99333e183b0a918fec0d549444d90b3205fc.tar.bz2
gentoo-2-930d99333e183b0a918fec0d549444d90b3205fc.zip
Version bump. Respect LDFLAGS. Fix building with --as-needed (bug #272242).
(Portage version: 13628-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/botan/ChangeLog9
-rw-r--r--dev-libs/botan/botan-1.8.2.ebuild110
-rw-r--r--dev-libs/botan/files/botan-1.8.2-respect_LDFLAGS.patch20
3 files changed, 138 insertions, 1 deletions
diff --git a/dev-libs/botan/ChangeLog b/dev-libs/botan/ChangeLog
index 8bf9c538d329..b1927baefa5d 100644
--- a/dev-libs/botan/ChangeLog
+++ b/dev-libs/botan/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/botan
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/ChangeLog,v 1.37 2009/04/29 11:30:57 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/ChangeLog,v 1.38 2009/06/06 20:04:07 arfrever Exp $
+
+*botan-1.8.2 (06 Jun 2009)
+
+ 06 Jun 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +botan-1.8.2.ebuild, +files/botan-1.8.2-respect_LDFLAGS.patch:
+ Version bump. Respect LDFLAGS. Fix building with --as-needed (bug
+ #272242).
29 Apr 2009; Raúl Porcel <armin76@gentoo.org> botan-1.8.0.ebuild:
Add ~ia64 wrt #267773
diff --git a/dev-libs/botan/botan-1.8.2.ebuild b/dev-libs/botan/botan-1.8.2.ebuild
new file mode 100644
index 000000000000..1e7307c551fc
--- /dev/null
+++ b/dev-libs/botan/botan-1.8.2.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/botan-1.8.2.ebuild,v 1.1 2009/06/06 20:04:07 arfrever Exp $
+
+EAPI="2"
+
+inherit eutils multilib toolchain-funcs
+
+MY_PN="Botan"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="A C++ crypto library"
+HOMEPAGE="http://botan.randombit.net/"
+SRC_URI="http://files.randombit.net/botan/${MY_P}.tgz"
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+SLOT="0"
+LICENSE="BSD"
+IUSE="bzip2 gmp ssl threads zlib"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="bzip2? ( >=app-arch/bzip2-1.0.5 )
+ zlib? ( >=sys-libs/zlib-1.2.3 )
+ gmp? ( >=dev-libs/gmp-4.2.2 )
+ ssl? ( >=dev-libs/openssl-0.9.8g )"
+
+# configure.pl requires Getopt::Long, File::Spec, and File::Copy;
+# all seem included in dev-lang/perl ATM.
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-respect_LDFLAGS.patch"
+}
+
+src_configure() {
+ # Modules that should work under any semi-recent Unix
+ local modules="alloc_mmap,egd,fd_unix,posix_rt"
+ local disable_modules="proc_walk,unix_procs,cpu_counter"
+
+ if useq bzip2; then modules="${modules},bzip2"; fi
+ if useq zlib; then modules="${modules},zlib"; fi
+ if useq gmp; then modules="${modules},gnump"; fi
+ if useq ssl; then modules="${modules},openssl"; fi
+ if useq threads; then modules="${modules},pthreads"; else
+ disable_modules="${disable_modules},pthreads"
+ fi
+
+ # This is also supported on i586+ - hope this is correct.
+ # documention says sparc though not enables because of
+ # http://bugs.gentoo.org/show_bug.cgi?id=71760#c11
+
+ # If we have assembly code for this machine, use it
+ if [ "${ARCH}" = "x86" ]; then
+ modules="${modules},mp_ia32"
+ #below is untested.
+ #modules="${modules},mp_ia32,mulop_ia32,serpent_ia32,ia32_eng,md4_ia32,md5_ia32,sha1_ia32,asm_ia32"
+ elif [ "${ARCH}" = "amd64" ]; then
+ modules="${modules},mp_amd64"
+ # monty_amd64 and mulop_amd64 had compile failures 20090103 Botan-1.8
+ #disable_modules="${disable_modules},monty_generic,mulop_generic"
+ #modules="${modules},monty_amd64,mp_amd64,mulop_amd64"
+ elif [ "${ARCH}" = "alpha" -o "${ARCH}" = "ia64" -o \
+ "${ARCH}" = "ppc64" -o "${PROFILE_ARCH}" = "mips64" ]; then
+ modules="${modules},mp_asm64"
+ fi
+
+ # Enable v9 instructions for sparc64
+ if [ "${PROFILE_ARCH}" = "sparc64" ]; then
+ CHOSTARCH="sparc32-v9"
+ else
+ CHOSTARCH="$(echo ${CHOST} | cut -d - -f 1)"
+ fi
+
+ cd "${S}"
+ elog "Enabling modules: " ${modules}
+ elog "Disabling modules: " ${disable_modules}
+
+ # FIXME: We might actually be on *BSD or OS X...
+ ./configure.pl \
+ --prefix="${D}"/usr \
+ --libdir=/$(get_libdir) \
+ --docdir=/share/doc/ \
+ --cc=gcc \
+ --os=linux \
+ --cpu=${CHOSTARCH} \
+ --with-endian="$(tc-endian)" \
+ --with-tr1=system \
+ --enable-modules=${modules} \
+ --disable-modules=${disable_modules} \
+ || die "configure.pl failed"
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" AR="$(tc-getAR) crs" LIB_OPT="${CXXFLAGS}" MACH_OPT="" || die "emake failed"
+}
+
+src_test() {
+ chmod -R ugo+rX "${S}"
+ emake CXX="$(tc-getCXX)" CHECK_OPT="${CXXFLAGS}" check || die "emake check failed"
+ LD_LIBRARY_PATH="${S}" ./check --validate || die "validation tests failed"
+}
+
+src_install() {
+ make install || die "make install failed"
+ sed -i -e "s:${D}::g" \
+ "${D}"/usr/bin/botan-config \
+ "${D}"/usr/$(get_libdir)/pkgconfig/botan-1.8.pc || die 'bad sed'
+ mv "${D}"/usr/share/doc/Botan-${PV} "${D}"/usr/share/doc/${PF} || die "could not rename directory"
+}
diff --git a/dev-libs/botan/files/botan-1.8.2-respect_LDFLAGS.patch b/dev-libs/botan/files/botan-1.8.2-respect_LDFLAGS.patch
new file mode 100644
index 000000000000..bf354a5307e0
--- /dev/null
+++ b/dev-libs/botan/files/botan-1.8.2-respect_LDFLAGS.patch
@@ -0,0 +1,20 @@
+--- src/build-data/makefile/unix_shr.in
++++ src/build-data/makefile/unix_shr.in
+@@ -88,7 +88,7 @@
+ # Link Commands #
+ ##################################################
+ $(CHECK): $(LIBRARIES) $(CHECKOBJS)
+- $(CXX) $(CHECKOBJS) -L. -lbotan-@{var:version} $(LINK_TO) -o $(CHECK)
++ $(CXX) $(LDFLAGS) $(CHECKOBJS) -o $(CHECK) -L. -lbotan-@{var:version} $(LINK_TO)
+
+ $(STATIC_LIB): $(LIBOBJS)
+ $(RM) $(STATIC_LIB)
+@@ -96,7 +96,7 @@
+ $(RANLIB) $(STATIC_LIB)
+
+ $(SHARED_LIB): $(LIBOBJS)
+- $(SO_LINK_CMD) $(LINK_TO) $(LIBOBJS) -o $(SHARED_LIB)
++ $(SO_LINK_CMD) $(LDFLAGS) $(LIBOBJS) -o $(SHARED_LIB) $(LINK_TO)
+ $(LN) $(SHARED_LIB) $(SYMLINK)
+
+ ##################################################