summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2003-03-29 14:52:50 +0000
committerDylan Carlson <absinthe@gentoo.org>2003-03-29 14:52:50 +0000
commit89c0d7539391f311d85468934d24b154ab34d423 (patch)
tree359147b7e2c47e6783bac2a8e2d8a8ccaee4a9d2 /dev-libs
parentfixed type, removed dulpicate slot keywords. (diff)
downloadgentoo-2-89c0d7539391f311d85468934d24b154ab34d423.tar.gz
gentoo-2-89c0d7539391f311d85468934d24b154ab34d423.tar.bz2
gentoo-2-89c0d7539391f311d85468934d24b154ab34d423.zip
Initial import.
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/apr/ChangeLog9
-rw-r--r--dev-libs/apr/apr-0.9.2.ebuild61
-rw-r--r--dev-libs/apr/files/digest-apr-0.9.22
3 files changed, 72 insertions, 0 deletions
diff --git a/dev-libs/apr/ChangeLog b/dev-libs/apr/ChangeLog
new file mode 100644
index 000000000000..1e1c57541ca8
--- /dev/null
+++ b/dev-libs/apr/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-libs/apr
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/ChangeLog,v 1.1 2003/03/29 14:52:50 absinthe Exp $
+
+*apr-0.9.2 (29 Mar 2003)
+
+ 29 Mar 2003; Dylan Carlson <absinthe@gentoo.org> apr-0.9.2.ebuild:
+ Initial import.
+
diff --git a/dev-libs/apr/apr-0.9.2.ebuild b/dev-libs/apr/apr-0.9.2.ebuild
new file mode 100644
index 000000000000..9edd2a8b23b9
--- /dev/null
+++ b/dev-libs/apr/apr-0.9.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/apr-0.9.2.ebuild,v 1.1 2003/03/29 14:52:50 absinthe Exp $
+
+inherit libtool
+
+P1="apr-${PV}-alpha.tar.gz"
+P2="apr-util-${PV}-alpha.tar.gz"
+S="${WORKDIR}/${P}"
+S2="${WORKDIR}/${PN}-util-${PV}"
+
+DESCRIPTION="Apache's Portable Runtime Library."
+SRC_URI="http://www.apache.org/dist/apr/${P1}
+ http://www.apache.org/dist/apr/${P2}"
+HOMEPAGE="http://apr.apache.org/"
+
+DEPEND=">=sys-devel/autoconf-2.50
+ >=sys-devel/libtool-1.4"
+IUSE=""
+SLOT="0"
+LICENSE="Apache-1.1"
+KEYWORDS="~x86 ~sparc ~ppc"
+
+src_unpack() {
+ unpack ${P1}
+ unpack ${P2}
+}
+
+src_compile() {
+ cd ${S}
+ econf || die
+ emake || die
+
+ cd ${S2}
+ econf --with-apr=${S} || die
+ emake || die
+ mv STATUS STATUS.apr-util
+ mv CHANGES CHANGES.apr-util
+}
+
+src_install () {
+ cd ${S}
+ dobin apr-config
+ dolib libapr-0.la
+ dolib.so .libs/libapr-0.so.${PV}
+ dohtml docs/APRDesign.html docs/canonical_filenames.html docs/win32_builds.html
+ dodoc docs/doxygen.conf docs/incomplete_types docs/non_apr_programs CHANGES STATUS
+
+ dodir /usr/include/${PN}
+ insinto /usr/include/${PN}
+ doins ${S}/include/*
+
+ cd ${S2}
+ dobin apu-config
+ dolib libaprutil-0.la
+ dolib.so .libs/libaprutil-0.so.${PV}
+ dodoc CHANGES.apr-util STATUS.apr-util
+ dodir /usr/include/${PN}-util
+ insinto /usr/include/${PN}-util
+ doins ${S2}/include/*
+}
diff --git a/dev-libs/apr/files/digest-apr-0.9.2 b/dev-libs/apr/files/digest-apr-0.9.2
new file mode 100644
index 000000000000..b1ab5d177499
--- /dev/null
+++ b/dev-libs/apr/files/digest-apr-0.9.2
@@ -0,0 +1,2 @@
+MD5 ff6879715965d453d917938718e9c0c2 apr-0.9.2-alpha.tar.gz 921748
+MD5 fa8e4cd60961fc267f6f98d9df0af41a apr-util-0.9.2-alpha.tar.gz 577183