summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-09-16 11:30:39 +0000
committerPacho Ramos <pacho@gentoo.org>2012-09-16 11:30:39 +0000
commit85acfd46c28c2969dced944be61ebb026b9c3018 (patch)
tree0d0ed45bf34bf614801f0b19c5972f458e889ef9 /dev-libs
parentDrop myth support as gmyth is going away, bug #315565. Drop old. (diff)
downloadgentoo-2-85acfd46c28c2969dced944be61ebb026b9c3018.tar.gz
gentoo-2-85acfd46c28c2969dced944be61ebb026b9c3018.tar.bz2
gentoo-2-85acfd46c28c2969dced944be61ebb026b9c3018.zip
Drop versions still supporting libwww (#320253).
(Portage version: 2.1.11.17/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/xerces-c/ChangeLog7
-rw-r--r--dev-libs/xerces-c/metadata.xml2
-rw-r--r--dev-libs/xerces-c/xerces-c-3.1.0.ebuild95
-rw-r--r--dev-libs/xerces-c/xerces-c-3.1.1.ebuild97
4 files changed, 5 insertions, 196 deletions
diff --git a/dev-libs/xerces-c/ChangeLog b/dev-libs/xerces-c/ChangeLog
index 16d0fc0eab09..ed7343f5de3e 100644
--- a/dev-libs/xerces-c/ChangeLog
+++ b/dev-libs/xerces-c/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/xerces-c
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xerces-c/ChangeLog,v 1.102 2012/07/29 17:05:04 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xerces-c/ChangeLog,v 1.103 2012/09/16 11:30:39 pacho Exp $
+
+ 16 Sep 2012; Pacho Ramos <pacho@gentoo.org> -xerces-c-3.1.0.ebuild,
+ -xerces-c-3.1.1.ebuild, metadata.xml:
+ Drop versions still supporting libwww (#320253).
29 Jul 2012; Raúl Porcel <armin76@gentoo.org> xerces-c-3.1.1-r1.ebuild:
alpha/sparc stable wrt #409545
@@ -436,4 +440,3 @@
09 Jun 2003; <zhen@gentoo.org> xerces-c-2.3.0.ebuild:
Initial commit of this package, please ref bug # 15260
-
diff --git a/dev-libs/xerces-c/metadata.xml b/dev-libs/xerces-c/metadata.xml
index b3a8456dfe73..4ae03a969480 100644
--- a/dev-libs/xerces-c/metadata.xml
+++ b/dev-libs/xerces-c/metadata.xml
@@ -9,8 +9,6 @@
message loader and something else like icu or the native method as
transcoder and vice-versa, but this is a less common case and hard to
handle)</flag>
- <flag name='libwww'>Use the <pkg>net-libs/libwww</pkg> library for fetching
- URLs, instead of the builtin method</flag>
<flag name='threads'>Enable threading support through pthread (or other
libraries on AIX, IRIX, HPUX, Solars). Highly recommended</flag>
</use>
diff --git a/dev-libs/xerces-c/xerces-c-3.1.0.ebuild b/dev-libs/xerces-c/xerces-c-3.1.0.ebuild
deleted file mode 100644
index f5d06929171a..000000000000
--- a/dev-libs/xerces-c/xerces-c-3.1.0.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xerces-c/xerces-c-3.1.0.ebuild,v 1.7 2011/02/26 13:13:34 armin76 Exp $
-
-EAPI="2"
-
-inherit eutils
-
-DESCRIPTION="A validating XML parser written in a portable subset of C++."
-HOMEPAGE="http://xerces.apache.org/xerces-c/"
-SRC_URI="mirror://apache/xerces/c/3/sources/${P}.tar.gz"
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="curl doc iconv icu libwww sse2 static-libs threads elibc_Darwin elibc_FreeBSD"
-
-RDEPEND="icu? ( >=dev-libs/icu-4.2 )
- curl? ( net-misc/curl )
- libwww? ( net-libs/libwww )
- virtual/libiconv"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
-
-pkg_setup() {
- export ICUROOT="/usr"
-
- if use iconv && use icu ; then
- ewarn "This package can use iconv or icu for loading messages"
- ewarn "and transcoding, but not both. ICU will precede."
- fi
-}
-
-src_prepare() {
- sed -i \
- -e 's|$(prefix)/msg|$(DESTDIR)/$(prefix)/share/xerces-c/msg|' \
- src/xercesc/util/MsgLoaders/MsgCatalog/Makefile.in || die "sed failed"
-}
-
-src_configure() {
- local mloader="inmemory"
- use iconv && mloader="iconv"
- use icu && mloader="icu"
-
- local transcoder="gnuiconv"
- use elibc_FreeBSD && transcoder="iconv"
- use elibc_Darwin && transcoder="macosunicodeconverter"
- use icu && transcoder="icu"
- # for interix maybe: transcoder="windows"
-
- # 'cfurl' is only available on OSX and 'socket' isn't supposed to work.
- # But the docs aren't clear about it, so we would need some testing...
- local netaccessor="socket"
- use elibc_Darwin && netaccessor="cfurl"
- use libwww && netaccessor="libwww"
- use curl && netaccessor="curl"
-
- econf \
- --disable-pretty-make \
- $(use_enable static-libs static) \
- $(use_enable threads) \
- --enable-msgloader-${mloader} \
- --enable-netaccessor-${netaccessor} \
- --enable-transcoder-${transcoder} \
- $(use_enable sse2)
-}
-
-src_compile() {
- default
-
- if use doc ; then
- cd "${S}/doc"
- doxygen || die "making docs failed"
- fi
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "emake failed"
-
- use static-libs || rm "${D}"/lib*/*.la
-
- # To make sure an appropriate NLS msg file is around when using the iconv msgloader
- # ICU has the messages compiled in.
- if use iconv && ! use icu ; then
- doenvd "${FILESDIR}/50xerces-c"
- fi
-
- if use doc; then
- insinto /usr/share/doc/${PF}
- rm -rf samples/Makefile* samples/runConfigure samples/src/*/Makefile* samples/.libs
- doins -r samples
- dohtml -r doc/html/*
- fi
-
- dodoc CREDITS KEYS NOTICE README version.incl
-}
diff --git a/dev-libs/xerces-c/xerces-c-3.1.1.ebuild b/dev-libs/xerces-c/xerces-c-3.1.1.ebuild
deleted file mode 100644
index c81bcd88cd03..000000000000
--- a/dev-libs/xerces-c/xerces-c-3.1.1.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xerces-c/xerces-c-3.1.1.ebuild,v 1.1 2010/08/28 06:25:10 dev-zero Exp $
-
-EAPI="2"
-
-inherit eutils
-
-DESCRIPTION="A validating XML parser written in a portable subset of C++."
-HOMEPAGE="http://xerces.apache.org/xerces-c/"
-SRC_URI="mirror://apache/xerces/c/3/sources/${P}.tar.gz"
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="curl doc iconv icu libwww sse2 static-libs threads elibc_Darwin elibc_FreeBSD"
-
-RDEPEND="icu? ( >=dev-libs/icu-4.2 )
- curl? ( net-misc/curl )
- libwww? ( net-libs/libwww )
- virtual/libiconv"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
-
-pkg_setup() {
- export ICUROOT="/usr"
-
- if use iconv && use icu ; then
- ewarn "This package can use iconv or icu for loading messages"
- ewarn "and transcoding, but not both. ICU will precede."
- fi
-}
-
-src_prepare() {
- use threads || epatch "${FILESDIR}/${PV}-disable-thread-tests.patch"
-
- sed -i \
- -e 's|$(prefix)/msg|$(DESTDIR)/$(prefix)/share/xerces-c/msg|' \
- src/xercesc/util/MsgLoaders/MsgCatalog/Makefile.in || die "sed failed"
-}
-
-src_configure() {
- local mloader="inmemory"
- use iconv && mloader="iconv"
- use icu && mloader="icu"
-
- local transcoder="gnuiconv"
- use elibc_FreeBSD && transcoder="iconv"
- use elibc_Darwin && transcoder="macosunicodeconverter"
- use icu && transcoder="icu"
- # for interix maybe: transcoder="windows"
-
- # 'cfurl' is only available on OSX and 'socket' isn't supposed to work.
- # But the docs aren't clear about it, so we would need some testing...
- local netaccessor="socket"
- use elibc_Darwin && netaccessor="cfurl"
- use libwww && netaccessor="libwww"
- use curl && netaccessor="curl"
-
- econf \
- --disable-pretty-make \
- $(use_enable static-libs static) \
- $(use_enable threads) \
- --enable-msgloader-${mloader} \
- --enable-netaccessor-${netaccessor} \
- --enable-transcoder-${transcoder} \
- $(use_enable sse2)
-}
-
-src_compile() {
- default
-
- if use doc ; then
- cd "${S}/doc"
- doxygen || die "making docs failed"
- fi
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "emake failed"
-
- use static-libs || rm "${D}"/lib*/*.la
-
- # To make sure an appropriate NLS msg file is around when using the iconv msgloader
- # ICU has the messages compiled in.
- if use iconv && ! use icu ; then
- doenvd "${FILESDIR}/50xerces-c"
- fi
-
- if use doc; then
- insinto /usr/share/doc/${PF}
- rm -rf samples/Makefile* samples/runConfigure samples/src/*/Makefile* samples/.libs
- doins -r samples
- dohtml -r doc/html/*
- fi
-
- dodoc CREDITS KEYS NOTICE README version.incl
-}