summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-09-29 07:17:26 +0000
committerJustin Lecher <jlec@gentoo.org>2014-09-29 07:17:26 +0000
commit84fdbe5be867f6bebd75c2474f7addf193a772e2 (patch)
tree78710ed47393d21c63de60785f6e5b598c4b8bcf /dev-libs
parentnet-analyzer/openvas-scanner: Add myself as maintainer (diff)
downloadgentoo-2-84fdbe5be867f6bebd75c2474f7addf193a772e2.tar.gz
gentoo-2-84fdbe5be867f6bebd75c2474f7addf193a772e2.tar.bz2
gentoo-2-84fdbe5be867f6bebd75c2474f7addf193a772e2.zip
dev-libs/qcustomplot: Move to new Cat
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/qcustomplot/ChangeLog17
-rw-r--r--dev-libs/qcustomplot/metadata.xml8
-rw-r--r--dev-libs/qcustomplot/qcustomplot-1.2.1.ebuild39
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-libs/qcustomplot/ChangeLog b/dev-libs/qcustomplot/ChangeLog
new file mode 100644
index 000000000000..419266c4ffc0
--- /dev/null
+++ b/dev-libs/qcustomplot/ChangeLog
@@ -0,0 +1,17 @@
+# ChangeLog for dev-libs/qcustomplot
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/qcustomplot/ChangeLog,v 1.1 2014/09/29 07:17:26 jlec Exp $
+
+ 29 Sep 2014; Justin Lecher <jlec@gentoo.org> +qcustomplot-1.2.1.ebuild,
+ +metadata.xml:
+ Move to new Cat
+
+ 28 Sep 2014; Justin Lecher <jlec@gentoo.org> qcustomplot-1.2.1.ebuild:
+ Install header
+
+*qcustomplot-1.2.1 (28 Sep 2014)
+
+ 28 Sep 2014; Justin Lecher <jlec@gentoo.org> +qcustomplot-1.2.1.ebuild,
+ +metadata.xml:
+ New addition, written by me
+
diff --git a/dev-libs/qcustomplot/metadata.xml b/dev-libs/qcustomplot/metadata.xml
new file mode 100644
index 000000000000..81a24972d134
--- /dev/null
+++ b/dev-libs/qcustomplot/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-libs/qcustomplot/qcustomplot-1.2.1.ebuild b/dev-libs/qcustomplot/qcustomplot-1.2.1.ebuild
new file mode 100644
index 000000000000..a7b77733dd12
--- /dev/null
+++ b/dev-libs/qcustomplot/qcustomplot-1.2.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/qcustomplot/qcustomplot-1.2.1.ebuild,v 1.1 2014/09/29 07:17:26 jlec Exp $
+
+EAPI=5
+
+inherit qt4-r2
+
+DESCRIPTION="Qt C++ widget for plotting and data visualization"
+HOMEPAGE="http://www.qcustomplot.com/"
+SRC_URI="
+ http://www.qcustomplot.com/release/${PV}/QCustomPlot-sharedlib.tar.gz -> ${PN}-sharedlib-${PV}.tar.gz
+ http://www.qcustomplot.com/release/${PV}/QCustomPlot-source.tar.gz -> ${PN}-source-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${PN}-source
+
+src_prepare() {
+ sed \
+ -e 's:../../::g' \
+ -e '/CONFIG/s:shared.*:shared:g' \
+ "${WORKDIR}"/${PN}-sharedlib/sharedlib-compilation/sharedlib-compilation.pro > ${PN}.pro || die
+ qt4-r2_src_prepare
+}
+
+src_install() {
+ dolib.so lib${PN}*
+ doheader ${PN}.h
+ dodoc changelog.txt
+}