summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-01-31 11:33:27 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-01-31 11:33:27 +0000
commit80d5719f260269238f6ef8216b185b9793cc5bdb (patch)
tree62b3e6875fb0ad4ab19723ce139e46268a04fa43 /dev-libs
parentFix problem with Supercite, bug 256886. (diff)
downloadgentoo-2-80d5719f260269238f6ef8216b185b9793cc5bdb.tar.gz
gentoo-2-80d5719f260269238f6ef8216b185b9793cc5bdb.tar.bz2
gentoo-2-80d5719f260269238f6ef8216b185b9793cc5bdb.zip
Add blocker for app-admin/fam, bug #254658.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libgamin/ChangeLog6
-rw-r--r--dev-libs/libgamin/libgamin-0.1.10-r1.ebuild3
-rw-r--r--dev-libs/libgamin/libgamin-0.1.10.ebuild76
3 files changed, 7 insertions, 78 deletions
diff --git a/dev-libs/libgamin/ChangeLog b/dev-libs/libgamin/ChangeLog
index db483fe456a3..b7127cbdc03a 100644
--- a/dev-libs/libgamin/ChangeLog
+++ b/dev-libs/libgamin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/libgamin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgamin/ChangeLog,v 1.9 2009/01/25 15:19:44 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgamin/ChangeLog,v 1.10 2009/01/31 11:33:27 eva Exp $
+
+ 31 Jan 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ -libgamin-0.1.10.ebuild, libgamin-0.1.10-r1.ebuild:
+ Add blocker for app-admin/fam, bug #254658.
25 Jan 2009; Tobias Klausmann <klausman@gentoo.org>
libgamin-0.1.10-r1.ebuild:
diff --git a/dev-libs/libgamin/libgamin-0.1.10-r1.ebuild b/dev-libs/libgamin/libgamin-0.1.10-r1.ebuild
index bdc6577c7e02..743a2f4d4d0d 100644
--- a/dev-libs/libgamin/libgamin-0.1.10-r1.ebuild
+++ b/dev-libs/libgamin/libgamin-0.1.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgamin/libgamin-0.1.10-r1.ebuild,v 1.5 2009/01/25 15:19:44 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgamin/libgamin-0.1.10-r1.ebuild,v 1.6 2009/01/31 11:33:27 eva Exp $
inherit autotools eutils flag-o-matic libtool python
@@ -19,6 +19,7 @@ IUSE="debug kernel_linux python"
RESTRICT="test" # need gam-server
RDEPEND="python? ( virtual/python )
+ !app-admin/fam
!<app-admin/gamin-0.1.10"
DEPEND="${RDEPEND}
diff --git a/dev-libs/libgamin/libgamin-0.1.10.ebuild b/dev-libs/libgamin/libgamin-0.1.10.ebuild
deleted file mode 100644
index da7dab9f6237..000000000000
--- a/dev-libs/libgamin/libgamin-0.1.10.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgamin/libgamin-0.1.10.ebuild,v 1.4 2009/01/06 15:52:38 ranger Exp $
-
-inherit autotools eutils flag-o-matic libtool python
-
-MY_PN=${PN//lib/}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Library providing the FAM File Alteration Monitor API"
-HOMEPAGE="http://www.gnome.org/~veillard/gamin/"
-SRC_URI="http://www.gnome.org/~veillard/${MY_PN}/sources/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="debug kernel_linux python"
-
-RESTRICT="test" # need gam-server
-
-RDEPEND="python? ( virtual/python )
- !<app-admin/gamin-0.1.10"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Fix compile warnings; bug #188923
- epatch "${FILESDIR}/${MY_PN}-0.1.9-freebsd.patch"
-
- # Fix collision problem due to intermediate library, upstream bug #530635
- epatch "${FILESDIR}/${P}-noinst-lib.patch"
-
- # autoconf is required as the user-cflags patch modifies configure.in
- # however, elibtoolize is also required, so when the above patch is
- # removed, replace the following call with a call to elibtoolize
- eautoreconf
-}
-
-src_compile() {
- # fixes bug #225403
- #append-flags "-D_GNU_SOURCE"
-
- econf --disable-debug \
- --disable-server \
- $(use_enable kernel_linux inotify) \
- $(use_enable debug debug-api) \
- $(use_with python)
-
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "installation failed"
-
- dodoc AUTHORS ChangeLog README TODO NEWS doc/*txt
- dohtml doc/*
-}
-
-pkg_postinst() {
- if use python; then
- python_version
- python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages
- fi
-}
-
-pkg_postrm() {
- if use python; then
- python_mod_cleanup /usr/$(get_libdir)/python*/site-packages
- fi
-}