summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-03-15 10:08:40 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-03-15 10:08:40 +0000
commit7fd45ae1611f1e231e4330969446cff9366435be (patch)
treed2c3536b878aed50ec7316053d684e10703ba7ec /dev-libs
parentDrop keywords in favor of newer stable ebuild (diff)
downloadgentoo-2-7fd45ae1611f1e231e4330969446cff9366435be.tar.gz
gentoo-2-7fd45ae1611f1e231e4330969446cff9366435be.tar.bz2
gentoo-2-7fd45ae1611f1e231e4330969446cff9366435be.zip
Remove older unstable ebuilds
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/xapian-bindings/ChangeLog6
-rw-r--r--dev-libs/xapian-bindings/xapian-bindings-1.2.5.ebuild138
-rw-r--r--dev-libs/xapian-bindings/xapian-bindings-1.2.7-r2.ebuild168
3 files changed, 5 insertions, 307 deletions
diff --git a/dev-libs/xapian-bindings/ChangeLog b/dev-libs/xapian-bindings/ChangeLog
index 8d7027574109..88d6fa8f8fba 100644
--- a/dev-libs/xapian-bindings/ChangeLog
+++ b/dev-libs/xapian-bindings/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/xapian-bindings
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian-bindings/ChangeLog,v 1.32 2012/03/14 02:23:50 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian-bindings/ChangeLog,v 1.33 2012/03/15 10:08:40 blueness Exp $
+
+ 15 Mar 2012; Anthony G. Basile <blueness@gentoo.org>
+ -xapian-bindings-1.2.5.ebuild, -xapian-bindings-1.2.7-r2.ebuild:
+ Remove older unstable ebuilds
14 Mar 2012; Anthony G. Basile <blueness@gentoo.org>
xapian-bindings-1.2.9.ebuild:
diff --git a/dev-libs/xapian-bindings/xapian-bindings-1.2.5.ebuild b/dev-libs/xapian-bindings/xapian-bindings-1.2.5.ebuild
deleted file mode 100644
index 4e05ba12c432..000000000000
--- a/dev-libs/xapian-bindings/xapian-bindings-1.2.5.ebuild
+++ /dev/null
@@ -1,138 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian-bindings/xapian-bindings-1.2.5.ebuild,v 1.2 2012/02/25 02:06:47 patrick Exp $
-
-EAPI="3"
-PYTHON_DEPEND="python? 2"
-PYTHON_USE_WITH="threads"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-
-inherit java-pkg-opt-2 mono python
-
-DESCRIPTION="SWIG and JNI bindings for Xapian"
-HOMEPAGE="http://www.xapian.org/"
-SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="java mono php python ruby tcl"
-
-COMMONDEPEND="=dev-libs/xapian-${PV}*
- mono? ( >=dev-lang/mono-1.0.8 )
- php? ( >=dev-lang/php-4 )
- ruby? ( dev-lang/ruby )
- tcl? ( >=dev-lang/tcl-8.1 )"
-DEPEND="${COMMONDEPEND}
- python? ( >=dev-lang/swig-1.3.29-r1 )
- java? ( >=virtual/jdk-1.3 )"
-RDEPEND="${COMMONDEPEND}
- java? ( >=virtual/jre-1.3 )"
-
-pkg_setup() {
- if use python; then
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- sed \
- -e 's:\(^pkgpylib_DATA = xapian/__init__.py\).*:\1:' \
- -e 's|\(^xapian/__init__.py: modern/xapian.py\)|\1 xapian/_xapian$(PYTHON_SO)|' \
- -i python/Makefile.{am,in} || die "sed failed"
-}
-
-src_configure() {
- if use java; then
- CXXFLAGS="${CXXFLAGS} $(java-pkg_get-jni-cflags)"
- fi
- econf \
- $(use_with java) \
- $(use_with mono csharp) \
- $(use_with php) \
- $(use_with python) \
- $(use_with ruby) \
- $(use_with tcl)
-
- # Python bindings are built/tested/installed manually.
- sed -e "/SUBDIRS =/s/ python//" -i Makefile || die "sed Makefile"
-}
-
-src_compile() {
- default
-
- if use python; then
- python_copy_sources python
- building() {
- emake \
- PYTHON="$(PYTHON)" \
- PYTHON_INC="$(python_get_includedir)" \
- PYTHON_LIB="$(python_get_libdir)" \
- pkgpylibdir="$(python_get_sitedir)/xapian"
- }
- python_execute_function -s --source-dir python building
- fi
-}
-
-src_test() {
- default
-
- if use python; then
- testing() {
- emake \
- PYTHON="$(PYTHON)" \
- PYTHON_INC="$(python_get_includedir)" \
- PYTHON_LIB="$(python_get_libdir)" \
- pkgpylibdir="$(python_get_sitedir)/xapian" \
- VERBOSE="1" \
- check
- }
- python_execute_function -s --source-dir python testing
- fi
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- if use java; then
- java-pkg_dojar java/built/xapian_jni.jar
- # TODO: make the build system not install this...
- java-pkg_doso "${D}/${S}/java/built/libxapian_jni.so"
- rm "${D}/${S}/java/built/libxapian_jni.so"
- rmdir -p "${D}/${S}/java/built"
- rmdir -p "${D}/${S}/java/native"
- fi
-
- if use python; then
- installation() {
- emake \
- DESTDIR="${D}" \
- PYTHON="$(PYTHON)" \
- PYTHON_INC="$(python_get_includedir)" \
- PYTHON_LIB="$(python_get_libdir)" \
- pkgpylibdir="$(python_get_sitedir)/xapian" \
- install
- }
- python_execute_function -s --source-dir python installation
- fi
-
- # For some USE combinations this directory is not created
- if [[ -d "${D}/usr/share/doc/xapian-bindings" ]]; then
- mv "${D}/usr/share/doc/xapian-bindings" "${D}/usr/share/doc/${PF}"
- fi
-
- dodoc AUTHORS HACKING NEWS TODO README || die "dodoc failed"
-}
-
-pkg_postinst() {
- if use python; then
- python_mod_optimize xapian
- fi
-}
-
-pkg_postrm() {
- if use python; then
- python_mod_cleanup xapian
- fi
-}
diff --git a/dev-libs/xapian-bindings/xapian-bindings-1.2.7-r2.ebuild b/dev-libs/xapian-bindings/xapian-bindings-1.2.7-r2.ebuild
deleted file mode 100644
index 9f8b4e1aca66..000000000000
--- a/dev-libs/xapian-bindings/xapian-bindings-1.2.7-r2.ebuild
+++ /dev/null
@@ -1,168 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian-bindings/xapian-bindings-1.2.7-r2.ebuild,v 1.2 2012/02/25 02:06:47 patrick Exp $
-
-EAPI="3"
-PYTHON_DEPEND="python? 2"
-PYTHON_USE_WITH="threads"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-
-PHP_EXT_NAME="xapian"
-PHP_EXT_INI="yes"
-PHP_EXT_OPTIONAL_USE="php"
-
-inherit java-pkg-opt-2 mono php-ext-source-r2 python
-
-DESCRIPTION="SWIG and JNI bindings for Xapian"
-HOMEPAGE="http://www.xapian.org/"
-SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="java lua mono perl php python ruby tcl"
-
-COMMONDEPEND="=dev-libs/xapian-${PV}*
- lua? ( >=dev-lang/lua-5.1 )
- mono? ( >=dev-lang/mono-1.0.8 )
- perl? ( dev-lang/perl )
- ruby? ( dev-lang/ruby )
- tcl? ( >=dev-lang/tcl-8.1 )"
-DEPEND="${COMMONDEPEND}
- java? ( >=virtual/jdk-1.3 )"
-RDEPEND="${COMMONDEPEND}
- java? ( >=virtual/jre-1.3 )"
-
-pkg_setup() {
- java-pkg-opt-2_pkg_setup
-
- if use python; then
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- java-pkg-opt-2_src_prepare
- if use java; then
- sed \
- -e 's/$(JAVAC)/$(JAVAC) $(JAVACFLAGS)/' \
- -i java{/,/org/xapian/errors/,/org/xapian/}Makefile.in || die "sed failed"
- fi
-
- if use python; then
- sed \
- -e 's:\(^pkgpylib_DATA = xapian/__init__.py\).*:\1:' \
- -e 's|\(^xapian/__init__.py: modern/xapian.py\)|\1 xapian/_xapian$(PYTHON_SO)|' \
- -i python/Makefile.in || die "sed failed"
- fi
-}
-
-src_configure() {
- if use java; then
- CXXFLAGS="${CXXFLAGS} $(java-pkg_get-jni-cflags)"
- fi
-
- if use perl; then
- export PERL_ARCH="$(perl -MConfig -e 'print $Config{installvendorarch}')"
- export PERL_LIB="$(perl -MConfig -e 'print $Config{installvendorlib}')"
- fi
-
- econf \
- $(use_with java) \
- $(use_with lua) \
- $(use_with mono csharp) \
- $(use_with perl) \
- $(use_with php) \
- $(use_with python) \
- $(use_with ruby) \
- $(use_with tcl)
-
- # Python bindings are built/tested/installed manually.
- sed -e "/SUBDIRS =/s/ python//" -i Makefile || die "sed Makefile"
-}
-
-src_compile() {
- default
-
- if use python; then
- python_copy_sources python
- building() {
- emake \
- PYTHON="$(PYTHON)" \
- PYTHON_INC="$(python_get_includedir)" \
- PYTHON_LIB="$(python_get_libdir)" \
- PYTHON_SO="$("$(PYTHON)" -c 'import distutils.sysconfig; print(distutils.sysconfig.get_config_vars("SO")[0])')" \
- pkgpylibdir="$(python_get_sitedir)/xapian"
- }
- python_execute_function -s --source-dir python building
- fi
-}
-
-src_test() {
- default
-
- if use python; then
- testing() {
- emake \
- PYTHON="$(PYTHON)" \
- PYTHON_INC="$(python_get_includedir)" \
- PYTHON_LIB="$(python_get_libdir)" \
- PYTHON_SO="$("$(PYTHON)" -c 'import distutils.sysconfig; print(distutils.sysconfig.get_config_vars("SO")[0])')" \
- pkgpylibdir="$(python_get_sitedir)/xapian" \
- VERBOSE="1" \
- check
- }
- python_execute_function -s --source-dir python testing
- fi
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- if use java; then
- java-pkg_dojar java/built/xapian_jni.jar
- # TODO: make the build system not install this...
- java-pkg_doso "${D}/${S}/java/built/libxapian_jni.so"
- rm "${D}/${S}/java/built/libxapian_jni.so"
- rmdir -p "${D}/${S}/java/built"
- rmdir -p "${D}/${S}/java/native"
- fi
-
- if use python; then
- installation() {
- emake \
- DESTDIR="${D}" \
- PYTHON="$(PYTHON)" \
- PYTHON_INC="$(python_get_includedir)" \
- PYTHON_LIB="$(python_get_libdir)" \
- PYTHON_SO="$("$(PYTHON)" -c 'import distutils.sysconfig; print(distutils.sysconfig.get_config_vars("SO")[0])')" \
- pkgpylibdir="$(python_get_sitedir)/xapian" \
- install
- }
- python_execute_function -s --source-dir python installation
- fi
-
- if use php; then
- php-ext-source-r2_createinifiles
- fi
-
- # For some USE combinations this directory is not created
- if [[ -d "${D}/usr/share/doc/xapian-bindings" ]]; then
- mv "${D}/usr/share/doc/xapian-bindings" "${D}/usr/share/doc/${PF}"
- fi
-
- dodoc AUTHORS HACKING NEWS TODO README || die "dodoc failed"
-}
-
-pkg_postinst() {
- if use python; then
- python_mod_optimize xapian
- fi
-}
-
-pkg_postrm() {
- if use python; then
- python_mod_cleanup xapian
- fi
-}