summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-09-23 16:11:46 +0000
committerMike Frysinger <vapier@gentoo.org>2006-09-23 16:11:46 +0000
commit7f322749803c3f11ea28480247707d7ad368f526 (patch)
tree558b6bd2d82c998667dcba06770913fe705b4431 /dev-libs
parentold (diff)
downloadgentoo-2-7f322749803c3f11ea28480247707d7ad368f526.tar.gz
gentoo-2-7f322749803c3f11ea28480247707d7ad368f526.tar.bz2
gentoo-2-7f322749803c3f11ea28480247707d7ad368f526.zip
Respect LDFLAGS #126868.
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libtommath/ChangeLog6
-rw-r--r--dev-libs/libtommath/files/digest-libtommath-0.36-r12
-rw-r--r--dev-libs/libtommath/files/libtommath-0.36-LDFLAGS.patch27
-rw-r--r--dev-libs/libtommath/libtommath-0.36-r1.ebuild5
4 files changed, 37 insertions, 3 deletions
diff --git a/dev-libs/libtommath/ChangeLog b/dev-libs/libtommath/ChangeLog
index cc526d3ab162..1c814eac763f 100644
--- a/dev-libs/libtommath/ChangeLog
+++ b/dev-libs/libtommath/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/libtommath
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtommath/ChangeLog,v 1.16 2006/03/03 12:36:15 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtommath/ChangeLog,v 1.17 2006/09/23 16:11:46 vapier Exp $
+
+ 23 Sep 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/libtommath-0.36-LDFLAGS.patch, libtommath-0.36-r1.ebuild:
+ Respect LDFLAGS #126868.
03 Mar 2006; Diego Pettenò <flameeyes@gentoo.org>
libtommath-0.36-r1.ebuild:
diff --git a/dev-libs/libtommath/files/digest-libtommath-0.36-r1 b/dev-libs/libtommath/files/digest-libtommath-0.36-r1
index ca35fa04a92c..c27d523ad22b 100644
--- a/dev-libs/libtommath/files/digest-libtommath-0.36-r1
+++ b/dev-libs/libtommath/files/digest-libtommath-0.36-r1
@@ -1 +1,3 @@
MD5 cd4f9305e1b721b3c3eb7bcdc25abfc6 ltm-0.36.tar.bz2 1924150
+RMD160 f9fc66d076913b7e6b0226470b5cff3caa704c2d ltm-0.36.tar.bz2 1924150
+SHA256 16243c61694a52553a2d65c097456e024d8dcd9e3571c8f712ca163eaa769c6b ltm-0.36.tar.bz2 1924150
diff --git a/dev-libs/libtommath/files/libtommath-0.36-LDFLAGS.patch b/dev-libs/libtommath/files/libtommath-0.36-LDFLAGS.patch
new file mode 100644
index 000000000000..80e466704575
--- /dev/null
+++ b/dev-libs/libtommath/files/libtommath-0.36-LDFLAGS.patch
@@ -0,0 +1,27 @@
+http://bugs.gentoo.org/126868
+
+--- libtommath-0.36/makefile.shared
++++ libtommath-0.36/makefile.shared
+@@ -81,7 +81,7 @@
+ bn_mp_to_signed_bin_n.o bn_mp_to_unsigned_bin_n.o
+
+ $(LIBNAME): $(OBJECTS)
+- libtool --mode=link --tag=CC gcc *.lo -o $(LIBNAME) -rpath $(LIBPATH) -version-info $(VERSION)
++ libtool --mode=link --tag=CC gcc $(LDFLAGS) *.lo -o $(LIBNAME) -rpath $(LIBPATH) -version-info $(VERSION)
+ libtool --mode=link --tag=CC gcc *.o -o $(LIBNAME_S)
+
+ install: $(LIBNAME) $(HEADERS)
+@@ -92,10 +92,10 @@
+
+ test: $(LIBNAME) demo/demo.o
+ gcc $(CFLAGS) -c demo/demo.c -o demo/demo.o
+- libtool --mode=link gcc -o test demo/demo.o $(LIBNAME_S)
++ libtool --mode=link gcc $(LDFLAGS) -o test demo/demo.o $(LIBNAME)
+
+ mtest: test
+- cd mtest ; gcc $(CFLAGS) mtest.c -o mtest
++ cd mtest ; gcc $(CFLAGS) $(LDFLAGS) mtest.c -o mtest
+
+ timing: $(LIBNAME)
+- gcc $(CFLAGS) -DTIMER demo/timing.c $(LIBNAME_S) -o ltmtest
++ libtool --mode=link gcc $(CFLAGS) $(LDFLAGS) -DTIMER demo/timing.c $(LIBNAME) -o ltmtest
diff --git a/dev-libs/libtommath/libtommath-0.36-r1.ebuild b/dev-libs/libtommath/libtommath-0.36-r1.ebuild
index 3ed0d34593db..126c08586941 100644
--- a/dev-libs/libtommath/libtommath-0.36-r1.ebuild
+++ b/dev-libs/libtommath/libtommath-0.36-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtommath/libtommath-0.36-r1.ebuild,v 1.3 2006/03/04 02:23:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtommath/libtommath-0.36-r1.ebuild,v 1.4 2006/09/23 16:11:46 vapier Exp $
inherit eutils multilib
@@ -10,7 +10,7 @@ SRC_URI="http://math.libtomcrypt.org/files/ltm-${PV}.tar.bz2"
LICENSE="public-domain"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc-macos ~x86"
+KEYWORDS="amd64 ppc ~ppc-macos x86"
IUSE=""
DEPEND="sys-devel/libtool"
@@ -20,6 +20,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-shared-lib.patch
+ epatch "${FILESDIR}"/${P}-LDFLAGS.patch
}
src_compile() {