summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2006-11-09 20:39:21 +0000
committerDaniel Black <dragonheart@gentoo.org>2006-11-09 20:39:21 +0000
commit7b46beeb175bcf79b49a1cec5c0e71c50748fa86 (patch)
tree65a6d89f1d37b249691441e0b55b3602040ceaa7 /dev-libs
parentMasked dev-db/dbbalancer for pending removal (diff)
downloadgentoo-2-7b46beeb175bcf79b49a1cec5c0e71c50748fa86.tar.gz
gentoo-2-7b46beeb175bcf79b49a1cec5c0e71c50748fa86.tar.bz2
gentoo-2-7b46beeb175bcf79b49a1cec5c0e71c50748fa86.zip
added OS.inl to install thanks to dev-zero
(Portage version: 2.1.2_rc1-r4)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/ace/ChangeLog9
-rw-r--r--dev-libs/ace/ace-5.5.3-r1.ebuild85
-rw-r--r--dev-libs/ace/files/digest-ace-5.5.3-r13
3 files changed, 96 insertions, 1 deletions
diff --git a/dev-libs/ace/ChangeLog b/dev-libs/ace/ChangeLog
index 0564a0d0f49e..8ed8fda46ff4 100644
--- a/dev-libs/ace/ChangeLog
+++ b/dev-libs/ace/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/ace
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ChangeLog,v 1.39 2006/11/06 20:47:30 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ChangeLog,v 1.40 2006/11/09 20:39:21 dragonheart Exp $
+
+*ace-5.5.3-r1 (10 Nov 2006)
+
+ 10 Nov 2006; Daniel Black <dragonheart@gentoo.org> ace-5.5.3-r1.ebuild,
+ -ace-5.5.3, metadata.xml:
+ added missing ACE_wrappers/ace/OS.inl thanks to dev-zero. added cpp to
+ metadata.xml
06 Nov 2006; Daniel Black <dragonheart@gentoo.org> ace-5.5.3.ebuild,
ace-5.5-r1.ebuild:
diff --git a/dev-libs/ace/ace-5.5.3-r1.ebuild b/dev-libs/ace/ace-5.5.3-r1.ebuild
new file mode 100644
index 000000000000..b5b22ab70a45
--- /dev/null
+++ b/dev-libs/ace/ace-5.5.3-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ace-5.5.3-r1.ebuild,v 1.1 2006/11/09 20:39:21 dragonheart Exp $
+
+inherit eutils autotools
+
+S="${WORKDIR}/ACE_wrappers"
+DESCRIPTION="The Adaptive Communications Environment"
+SRC_URI="http://download.dre.vanderbilt.edu/previous_versions/ACE-${PV}.tar.bz2"
+
+# tao? ( !ciao? (
+# http://download.dre.vanderbilt.edu/previous_versions/ACE+TAO-${PV}.tar.bz2 )
+# ciao? (
+# http://download.dre.vanderbilt.edu/previous_versions/ACE+TAO+CIAO-${PV}.tar.bz2
+# )
+# )"
+
+# tao currently has upstream bug
+# http://deuce.doc.wustl.edu/bugzilla/show_bug.cgi?id=2684
+
+# ciao currently isn't autoconf and depends of tao
+# http://www.dre.vanderbilt.edu/~schmidt/DOC_ROOT/CIAO/CIAO-INSTALL.html
+
+HOMEPAGE="http://www.cs.wustl.edu/~schmidt/ACE.html"
+
+SLOT="0"
+LICENSE="BSD as-is"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~amd64"
+#IUSE="X ipv6 tao ciao"
+IUSE="X ipv6"
+
+DEPEND="dev-libs/openssl"
+
+RDEPEND="${DEPEND}
+ X? ( || (
+ ( x11-libs/libXt
+ x11-libs/libXaw )
+ virtual/x11 )
+ )"
+
+DEPEND="${DEPEND}
+ X? ( || (
+ ( x11-proto/xproto )
+ virtual/x11 )
+ )"
+
+src_compile() {
+ export ACE_ROOT="${S}"
+ mkdir build
+ cd build
+ ECONF_SOURCE="${S}"
+ econf --enable-lib-all $(use_with X) $(use_enable ipv6) || \
+ die "econf died"
+ # --with-qos needs ACE_HAS_RAPI
+ emake static_libs=1 || die
+}
+
+
+src_test() {
+ cd ${S}/build
+ make ACE_ROOT=${S} check || die "self test failed"
+ #einfo "src_test currently stalls after Process_Mutex_Test"
+}
+
+src_install() {
+ cd build
+ make ACE_ROOT="${S}" DESTDIR="${D}" install || die "failed to install"
+ insinto /usr/include/ace
+ doins "${S}"/ace/OS.inl
+ # punt gperf stuff
+ rm -rf "${D}"/usr/bin "${D}"/usr/share
+}
+
+
+pkg_postinst() {
+ # This is required, as anything trying to compile against ACE will have
+ # problems with conflicting OS.h files if this is not done.
+
+ local CC_MACHINE=`gcc -dumpmachine`
+ local CC_VERSION=`gcc -dumpversion`
+ if [ -d "/usr/lib/gcc-lib/${CC_MACHINE}/${CC_VERSION}/include/ace" ]; then
+ mv "/usr/lib/gcc-lib/${CC_MACHINE}/${CC_VERSION}/include/ace" \
+ "/usr/lib/gcc-lib/${CC_MACHINE}/${CC_VERSION}/include/ace.old"
+ fi
+}
diff --git a/dev-libs/ace/files/digest-ace-5.5.3-r1 b/dev-libs/ace/files/digest-ace-5.5.3-r1
new file mode 100644
index 000000000000..7fb716ab0e4d
--- /dev/null
+++ b/dev-libs/ace/files/digest-ace-5.5.3-r1
@@ -0,0 +1,3 @@
+MD5 f51b82275b03f338503a4e01174cc789 ACE-5.5.3.tar.bz2 8073158
+RMD160 289b78cc6a7dddfda68705dccdca373b74711785 ACE-5.5.3.tar.bz2 8073158
+SHA256 6cf285d2f1b0f0d4eac57f894018e1c88bc855a554a2b1d1edb86245757849c8 ACE-5.5.3.tar.bz2 8073158