summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2004-10-14 01:04:17 +0000
committerChris White <chriswhite@gentoo.org>2004-10-14 01:04:17 +0000
commit760f0e201a9bc2e41e5f1d1c6edc1f36f1d40922 (patch)
tree736d0100dcbcb2dbb645de2d66c454661b19e10a /dev-libs
parentVersion bump (Manifest recommit) (diff)
downloadgentoo-2-760f0e201a9bc2e41e5f1d1c6edc1f36f1d40922.tar.gz
gentoo-2-760f0e201a9bc2e41e5f1d1c6edc1f36f1d40922.tar.bz2
gentoo-2-760f0e201a9bc2e41e5f1d1c6edc1f36f1d40922.zip
Fixed bad USE logic and myconf issues.
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/vdk/ChangeLog5
-rw-r--r--dev-libs/vdk/vdk-2.4.0.ebuild13
2 files changed, 14 insertions, 4 deletions
diff --git a/dev-libs/vdk/ChangeLog b/dev-libs/vdk/ChangeLog
index 0f0cb0e13401..c9715975e9a0 100644
--- a/dev-libs/vdk/ChangeLog
+++ b/dev-libs/vdk/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/vdk
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/vdk/ChangeLog,v 1.10 2004/10/14 00:47:37 chriswhite Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/vdk/ChangeLog,v 1.11 2004/10/14 01:04:17 chriswhite Exp $
+
+ 14 Oct 2004; Chris White <chriswhite@gentoo.org> vdk-2.4.0.ebuild:
+ Made sure mylocal was setup empty. Fixed really bad USE logic.
*vdk-2.4.0 (13 Oct 2004)
diff --git a/dev-libs/vdk/vdk-2.4.0.ebuild b/dev-libs/vdk/vdk-2.4.0.ebuild
index 4ea3672f79e7..1966ec1bbdd3 100644
--- a/dev-libs/vdk/vdk-2.4.0.ebuild
+++ b/dev-libs/vdk/vdk-2.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/vdk/vdk-2.4.0.ebuild,v 1.1 2004/10/14 00:46:04 chriswhite Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/vdk/vdk-2.4.0.ebuild,v 1.2 2004/10/14 01:04:17 chriswhite Exp $
inherit eutils toolchain-funcs
@@ -17,8 +17,11 @@ DEPEND=">x11-libs/gtk+-2.4*
doc? (app-doc/doxygen)"
src_compile() {
+
cd ${S}
+ local myconf=""
+
if [ "$(gcc-major-version)" -ge "4" ] || [ "$(gcc-major-version)" -ge "3" -a "$(gcc-minor-version)" -ge "4" ]
then
epatch ${FILESDIR}/${P}-gcc3.4.patch
@@ -30,10 +33,14 @@ src_compile() {
use doc && \
myconf="${myconf} --enable-doc-html=yes \
--enable-doc-latex=yes \
- --enable-doc-man=yes"
+ --enable-doc-man=yes" \
+ || myconf="${myconf} --enable-doc-html=no \
+ --enable-doc-latex=no \
+ --enable-doc-man=no"
use debug && \
- myconf="${myconf} --enable-debug=yes"
+ myconf="${myconf} --enable-debug=yes" \
+ || myconf="${myconf} --enable-debug=no"
econf \
${myconf} \