summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-03-13 16:16:49 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-03-13 16:16:49 +0000
commit75f872af99a86f41d974b90287ac6ed793c2a566 (patch)
tree130f3a04ac0a64077b025cac98d8f0a4008ed86a /dev-libs
parentWrap sys-apps/openrc RDEPEND around USE ! prefix by Jeremy Olexa. (diff)
downloadgentoo-2-75f872af99a86f41d974b90287ac6ed793c2a566.tar.gz
gentoo-2-75f872af99a86f41d974b90287ac6ed793c2a566.tar.bz2
gentoo-2-75f872af99a86f41d974b90287ac6ed793c2a566.zip
Version bump
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/xapian/ChangeLog7
-rw-r--r--dev-libs/xapian/xapian-1.2.9.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-libs/xapian/ChangeLog b/dev-libs/xapian/ChangeLog
index dfba27cf9bfb..7ca9fc97b29c 100644
--- a/dev-libs/xapian/ChangeLog
+++ b/dev-libs/xapian/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/xapian
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian/ChangeLog,v 1.72 2012/02/24 14:44:54 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian/ChangeLog,v 1.73 2012/03/13 16:16:49 blueness Exp $
+
+*xapian-1.2.9 (13 Mar 2012)
+
+ 13 Mar 2012; Anthony G. Basile <blueness@gentoo.org> +xapian-1.2.9.ebuild:
+ Version bump
24 Feb 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> xapian-1.2.8.ebuild:
x86 stable wrt bug #402185
diff --git a/dev-libs/xapian/xapian-1.2.9.ebuild b/dev-libs/xapian/xapian-1.2.9.ebuild
new file mode 100644
index 000000000000..10dfbb9652cd
--- /dev/null
+++ b/dev-libs/xapian/xapian-1.2.9.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian/xapian-1.2.9.ebuild,v 1.1 2012/03/13 16:16:49 blueness Exp $
+
+EAPI="4"
+
+MY_P="${PN}-core-${PV}"
+
+DESCRIPTION="Xapian Probabilistic Information Retrieval library"
+HOMEPAGE="http://www.xapian.org/"
+SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs -sse +sse2 +brass +chert +flint +inmemory +remote"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local myconf=""
+
+ ewarn
+ if use sse2; then
+ ewarn "Using sse2"
+ myconf="${myconf} --enable-sse=sse2"
+ else
+ if use sse; then
+ ewarn "Using sse"
+ myconf="${myconf} --enable-sse=sse"
+ else
+ ewarn "Disabling sse and sse2"
+ myconf="${myconf} --disable-sse"
+ fi
+ fi
+ ewarn
+
+ myconf="${myconf} $(use_enable static-libs static)"
+
+ use brass || myconf="${myconf} --disable-backend-brass"
+ use chert || myconf="${myconf} --disable-backend-chert"
+ use flint || myconf="${myconf} --disable-backend-flint"
+ use inmemory || myconf="${myconf} --disable-backend-inmemory"
+ use remote || myconf="${myconf} --disable-backend-remote"
+
+ econf $myconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ mv "${D}usr/share/doc/xapian-core" "${D}usr/share/doc/${PF}"
+ use doc || rm -rf "${D}usr/share/doc/${PF}"
+
+ dodoc AUTHORS HACKING PLATFORMS README NEWS
+}
+
+src_test() {
+ emake check VALGRIND=
+}