summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryon Roche <kain@gentoo.org>2002-09-17 09:37:57 +0000
committerBryon Roche <kain@gentoo.org>2002-09-17 09:37:57 +0000
commit756260e4291e9d84ddee1319142fb2bdc0a1cf4b (patch)
tree4b1ff8ba80edac19c08a49d60e1005025fc5353d /dev-libs
parentcyrus-sasl-2.1.7-r2 (diff)
downloadgentoo-2-756260e4291e9d84ddee1319142fb2bdc0a1cf4b.tar.gz
gentoo-2-756260e4291e9d84ddee1319142fb2bdc0a1cf4b.tar.bz2
gentoo-2-756260e4291e9d84ddee1319142fb2bdc0a1cf4b.zip
kerberos 5 + GCC 3.2 fixes; Dealing with the gcc 3.2 includeorder crap
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/cyrus-sasl/ChangeLog9
-rw-r--r--dev-libs/cyrus-sasl/cyrus-sasl-2.1.7-r2.ebuild109
-rw-r--r--dev-libs/cyrus-sasl/files/cyrus-sasl-gcc32.patch11
-rw-r--r--dev-libs/cyrus-sasl/files/digest-cyrus-sasl-2.1.7-r21
4 files changed, 129 insertions, 1 deletions
diff --git a/dev-libs/cyrus-sasl/ChangeLog b/dev-libs/cyrus-sasl/ChangeLog
index a42d3500f530..fa4b9b8ccf81 100644
--- a/dev-libs/cyrus-sasl/ChangeLog
+++ b/dev-libs/cyrus-sasl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/cyrus-sasl
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/ChangeLog,v 1.19 2002/09/16 14:16:00 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/ChangeLog,v 1.20 2002/09/17 09:37:57 kain Exp $
+
+*cyrus-sasl-2.1.7-r2 (17 Sep 2002)
+
+ 17 Sep 2002; Bryon Roche <kain@kain.org>
+ cyrus-sasl-2.1.7-r2.ebuild, files/digest-cyrus-sasl-2.1.7-r2,
+ files/cyrus-sasl-gcc32.patch :
+ Kerberos 5 fix and a fix for GCC 3.2
*cyrus-sasl-2.1.7-r1 (23 Aug 2002)
diff --git a/dev-libs/cyrus-sasl/cyrus-sasl-2.1.7-r2.ebuild b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.7-r2.ebuild
new file mode 100644
index 000000000000..ab8fa1cb39a0
--- /dev/null
+++ b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.7-r2.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/cyrus-sasl-2.1.7-r2.ebuild,v 1.1 2002/09/17 09:37:57 kain Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="The Cyrus SASL (Simple Authentication and Security Layer)"
+HOMEPAGE="http://asg.web.cmu.edu/sasl/"
+SRC_URI="ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+
+RDEPEND=">=sys-libs/db-3.2
+ >=sys-libs/pam-0.75
+ >=dev-libs/openssl-0.9.6d
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )
+ berkdb? ( >=sys-libs/db-3.2.9 )
+ ldap? ( >=net-nds/openldap-2.0.25 )
+ mysql? ( >=dev-db/mysql-3.23.51 )
+ kerberos? ( >=app-crypt/krb5-1.2.5 )"
+
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ sys-devel/autoconf
+ sys-devel/automake"
+
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/cyrus-sasl-iovec.diff || die
+ patch -p1 < ${FILESDIR}/crypt.diff || die
+ patch -p0 < ${FILESDIR}/cyrus-sasl-gcc32.patch || die
+
+}
+
+src_compile() {
+
+ local myconf
+
+ libtoolize --copy --force
+ aclocal -I config -I cmulocal
+ autoheader
+ autoconf
+ automake -a --foreign
+
+ use ldap && myconf="${myconf} --with-ldap" \
+ || myconf="${myconf} --without-ldap"
+
+ use mysql && myconf="${myconf} --with-mysql" \
+ || myconf="${myconf} --without-mysql"
+
+ if use berkdb; then
+ myconf="${myconf} --with-dblib=berkeley"
+ elif use gdbm; then
+ myconf="${myconf} --with-dblib=gdbm --with-gdbm=/usr"
+ else
+ myconf="${myconf} --with-dblib=berkeley"
+ fi
+
+ use static && myconf="${myconf} --enable-static --with-staticsasl" \
+ || myconf="${myconf} --disable-static --without-staticsasl"
+
+ #use kerberos && myconf="${myconf} --enable-krb4" \
+ # || myconf="${myconf} --disable-krb4"
+ #Ya this seems wierd, but I'm guessing we'd rather prefer GSSAPI auth.
+
+ econf \
+ --with-saslauthd=/var/lib/sasl2 \
+ --with-pwcheck=/var/lib/sasl2 \
+ --with-configdir=/etc/sasl2 \
+ --with-openssl \
+ --with-plugindir=/usr/lib/sasl2 \
+ --with-dbpath=/etc/sasl2/sasldb2 \
+ --with-des \
+ --with-rc4 \
+ --disable-krb4 \
+ --with-gnu-ld \
+ --enable-shared \
+ --disable-sample \
+ --enable-login \
+ ${myconf} || die "bad ./configure"
+
+ make || die "compile problem"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "install problem"
+
+ dodoc AUTHORS ChangeLog COPYING NEWS README doc/*.txt
+ docinto examples ; dodoc sample/{*.[ch],Makefile}
+ newdoc pwcheck/README README.pwcheck
+ dohtml doc/*
+
+ insinto /etc/conf.d ; newins ${FILESDIR}/saslauthd.confd saslauthd
+ exeinto /etc/init.d ; newexe ${FILESDIR}/saslauthd2.rc6 saslauthd
+ exeinto /etc/init.d ; newexe ${FILESDIR}/pwcheck.rc6 pwcheck
+}
+
+pkg_postinst() {
+
+ # empty directories..
+ dodir /var/lib/sasl2
+ dodir /etc/sasl2
+
+}
diff --git a/dev-libs/cyrus-sasl/files/cyrus-sasl-gcc32.patch b/dev-libs/cyrus-sasl/files/cyrus-sasl-gcc32.patch
new file mode 100644
index 000000000000..d781bfd2161a
--- /dev/null
+++ b/dev-libs/cyrus-sasl/files/cyrus-sasl-gcc32.patch
@@ -0,0 +1,11 @@
+--- ../cyrus-sasl-2.1.7/configure.in 2002-08-09 10:40:37.000000000 -0500
++++ configure.in 2002-09-17 04:03:54.000000000 -0500
+@@ -74,7 +74,7 @@
+ dnl check for -R, etc. switch
+ CMU_GUESS_RUNPATH_SWITCH
+ dnl let's just link against local. otherwise we never find anything useful.
+-CPPFLAGS="-I/usr/local/include ${CPPFLAGS}"
++#CPPFLAGS="-I/usr/local/include ${CPPFLAGS}"
+ CMU_ADD_LIBPATH("/usr/local/lib")
+
+ AM_DISABLE_STATIC
diff --git a/dev-libs/cyrus-sasl/files/digest-cyrus-sasl-2.1.7-r2 b/dev-libs/cyrus-sasl/files/digest-cyrus-sasl-2.1.7-r2
new file mode 100644
index 000000000000..f63f2f378471
--- /dev/null
+++ b/dev-libs/cyrus-sasl/files/digest-cyrus-sasl-2.1.7-r2
@@ -0,0 +1 @@
+MD5 a73e12bea77e96300103aaf511c6bfc4 cyrus-sasl-2.1.7.tar.gz 1266804