summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Keadle <mkeadle@gentoo.org>2002-10-03 21:03:48 +0000
committerMatt Keadle <mkeadle@gentoo.org>2002-10-03 21:03:48 +0000
commit6fa8c14638c075518e839c7ae37a236a6a7daf93 (patch)
treeb749a399bf96b3e3acf73ec1036293ad67e98263 /dev-libs
parentMasking new commoncpp2 package for testing (diff)
downloadgentoo-2-6fa8c14638c075518e839c7ae37a236a6a7daf93.tar.gz
gentoo-2-6fa8c14638c075518e839c7ae37a236a6a7daf93.tar.bz2
gentoo-2-6fa8c14638c075518e839c7ae37a236a6a7daf93.zip
Adding package commoncpp2
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/commoncpp2/ChangeLog11
-rw-r--r--dev-libs/commoncpp2/commoncpp2-1.0.1.ebuild49
-rw-r--r--dev-libs/commoncpp2/files/digest-commoncpp2-1.0.11
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-libs/commoncpp2/ChangeLog b/dev-libs/commoncpp2/ChangeLog
new file mode 100644
index 000000000000..76d560f149b7
--- /dev/null
+++ b/dev-libs/commoncpp2/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header:
+
+*commoncpp2-1.0.1 (03 Oct 2002)
+
+ 03 Oct 2002; Matt Keadle <mkeadle@gentoo.org> commoncpp2-1.0.1:
+ This changelog is for the initial release of commoncpp2-1.0.1.ebuild which is
+ just a library needed for a few gnu applications. It is the new branch of
+ commonc++. Thanks to foser (real name??) for the ebuild!
+
diff --git a/dev-libs/commoncpp2/commoncpp2-1.0.1.ebuild b/dev-libs/commoncpp2/commoncpp2-1.0.1.ebuild
new file mode 100644
index 000000000000..d65f1a0b9457
--- /dev/null
+++ b/dev-libs/commoncpp2/commoncpp2-1.0.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/commoncpp2/commoncpp2-1.0.1.ebuild,v 1.1 2002/10/03 21:03:48 mkeadle Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GNU Common C++ is a C++ framework offering portable support for\
+threading, sockets, file access, daemons, persistence, serial I/O, XML parsing,\
+and system services"
+SRC_URI="mirror://gnu/commonc++/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/commonc++/"
+
+DEPEND="sys-libs/zlib
+ xml2? ( dev-libs/libxml2 )
+ doc? ( app-doc/doxygen )"
+
+RDEPEND=${DEPEND}
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+src_compile() {
+ local myconf=""
+
+ use xml2 \
+ && myconf="${myconf} --with-xml" \
+ || myconf="${myconf} --without-xml"
+
+ econf ${myconf} || die "./configure failed"
+
+ emake || die
+
+ # kdoc disabled for now, it errors out
+ use doc && make doxy
+}
+
+src_install () {
+
+ einstall || die
+
+ dodoc AUTHORS INSTALL NEWS ChangeLog README\
+ THANKS TODO COPYING COPYING.addendum
+
+ # the docs come out already compressed
+ use doc && ( \
+ dodoc commoncpp2-html-manual-1.0.1.tar.gz \
+ commoncpp2-latex-manual-1.0.1.tar.gz
+ )
+}
diff --git a/dev-libs/commoncpp2/files/digest-commoncpp2-1.0.1 b/dev-libs/commoncpp2/files/digest-commoncpp2-1.0.1
new file mode 100644
index 000000000000..a0c043cd9f94
--- /dev/null
+++ b/dev-libs/commoncpp2/files/digest-commoncpp2-1.0.1
@@ -0,0 +1 @@
+MD5 b53c6a3ed187d8fb5056a6801fffb899 commoncpp2-1.0.1.tar.gz 582709