summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2007-06-06 19:25:19 +0000
committerTiziano Müller <dev-zero@gentoo.org>2007-06-06 19:25:19 +0000
commit66ef577b863ea32009bef49f022d6b23a4937e52 (patch)
treef9d66ef0c2b0c99e886d60672dc2ba94387a738e /dev-libs
parentVersion bump. (diff)
downloadgentoo-2-66ef577b863ea32009bef49f022d6b23a4937e52.tar.gz
gentoo-2-66ef577b863ea32009bef49f022d6b23a4937e52.tar.bz2
gentoo-2-66ef577b863ea32009bef49f022d6b23a4937e52.zip
Version bump.
(Portage version: 2.1.2.9)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/boost/ChangeLog8
-rw-r--r--dev-libs/boost/boost-1.34.0.ebuild (renamed from dev-libs/boost/boost-1.34_pre20061214.ebuild)117
-rw-r--r--dev-libs/boost/files/digest-boost-1.34.03
-rw-r--r--dev-libs/boost/files/digest-boost-1.34_pre200612143
4 files changed, 112 insertions, 19 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index c51363a3ad58..37c10f4145f8 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/boost
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.109 2007/02/20 20:43:00 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.110 2007/06/06 19:25:19 dev-zero Exp $
+
+*boost-1.34.0 (06 Jun 2007)
+
+ 06 Jun 2007; Tiziano Müller <dev-zero@gentoo.org>
+ -boost-1.34_pre20061214.ebuild, +boost-1.34.0.ebuild:
+ Version bump.
20 Feb 2007; Tiziano Müller <dev-zero@gentoo.org> boost-1.33.1-r1.ebuild:
Using check-reqs to check for enough free diskspace for building tests
diff --git a/dev-libs/boost/boost-1.34_pre20061214.ebuild b/dev-libs/boost/boost-1.34.0.ebuild
index 3f20e9bc9aee..af9b7c4955cd 100644
--- a/dev-libs/boost/boost-1.34_pre20061214.ebuild
+++ b/dev-libs/boost/boost-1.34.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.34_pre20061214.ebuild,v 1.4 2007/02/20 20:32:25 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.34.0.ebuild,v 1.1 2007/06/06 19:25:19 dev-zero Exp $
-inherit distutils flag-o-matic multilib toolchain-funcs versionator
+inherit distutils flag-o-matic multilib toolchain-funcs versionator check-reqs
KEYWORDS="~amd64 ~x86"
@@ -10,10 +10,10 @@ MY_P=${PN}_$(replace_all_version_separators _)
DESCRIPTION="Boost Libraries for C++"
HOMEPAGE="http://www.boost.org/"
-SRC_URI="http://dev.gentoo.org/~dev-zero/distfiles/${MY_P}.tar.bz2"
+SRC_URI="mirror://sourceforge/boost/${MY_P}.tar.bz2"
LICENSE="freedist Boost-1.0"
SLOT="0"
-IUSE="debug doc icc icu pyste tools userland_Darwin"
+IUSE="debug doc icu pyste tools userland_Darwin"
DEPEND="icu? ( >=dev-libs/icu-3.2 )
sys-libs/zlib
@@ -23,12 +23,35 @@ RDEPEND="${DEPEND}
S=${WORKDIR}/${MY_P}
+# Maintainer Information
+# ToDo:
+# - gccxml needed by pyste is broken with >=gcc-4.1.1 (bug #147976)
+# - write a patch to support /dev/urandom on FreeBSD and OSX (see below)
+
+pkg_setup() {
+ if has test ${FEATURES} ; then
+ CHECKREQS_DISK_BUILD="1024"
+ check_reqs
+
+ ewarn "The tests may take several hours on a recent machine"
+ ewarn "but they will not fail (unless something weird happens ;-)"
+ ewarn "This is because the tests depend on the used compiler/-version"
+ ewarn "and the platform and upstream says that this is normal."
+ ewarn "If you are interested in the results, please take a look at the"
+ ewarn "generated results page:"
+ ewarn " ${ROOT}usr/share/doc/${PF}/status/cs-$(uname).html"
+ ebeep 5
+
+ fi
+}
+
src_unpack() {
unpack ${A}
cd "${S}"
rm boost-build.jam
+ # This enables building the boost.random library with /dev/urandom support
if ! use userland_Darwin ; then
mkdir -p libs/random/build
cp "${FILESDIR}/random-Jamfile" libs/random/build/Jamfile.v2
@@ -38,6 +61,15 @@ src_unpack() {
generate_options() {
LINK_OPTIONS="shared static"
+ # Maintainer information:
+ # The debug-symbols=none and optimization=none
+ # are not official upstream flags but a Gentoo
+ # specific patch to make sure that all our
+ # CXXFLAGS/LDFLAGS are being respected.
+ # Using optimization=off would for example add
+ # "-O0" and override "-O2" set by the user.
+ # Please take a look at the boost-build ebuild
+ # for more infomration.
if ! use debug ; then
OPTIONS="release debug-symbols=none"
else
@@ -45,10 +77,10 @@ generate_options() {
fi
OPTIONS="${OPTIONS} optimization=none"
- OPTIONS="${OPTIONS} threading=single,multi"
use icu && OPTIONS="${OPTIONS} -sHAVE_ICU=1 -sICU_PATH=/usr"
+ OPTIONS="${OPTIONS} --user-config=${S}/user-config.jam"
}
generate_userconfig() {
@@ -56,10 +88,7 @@ generate_userconfig() {
distutils_python_version
local compiler compilerVersion compilerExecutable
- if use icc ; then
- compiler=intel-linux
- compilerExecutable=icc
- elif use userland_Darwin ; then
+ if use userland_Darwin ; then
compiler=darwin
compilerExecutable=c++
append-ldflags -ldl
@@ -69,7 +98,7 @@ generate_userconfig() {
compilerExecutable=$(tc-getCXX)
fi
- cat > "${HOME}/user-config.jam" << __EOF__
+ cat > "${S}/user-config.jam" << __EOF__
import toolset : using ;
import toolset : flags ;
using ${compiler} : ${compilerVersion} : ${compilerExecutable} : <cxxflags>"${CXXFLAGS}" <linkflags>"${LDFLAGS}" ;
@@ -85,15 +114,17 @@ src_compile() {
generate_userconfig
generate_options
+ elog "Using the following options to build: "
+ elog " ${OPTIONS}"
+
export BOOST_ROOT=${S}
export BOOST_BUILD_PATH=/usr/share/boost-build
- # Note: The line "debug-symbols=on" only adds '-g' to compiler and linker invocation
- # and prevents boost-build from stripping the libraries/binaries
for linkoption in ${LINK_OPTIONS} ; do
einfo "Building ${linkoption} libraries"
bjam ${NUMJOBS} \
${OPTIONS} \
+ threading=single,multi \
runtime-link=${linkoption} link=${linkoption} \
--prefix="${D}/usr" \
--layout=system \
@@ -110,12 +141,23 @@ src_compile() {
# We have to set optimization to -O0 or -O1 to work around a gcc-bug
# optimization=off adds -O0 to the compiler call and overwrites our settings.
bjam ${NUMJOBS} \
- release \
- debug-symbols=none \
+ release debug-symbols=none \
optimization=off \
--prefix="${D}/usr" \
- --layout=system || die "building tools failed"
+ --layout=system \
+ --user-config="${S}/user-config.jam" \
+ || die "building tools failed"
fi
+
+ if has test ${FEATURES} ; then
+ cd "${S}/tools/regression/build"
+ bjam \
+ ${OPTIONS} \
+ --prefix="${D}/usr" \
+ --layout=system \
+ || die "building regression test helpers failed"
+ fi
+
}
src_install () {
@@ -128,6 +170,7 @@ src_install () {
for linkoption in ${LINK_OPTIONS} ; do
bjam \
${OPTIONS} \
+ threading=single,multi \
runtime-link=${linkoption} link=${linkoption} \
--prefix="${D}/usr" \
--includedir="${D}/usr/include" \
@@ -162,4 +205,48 @@ src_install () {
doins -r share
fi
+ if has test ${FEATURES} ; then
+ cd "${S}/status"
+ docinto status
+ dohtml *.{html,gif} ../boost.png
+ dodoc regress.log
+ fi
+}
+
+src_test() {
+ generate_options
+
+ export BOOST_ROOT=${S}
+ export BOOST_BUILD_PATH=/usr/share/boost-build
+
+ cd "${S}/status"
+
+ # The following is largely taken from tools/regression/run_tests.sh,
+ # but adapted to our needs.
+
+ # Run the tests & write them into a file for postprocessing
+ bjam \
+ ${OPTIONS} \
+ --dump-tests 2>&1 | tee regress.log
+
+ # Postprocessing
+ cat regress.log | "${S}/dist/bin/process_jam_log" --v2
+ if test $? != 0 ; then
+ die "Postprocessing the build log failed"
+ fi
+
+ cat > "${S}/status/comment.html" <<- __EOF__
+ <p>Tests are run on a <a href="http://www.gentoo.org">Gentoo</a> system.</p>
+__EOF__
+
+ # Generate the build log html summary page
+ "${S}/dist/bin/compiler_status" --v2 \
+ --comment "${S}/status/comment.html" "${S}" \
+ cs-$(uname).html cs-$(uname)-links.html
+ if test $? != 0 ; then
+ die "Generating the build log html summary page failed"
+ fi
+
+ # And do some cosmetic fixes :)
+ sed -i -e 's|../boost.png|boost.png|' *.html
}
diff --git a/dev-libs/boost/files/digest-boost-1.34.0 b/dev-libs/boost/files/digest-boost-1.34.0
new file mode 100644
index 000000000000..792d3db7556c
--- /dev/null
+++ b/dev-libs/boost/files/digest-boost-1.34.0
@@ -0,0 +1,3 @@
+MD5 ed5b9291ffad776f8757a916e1726ad0 boost_1_34_0.tar.bz2 13021700
+RMD160 2297f8093e0b2ecb8d52dd9734f149a073136d8a boost_1_34_0.tar.bz2 13021700
+SHA256 455cb8fa41b759272768257c2e7bdc5c47ec113245dfa533f275e787a855efd2 boost_1_34_0.tar.bz2 13021700
diff --git a/dev-libs/boost/files/digest-boost-1.34_pre20061214 b/dev-libs/boost/files/digest-boost-1.34_pre20061214
deleted file mode 100644
index ed25c5f3af30..000000000000
--- a/dev-libs/boost/files/digest-boost-1.34_pre20061214
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 c2ecc5f9f12198eb7fe116a14edd65a5 boost_1_34_pre20061214.tar.bz2 12357020
-RMD160 51a96ef3dc28b4bd1d5fc3c295a4a3f874fe59fa boost_1_34_pre20061214.tar.bz2 12357020
-SHA256 4c88805afe6b47366d960d878eec8a6e0e7f40a7f9122a7d877020e9102d0e49 boost_1_34_pre20061214.tar.bz2 12357020