summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-23 10:00:31 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-23 10:00:31 +0000
commit5d5ede16951e57359bf83c837fbebc1e907a364d (patch)
tree4d93a38f707e643d0bafb56389f579c7baab654a /dev-libs
parentFixed assembly and threading issues (diff)
downloadgentoo-2-5d5ede16951e57359bf83c837fbebc1e907a364d.tar.gz
gentoo-2-5d5ede16951e57359bf83c837fbebc1e907a364d.tar.bz2
gentoo-2-5d5ede16951e57359bf83c837fbebc1e907a364d.zip
Fix autotools rebuilding, force automake 1.9 because it does not work with 1.10. Closes bug #148207.
(Portage version: 2.1.2_pre3-r6)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/cyrus-sasl/ChangeLog7
-rw-r--r--dev-libs/cyrus-sasl/cyrus-sasl-2.1.22.ebuild30
2 files changed, 15 insertions, 22 deletions
diff --git a/dev-libs/cyrus-sasl/ChangeLog b/dev-libs/cyrus-sasl/ChangeLog
index 97349b58d012..0fa572fd8dec 100644
--- a/dev-libs/cyrus-sasl/ChangeLog
+++ b/dev-libs/cyrus-sasl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/cyrus-sasl
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/ChangeLog,v 1.161 2006/10/15 09:24:06 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/ChangeLog,v 1.162 2006/10/23 10:00:31 flameeyes Exp $
+
+ 23 Oct 2006; Diego Pettenò <flameeyes@gentoo.org>
+ cyrus-sasl-2.1.22.ebuild:
+ Fix autotools rebuilding, force automake 1.9 because it does not work with
+ 1.10. Closes bug #148207.
15 Oct 2006; Bryan Østergaard <kloeri@gentoo.org>
cyrus-sasl-2.1.22.ebuild:
diff --git a/dev-libs/cyrus-sasl/cyrus-sasl-2.1.22.ebuild b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.22.ebuild
index 2e1a2fe09457..41f468799491 100644
--- a/dev-libs/cyrus-sasl/cyrus-sasl-2.1.22.ebuild
+++ b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.22.ebuild
@@ -1,8 +1,11 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/cyrus-sasl-2.1.22.ebuild,v 1.16 2006/10/15 09:24:06 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/cyrus-sasl-2.1.22.ebuild,v 1.17 2006/10/23 10:00:31 flameeyes Exp $
-inherit eutils gnuconfig flag-o-matic java-pkg multilib
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="1.9"
+
+inherit eutils gnuconfig flag-o-matic java-pkg multilib autotools
ntlm_patch=${P}-ntlm_impl-spnego.patch.gz
SASLAUTHD_CONF_VER=2.1.21
@@ -35,10 +38,7 @@ RDEPEND="berkdb? ( >=sys-libs/db-3.2 )
java? ( =virtual/jdk-1.4* )
ntlm_unsupported_patch? ( >=net-fs/samba-3.0.9 )"
DEPEND="${RDEPEND}
- >=sys-apps/sed-4
- >=sys-devel/autoconf-2.58
- sys-devel/automake
- sys-devel/libtool"
+ >=sys-apps/sed-4"
pkg_setup() {
@@ -97,21 +97,9 @@ src_unpack() {
sed -i 's:^sasldir = .*$:sasldir = $(plugindir):' "${S}"/plugins/Makefile.{am,in}
# Recreate configure.
- export WANT_AUTOCONF="2.5"
- rm -rf configure config.h.in autom4te.cache
- ebegin "Recreating configure"
- aclocal -I "${S}/cmulocal" -I "${S}/config" && autoheader && autoconf || \
- die "recreate configure failed"
- eend $?
-
- # Recreate configure in saslauthd.
- cd "${S}/saslauthd" || die "cd ${S}/saslauthd failed"
- rm -rf configure config.h.in autom4te.cache
- ebegin "Recreating configure in saslauthd"
- aclocal -I "${S}/cmulocal" -I "${S}/config" && autoheader && autoconf || \
- die "recreate configure failed"
- eend $?
-
+ cd "${S}"
+ rm "${S}/config/libtool.m4"
+ AT_M4DIR="${S}/cmulocal ${S}/config" eautoreconf
}
src_compile() {