summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-03-25 01:34:13 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-03-25 01:34:13 +0000
commit50c0248fa74e874594817e5b771df617d2663036 (patch)
tree9631e127c6b49f01c52ca2af4d427fd1c97ebc37 /dev-libs
parentVersion bump. (diff)
downloadgentoo-2-50c0248fa74e874594817e5b771df617d2663036.tar.gz
gentoo-2-50c0248fa74e874594817e5b771df617d2663036.tar.bz2
gentoo-2-50c0248fa74e874594817e5b771df617d2663036.zip
Fix testsuite processing for paludis users.
(Portage version: 2.2_rc26/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/boost/ChangeLog5
-rw-r--r--dev-libs/boost/boost-1.35.0-r2.ebuild48
2 files changed, 26 insertions, 27 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index 03ad85b1a702..5e2641dab7c4 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/boost
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.147 2009/03/24 04:51:20 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.148 2009/03/25 01:34:13 dirtyepic Exp $
+
+ 25 Mar 2009; Ryan Hill <dirtyepic@gentoo.org> boost-1.35.0-r2.ebuild:
+ Fix testsuite processing for paludis users.
24 Mar 2009; Ryan Hill <dirtyepic@gentoo.org> boost-1.35.0-r3.ebuild,
boost-1.35.0-r4.ebuild:
diff --git a/dev-libs/boost/boost-1.35.0-r2.ebuild b/dev-libs/boost/boost-1.35.0-r2.ebuild
index ac4503293591..85acf061e6cb 100644
--- a/dev-libs/boost/boost-1.35.0-r2.ebuild
+++ b/dev-libs/boost/boost-1.35.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.35.0-r2.ebuild,v 1.3 2009/03/24 04:28:27 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.35.0-r2.ebuild,v 1.4 2009/03/25 01:34:13 dirtyepic Exp $
inherit python flag-o-matic multilib toolchain-funcs versionator check-reqs
@@ -35,11 +35,11 @@ pkg_setup() {
if has test ${FEATURES} ; then
CHECKREQS_DISK_BUILD="1024"
check_reqs
- ewarn "The testsuite may take several hours to run on a modern system."
- ewarn "It is normal to see some tests failing, as some are dependent"
- ewarn "on compiler version and platform. Unless something weird"
- ewarn "happens, the ebuild should continue installing as normal."
- ewarn
+
+ ewarn "The tests may take several hours on a recent machine"
+ ewarn "but they will not fail (unless something weird happens ;-)"
+ ewarn "This is because the tests depend on the used compiler/-version"
+ ewarn "and the platform and upstream says that this is normal."
ewarn "If you are interested in the results, please take a look at the"
ewarn "generated results page:"
ewarn " ${ROOT}usr/share/doc/${PF}/status/cs-$(uname).html"
@@ -75,8 +75,10 @@ generate_options() {
# Please take a look at the boost-build ebuild
# for more information.
- OPTIONS="gentoorelease"
- use debug && OPTIONS="gentoodebug"
+ BUILDNAME="gentoorelease"
+ use debug && BUILDNAME="gentoodebug"
+
+ OPTIONS="${BUILDNAME}"
use icu && OPTIONS="${OPTIONS} -sICU_PATH=/usr"
if use expat ; then
@@ -150,17 +152,6 @@ src_compile() {
--layout=system \
|| die "building tools failed"
fi
-
- if has test ${FEATURES} ; then
- cd "${S}/tools/regression/build"
- bjam -q \
- ${OPTIONS} \
- --prefix="${D}/usr" \
- --layout=system \
- process_jam_log compiler_status \
- || die "building regression test helpers failed"
- fi
-
}
src_install () {
@@ -221,8 +212,8 @@ src_install () {
doins -r share
fi
- if has test ${FEATURES} ; then
- cd "${S}/status"
+ cd "${S}/status"
+ if [ -f regress.log ]; then
docinto status
dohtml *.{html,gif} ../boost.png
dodoc regress.log
@@ -234,6 +225,14 @@ src_test() {
export BOOST_ROOT=${S}
+ cd "${S}/tools/regression/build"
+ bjam -q \
+ ${OPTIONS} \
+ --prefix="${D}/usr" \
+ --layout=system \
+ process_jam_log compiler_status \
+ || die "building regression test helpers failed"
+
cd "${S}/status"
# Some of the test-checks seem to rely on regexps
@@ -248,10 +247,7 @@ src_test() {
--dump-tests 2>&1 | tee regress.log
# Postprocessing
- process_jam_log=$(find "${S}"/tools/regression/build/bin -name process_jam_log -print);
- compiler_status=$(find "${S}"/tools/regression/build/bin -name compiler_status -print);
-
- cat regress.log | "${process_jam_log}" --v2
+ cat regress.log | "${S}/tools/regression/build/bin/gcc-$(gcc-version)/${BUILDNAME}/process_jam_log" --v2
if test $? != 0 ; then
die "Postprocessing the build log failed"
fi
@@ -261,7 +257,7 @@ src_test() {
__EOF__
# Generate the build log html summary page
- "${compiler_status}" --v2 \
+ "${S}/tools/regression/build/bin/gcc-$(gcc-version)/${BUILDNAME}/compiler_status" --v2 \
--comment "${S}/status/comment.html" "${S}" \
cs-$(uname).html cs-$(uname)-links.html
if test $? != 0 ; then