summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2011-02-23 12:08:14 +0000
committerMike Auty <ikelos@gentoo.org>2011-02-23 12:08:14 +0000
commit5081f6cb36cb3bf6aa96a2e2873927803cc8c5d3 (patch)
tree1e4474add297cea7f3045f0adc21c6813d2bd49b /dev-libs
parent[net-wireless/wimax-tools] Add updates from git (diff)
downloadgentoo-2-5081f6cb36cb3bf6aa96a2e2873927803cc8c5d3.tar.gz
gentoo-2-5081f6cb36cb3bf6aa96a2e2873927803cc8c5d3.tar.bz2
gentoo-2-5081f6cb36cb3bf6aa96a2e2873927803cc8c5d3.zip
Version bump to 1.4.2 which has a different API and now uses proper sonaming.
(Portage version: 2.2.0_alpha25/cvs/Linux i686)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libnfc/ChangeLog9
-rw-r--r--dev-libs/libnfc/libnfc-1.4.2.ebuild31
2 files changed, 38 insertions, 2 deletions
diff --git a/dev-libs/libnfc/ChangeLog b/dev-libs/libnfc/ChangeLog
index c5fd94836c1f..51e0b647676f 100644
--- a/dev-libs/libnfc/ChangeLog
+++ b/dev-libs/libnfc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libnfc
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnfc/ChangeLog,v 1.5 2010/04/06 22:06:48 ikelos Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnfc/ChangeLog,v 1.6 2011/02/23 12:08:14 ikelos Exp $
+
+*libnfc-1.4.2 (23 Feb 2011)
+
+ 23 Feb 2011; Mike Auty <ikelos@gentoo.org> +libnfc-1.4.2.ebuild:
+ Version bump to 1.4.2 which has a different API and now uses proper sonaming.
*libnfc-1.3.4 (06 Apr 2010)
diff --git a/dev-libs/libnfc/libnfc-1.4.2.ebuild b/dev-libs/libnfc/libnfc-1.4.2.ebuild
new file mode 100644
index 000000000000..6a4ab4c87af0
--- /dev/null
+++ b/dev-libs/libnfc/libnfc-1.4.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnfc/libnfc-1.4.2.ebuild,v 1.1 2011/02/23 12:08:14 ikelos Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Near Field Communications (NFC) library"
+HOMEPAGE="http://www.libnfc.org/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc"
+
+RDEPEND="sys-apps/pcsc-lite
+ dev-libs/libusb"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+ emake || die "Failed to compile."
+ use doc && doxygen
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "Failed to install properly."
+ use doc && dohtml "${S}"/doc/html/*
+}